Speed Limit
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 17578   Accepted: 12361

Description

Bill and Ted are taking a road trip. But the odometer in their car is broken, so they don't know how many miles they have driven. Fortunately, Bill has a working stopwatch, so they can record their speed and the total time they have driven. Unfortunately, their record keeping strategy is a little odd, so they need help computing the total distance driven. You are to write a program to do this computation.

For example, if their log shows

Speed in miles perhour Total elapsed time in hours
20 2
30 6
10 7

this means they drove 2 hours at 20 miles per hour, then 6-2=4 hours
at 30 miles per hour, then 7-6=1 hour at 10 miles per hour. The
distance driven is then (2)(20) + (4)(30) + (1)(10) = 40 + 120 + 10 =
170 miles. Note that the total elapsed time is always since the
beginning of the trip, not since the previous entry in their log.

Input

The
input consists of one or more data sets. Each set starts with a line
containing an integer n, 1 <= n <= 10, followed by n pairs of
values, one pair per line. The first value in a pair, s, is the speed in
miles per hour and the second value, t, is the total elapsed time. Both
s and t are integers, 1 <= s <= 90 and 1 <= t <= 12. The
values for t are always in strictly increasing order. A value of -1 for n
signals the end of the input.

Output

For each input set, print the distance driven, followed by a space, followed by the word "miles"

Sample Input

3
20 2
30 6
10 7
2
60 1
30 5
4
15 1
25 2
30 3
10 5
-1

Sample Output

170 miles
180 miles
90 miles

Source

 
    题目分析:输入n行,每行是速度和运行总时间。  也就是说:以样例为例:运行到2小时末的时候都是20的速度,运行到6小时末的时候期间的都是30的速度,==中间4小时是30的速度
    运行到7小时末的时候是10的速度,也就是说(7-6)的1小时是10的速度,输出总的行驶距离。
    代码:

//直叙式的简单模拟题
#include <stdio.h>
#include <string.h> int main()
{
int n;
int i, j;
int a[20], b[20]; while(scanf("%d", &n)&&n!=-1)
{
for(i=0; i<n; i++)
{
scanf("%d %d", &a[i], &b[i] );
}
int ans=0, t=0; for(j=0; j<n; j++)
{
ans=ans+a[j]*(b[j]-t);
t=b[j];
}
printf("%d miles\n", ans );
}
return 0;
}

最新文章

  1. Python系统命令操作
  2. 基于FPGA的音频信号的FIR滤波(Matlab+Modelsim验证)
  3. Junit初级编码(二)探索JUnit核心
  4. Bonobo Git Server (Simple git server for Windows.) 测试备忘
  5. struts2--表单标签
  6. MySQL 设置允许远程登录
  7. 69道java Spring面试题和答案
  8. Linux读写锁的使用
  9. JavaBean个人总结
  10. PHP上传文件DEMO
  11. View的滑动冲突
  12. Hrbustoj 2266 Legendary Weights(辗转相除求最大公约数)
  13. java Swing 图片缓冲机制
  14. Socket简单实现数据交互及上传
  15. Nginx调用远程php-fpm
  16. JavaScript教程大纲
  17. k8s编排最佳实践
  18. LeetCode第二十二题-创建n对括号
  19. 织梦dedecms安全设置详情
  20. Maven包下载不下来的情况

热门文章

  1. Ionic2如何下拉刷新和上拉加载
  2. LightOJ1125 Divisible Group Sums
  3. Spring JdbcTemplate 查询方法中的RowMapper实现汇总
  4. NOIP 前夕 模板整理
  5. Codeforces891C. Envy
  6. leetcode 318. Maximum Product of Word Lengths
  7. SecureCRT 配置文件中 找密码
  8. Java常用几种加密算法
  9. Linux下使用nohup实现在后台运行程序(转)
  10. 使用MVP模式重构代码