原题链接:

pid=1501">http://acm.hdu.edu.cn/showproblem.php?pid=1501

一:原题内容

Problem Description
Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order.



For example, consider forming "tcraete" from "cat" and "tree":



String A: cat

String B: tree

String C: tcraete



As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming "catrtee" from "cat" and "tree":



String A: cat

String B: tree

String C: catrtee



Finally, notice that it is impossible to form "cttaree" from "cat" and "tree".
 
Input
The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line.



For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two
strings will have lengths between 1 and 200 characters, inclusive.

 
Output
For each data set, print:



Data set n: yes



if the third string can be formed from the first two, or



Data set n: no



if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example.
 
Sample Input
3
cat tree tcraete
cat tree catrtee
cat tree cttaree
 
Sample Output
Data set 1: yes
Data set 2: yes
Data set 3: no

二:分析理解

第三个字符串能否由前两个字符串依照原有顺序不变的原则交叉构成。须要注意的是,visit数组元素值为1时,表示该位置已被訪问过,下次无需訪问。

三:AC代码

#define _CRT_SECURE_NO_DEPRECATE
#define _CRT_SECURE_CPP_OVERLOAD_STANDARD_NAMES 1 #include<iostream>
#include<string>
#include<string.h>
using namespace std; string str1, str2, str3;
int len1, len2, len3;
bool flag;//为真时,表示能够输出“yes” int visit[201][201];//标记数组,默认都是0 void DFS(int i, int j, int k); int main()
{
int N;
cin >> N;
for (int i = 1; i <= N; i++)
{
memset(visit, 0, sizeof(visit));
flag = false;
cin >> str1 >> str2 >> str3; len1 = str1.length();
len2 = str2.length();
len3 = str3.length(); DFS(0, 0, 0); if (flag)
cout << "Data set " << i << ": " << "yes\n";
else
cout << "Data set " << i << ": " << "no\n";
} return 0;
} void DFS(int i, int j, int k)
{
if (flag || visit[i][j])//假设为真或该点已被訪问过
return; if (k == len3)//由于依据题意len1+len2=len3
{
flag = true;
return;
} visit[i][j] = 1; if (i < len1 && str1[i] == str3[k])
DFS(i + 1, j, k + 1);
if (j < len2 && str2[j] == str3[k])
DFS(i, j + 1, k + 1); }

最新文章

  1. ASP.net 页面生命周期
  2. swift language
  3. leetcode - 位运算题目汇总(下)
  4. swiper 技巧
  5. mac os 下打开FTP服务器
  6. 堡垒机 paramiko 自动登陆代码
  7. C-指针和数组的区别
  8. Java 异常 —— Bad version number in .class file
  9. Redis操作的封装类
  10. H5下拉刷新特效demo,动画流畅
  11. SecureCRT使用教程
  12. WPF - EventSetter
  13. Linux文件io--one简述
  14. windows下使用git时生成sshkey和配置
  15. python unitest基本
  16. [转]使用sklearn进行集成学习——理论
  17. 优化css选择器
  18. 使用SQL 提示优化sql
  19. FC经典游戏还原之:松鼠大作战2
  20. Java之Spring mvc详解

热门文章

  1. java 通过cookie判断是否登陆
  2. Mybatis传递多个参数的解决办法(三种)
  3. BZOJ1567 [JSOI2008]Blue Mary的战役地图(二分+二维hash)
  4. 洛谷 P1088 火星人 (全排列)
  5. root用户无法切换到cdh的hive账号上
  6. (三)ng-app的使用困惑和angularJS框架的自己主动载入
  7. [React Native] Dismiss the Keyboard in React Native
  8. php冒泡排序函数
  9. 51nod-1273: 旅行计划
  10. hdoj--1237--简单计算器(栈模拟)