Rails
Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 20000/10000K (Java/Other)
Total Submission(s) : 31   Accepted Submission(s) : 17
Problem Description
There is a famous railway station in PopPush City. Country there is incredibly hilly. The station was built in last century. Unfortunately, funds were extremely limited that time. It was possible to establish only a surface track. Moreover, it turned out that the station could be only a dead-end one (see picture) and due to lack of available space it could have only one track.

The local tradition is that every train arriving from the direction A continues in the direction B with coaches reorganized in some way. Assume that the train arriving from the direction A has N <= 1000 coaches numbered in increasing order 1, 2, ..., N. The chief for train reorganizations must know whether it is possible to marshal coaches continuing in the direction B so that their order will be a1, a2, ..., aN. Help him and write a program that decides whether it is possible to get the required order of coaches. You can assume that single coaches can be disconnected from the train before they enter the station and that they can move themselves until they are on the track in the direction B. You can also suppose that at any time there can be located as many coaches as necessary in the station. But once a coach has entered the station it cannot return to the track in the direction A and also once it has left the station in the direction B it cannot return back to the station.

Input
The input consists of blocks of lines. Each block except the last describes one train and possibly more requirements for its reorganization. In the first line of the block there is the integer N described above. In each of the next lines of the block there is a permutation of 1, 2, ..., N. The last line of the block contains just 0.

The last block consists of just one line containing 0.

Output
The output contains the lines corresponding to the lines with permutations in the input. A line of the output contains Yes if it is possible to marshal the coaches in the order required on the corresponding line of the input. Otherwise it contains No. In addition, there is one empty line after the lines corresponding to one block of the input. There is no line in the output corresponding to the last ``null'' block of the input.

Sample Input
5
1 2 3 4 5
5 4 1 2 3
0
6
6 5 4 3 2 1
0
0

Sample Output
Yes
No

Yes

#include <stdio.h>
#include <string.h>

int a[1100];
int stack[1100];
int main()
{
    int n;
    while(scanf("%d",&n),n)
    {
        int i,j,top;
        memset(a,0,sizeof(a));
        while(scanf("%d",&a[1]),a[1])
        {
            for(i=2;i<=n;i++)
            scanf("%d",&a[i]);
            memset(stack,0,sizeof(stack));
            top=1;
            for(j=1,i=1;i<=n;i++)
            {
                stack[top++]=i;
                while(j<=n&&(a[j]==stack[top-1]))
                {
                    j++;
                    --top;
                }
            }
           
            if(top==1)
            printf("Yes\n");
            else
            printf("No\n");
        }
        printf("\n");
    }
    return 0;
}

最新文章

  1. 微信小程序时代已经来临
  2. Html5三维全景
  3. js/ajax跨越访问-jsonp的原理和实例(javascript和jquery实现代码)
  4. 【现代程序设计】【homework-04】
  5. markdown2 在win10下无法预览解决方案
  6. Android得到一个闹钟在第三方
  7. mysql 大树据表update很慢
  8. mysql服务器主从数据库同步配置(转)
  9. JAVA设计模式---模板方法
  10. 「HNOI 2019」白兔之舞
  11. vi / vim 命令集合
  12. mysql 开发基础系列12 选择合适的数据类型(上)
  13. cxf与spring的整合
  14. Flutter 知识点
  15. 循环匹配出图片地址(即src属性)
  16. MySql查询最近一个月,一周,一天
  17. Python hash() 函数
  18. Hadoop框架之HDFS的shell操作
  19. on SDN
  20. 25. instr用法

热门文章

  1. PCB 内层负片散热PAD Symbols尺寸更改方法
  2. PCB CS架构(工程系统)实现单点登入方法
  3. [Apple开发者帐户帮助]六、配置应用服务(5.1)推送通知(APN):使用身份验证令牌与APN通信
  4. 如何获取&lt;a&gt;标签的Id
  5. P3368 【模板】树状数组 2(树状数组维护差分序列)
  6. 将子节点的所有父节点ID合并成一个字符串,并更新表
  7. echarts交叉关系图一
  8. csf 课件转化为wmv正常格式
  9. jQuery导航插件One-Page-Nav演示-显示命名锚记
  10. CDR如何使用钢笔工具进行完美抠图?【6&#183;18特惠倒计时!】