Probability One
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 1674   Accepted: 1151

Description

Number guessing is a popular game between elementary-school kids. Teachers encourage pupils to play the game as it enhances their arithmetic skills, logical thinking, and following-up simple procedures. We think that, most probably, you too will master in few
minutes. Here’s one example of how you too can play this game: Ask a friend to think of a number, let’s call it n0. Then:

  1. Ask your friend to compute n1 = 3 * n0 and to tell you if n1 is even or odd.
  2. If n1 is even, ask your friend to compute n2 = n1/2. If, otherwise, n1 was odd then let your friend compute n2 = (n1 + 1)/2.
  3. Now ask your friend to calculate n3 = 3 * n2.
  4. Ask your friend to tell tell you the result of n4 = n3/9. (n4 is the quotient of the division operation. In computer lingo, ’/’ is the integer-division operator.)
  5. Now you can simply reveal the original number by calculating n0 = 2 * n4 if n1 was even, or n0 = 2 * n4 + 1 otherwise.

Here’s an example that you can follow: If n0 = 37, then n1 = 111 which is odd. Now we can calculate n2 = 56, n3 = 168, and n4 = 18, which is what your friend will tell you. Doing the calculation 2 * n4 +
1 = 37 reveals n0.

Input

Your program will be tested on one or more test cases. Each test case is made of a single positive number (0 < n0 < 1,000,000). 

The last line of the input file has a single zero (which is not part of the test cases.)

Output

For each test case, print the following line: 

k. B Q 

Where k is the test case number (starting at one,) B is either ’even’ or ’odd’ (without the quotes) depending on your friend’s answer in step 1. Q is your friend’s answer to step 4.

Sample Input

37
38
0

Sample Output

1. odd 18
2. even 19

把整个过程换算完了就是把原数除以2。

代码:

#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
#include <string>
#include <cstring>
using namespace std; int main()
{
int num,i=1;
while(cin>>num)
{
if(num==0)
break;
cout<<i<<". ";
i++;
if(num%2)
cout<<"odd ";
else
cout<<"even ";
cout<<num/2<<endl;
}
return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

最新文章

  1. 【转】 jquery遍历json数组方法
  2. Objective-C 桥接模式 -- 简单实用和说明
  3. Java线程新特征——Java并发库
  4. windows7 编译boost1.54
  5. ffmpeg-20160617-git-bin.7z ffmpeg-20160626-git-bin.7z
  6. mongodb配置
  7. Asp.net MVC 视图(二)
  8. C#常见控件命名规则举例
  9. Xcode 8 新特性
  10. dbVisualizer破解
  11. 26 个 jQuery使用技巧
  12. Java 反射学习笔记
  13. UVa 108: Maximum Sum
  14. ExtJS实例1
  15. [ios 开发笔记]:一句话笔记
  16. Android Data Binding代码实践(告别findViewById)(四)
  17. Windows上使用Git托管代码到Coding
  18. python练习实例1--------给定数字组成三位数
  19. HDU 5988 Coding Contest(最小费用最大流变形)
  20. GoJS 在 vue 项目中的使用

热门文章

  1. 41和为S的连续正数序列+注意循环条件记一下这题特殊解法
  2. SPring整合Mybatis方式一
  3. 记录下spingboot连接阿里云服务器上的MySQL数据库报错
  4. BSD socket编程学习
  5. 写给java web一年左右工作经验的人
  6. 十 Servlet
  7. Net Core3.1 添加 Swagger
  8. 【LeetCode】寻找右区间
  9. phpStudy隐藏后门预警
  10. 吴裕雄 Bootstrap 前端框架开发——Bootstrap 字体图标(Glyphicons):glyphicon glyphicon-file