PAT:A1024 Palindromic Number

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.
Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (≤10​10​​) is the initial numer and K (≤100) is the maximum number of steps. The numbers are separated by a space.
Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.
Sample Input 1:

67 3

Sample Output 1:

 484
 2

Sample Input 2:

69 3

Sample Output 2:

1353
3

#include<stdio.h>
#include<string.h>
#include<algorithm>
typedef long long ll;
using namespace std;
struct bign{
    int d[1000];
    int len;
    bign(){
        memset(d,0,sizeof(d));
        len = 0;
    }
};

bign change(char str[]){     //将整数转换为bign
    bign a;
    a.len = strlen(str);
    for(int i=0;i<a.len;i++){
        a.d[i] = str[a.len-1-i] - '0';
    }
    return a;
}

bool judge(bign a){         //判断是否是回文
    for(int i=0; i <= a.len/2; i++){
        if(a.d[i] != a.d[a.len-1-i]){
            return false;
        }
    }
    return true;
}

bign add(bign a,bign b){               //高精度a+b
    bign c;
    int carry = 0;
    for(int i=0; i < a.len || i < b.len; i++){
        int temp = a.d[i] + b.d[i] + carry;
        c.d[c.len++] = temp % 10;
        carry = temp / 10;
    }
    if(carry != 0){
        c.d[c.len++] = carry;
    }
    return c;
}

void print(bign a){            //输出bign
    for(int i = a.len-1; i >= 0; i--){
        printf("%d",a.d[i]);
    }
    printf("\n");
}

int main(){
    char str[1000];
    int k,num=0;
    while(scanf("%s %d",str,&k)!=EOF){
        bign a = change(str);
        while(num<k && judge(a)==false){
            bign b = a;
            reverse(b.d,b.d+b.len);  //将字符串倒置
            a = add(a,b);
            num++;
        }
        print(a);
        printf("%d\n",num);
    }
    return 0;
}

最新文章

  1. Android异步回调中的UI同步性问题
  2. 洛谷P1595 信封问题
  3. 2 GPS utility methods
  4. 记一个奇怪的python异常处理过程
  5. Simple Chroma Key 0.1.16 图片抠像(vs2003) 无任何插件
  6. go对json的解析处理
  7. MyEclipse x.x各版本终极优化配置指南
  8. WPF中TreeView数据结构解析
  9. PHP实战开发教程
  10. Rational Rose的四种视图介绍
  11. 关于如何获取移动端 touchmove 事件中真正触摸点下方的元素
  12. Angular集成UEditor
  13. c#异步学习笔记
  14. 自动化测试基础篇--Selenium浏览器操作
  15. DOM-Element对象
  16. AngularJS中实现Model缓存
  17. video标签、audio标签
  18. java的(PO,VO,TO,BO,DAO,POJO)解释1
  19. 解决Linux SSH登录慢
  20. wp8.1 sqlite Error - Deployment optimization failed due to an assembly that&#39;s not valid.

热门文章

  1. Java中的引用类型和使用场景
  2. dbus客户端使用指南
  3. 实践篇 -- Redis客户端缓存在SpringBoot应用的探究
  4. 从零入门 Serverless | 企业级 CI/CD 工具部署 Serverless 应用的落地实践
  5. Java基础之(六):变量、运算符与JavaDoc
  6. Java(12)方法的重载
  7. BUAA_2020_软件工程_个人博客作业
  8. Asp.net Core使用EFCore+Linq进行操作
  9. rabbitmq生产者消息确认
  10. IDEA注释设置:从当前鼠标位置开始注释快捷键