1058. A+B in Hogwarts

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your
job is to write a program to compute A+B where A and B are given in the standard form of "Galleon.Sickle.Knut" (Galleon is an integer in [0, 107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:

3.2.1 10.16.27

Sample Output:

14.1.28



水题,可能唯一要注意的就是不能把所有位转换到最低位,然后对两个数相加再转换回去,因为这种方法可能会溢出。只需要从低位到高位依次相加,考虑进位即可。

#include <cstdio>
int main(void) {
int g1, s1, k1, g2, s2, k2, g3, s3, k3, t; scanf("%d.%d.%d %d.%d.%d", &g1, &s1, &k1, &g2, &s2, &k2);
k3 = (k1 + k2) % 29;
t = s1 + s2 + (k1 + k2) / 29;
s3 = t % 17;
g3 = g1 + g2 + t / 17;
printf("%d.%d.%d\n", g3, s3, k3); return 0;
}

最新文章

  1. Inode详解
  2. javascript 获取iframe中的dom
  3. 时间处理工具类DateUtils
  4. Sumsets
  5. SXT_项目
  6. magento csv导入
  7. easyui layout 收缩的bug
  8. [转载]C#对象序列化与反序列化
  9. &lt;property name=&quot;current_session_context_class&quot;&gt;thread&lt;/property&gt; 属性
  10. Javascript实现摩斯码加密解密
  11. Cocos2d-x创建新工程
  12. HTTP Authorization
  13. Ubuntu 配置Tomcat环境
  14. Web服务器压力测试一例
  15. Android消息推送的服务端
  16. Java使用反射机制优化工厂方法
  17. C:数据结构与算法之顺序表
  18. The Hungarian Abhorrence Principle
  19. python2 =&gt; python3 踩坑集合
  20. adb环境配置+常用adb命令+Logcat命令的用法+手动进行文件比对的方法+批量挪bug

热门文章

  1. 【JAVA基础】11 Scanner类
  2. 【Linux常见命令】touch命令
  3. 聊聊flink的BlobStoreService
  4. mac OS 安装淘宝npm镜像
  5. Hadoop学习笔记(二)——插件安装和使用(Hadoop Eclipse)
  6. Random Number Generator
  7. python(格式化输出)
  8. python的unittest框架中的assert断言
  9. 配置Ansible加速
  10. 学习bootstarp第一天