To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification:
Each input file contains one test case. Each case contains a positive integer N (≤1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

Output Specification:
For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line There are N accounts and no account is modified where N is the total number of accounts. However, if N is one, you must print There is 1 account and no account is modified instead.

Sample Input 1:

3
Team000003 perfectpwd
Team000001 R1spOdfa

Sample Output 1:

2
Team000002 RLsp%dfa
Team000001 R@spodfa

Sample Input 2:

1
team110 abcdefg332

Sample Output 2:

There is 1 account and no account is modified

Sample Input 3:

2
team110 abcdefg222
team220 abcdefg333

Sample Output 3:

There are 2 accounts and no account is modified

之前的题解定义了结构体,较为复杂:

 #include<cstdio>
 #include<iostream>
 #include<cstring>
 using namespace std;

struct Users{
    char num[20];
    char pass[20];
    bool flag = false;
}user[1005];
int main()

  {
    int N;
    int sum=0;
    scanf("%d",&N);
    int i,j;
    for(i=0;i<N;i++)
    {
        scanf("%s %s",user[i].num,user[i].pass);
        for( j=0;j<strlen(user[i].pass);j++)
        {
            if(user[i].flag!=true)
            {
            if(user[i].pass[j]=='1') {user[i].pass[j]='@';user[i].flag=true;break;}
            if(user[i].pass[j]=='0') {user[i].pass[j]='%';user[i].flag=true;break;}
            if(user[i].pass[j]=='l') {user[i].pass[j]='L';user[i].flag=true;break;}
            if(user[i].pass[j]=='O') {user[i].pass[j]='o';user[i].flag=true;break;}

              }
            if(user[i].flag==true)
            {
                sum++;
                break;
            }

          }
      }

    if(sum)
    {
        printf("%d",sum);
        for(int i=0;i<N;i++)
        {
            if(user[i].flag==true)
            {
            printf("\n");
            printf("%s %s",user[i].num,user[i].pass);
              }

          }
      }
      else
      {
        if(N==1)
        {
            printf("There is 1 account and no account is modified");
          }
          else
          {
            printf("There are %d accounts and no account is modified",N);
          }
      }
   } 

更好的是:

#include <iostream>
#include <vector>
using namespace std;
int main() {
         int n;
         scanf("%d", &n);
         vector<string> v;
         for(int i = 0; i < n; i++) {
                 string name, s;
                 cin >> name >> s;
                 int len = s.length(), flag = 0;
                 for(int j = 0; j < len; j++) {
                         switch(s[j]) {
                                 case '1' : s[j] = '@'; flag = 1; break;
                                 case '0' : s[j] = '%'; flag = 1; break;
                                 case 'l' : s[j] = 'L'; flag = 1; break;
                                 case 'O' : s[j] = 'o'; flag = 1; break;
                         }
                  }
         if(flag) {
                 string temp = name + " " + s;
                 v.push_back(temp);
             }
         }
         int cnt = v.size();
         if(cnt != 0) {
                 printf("%d\n", cnt);
                 for(int i = 0; i < cnt; i++)
                 cout << v[i] << endl;
         }
        else if(n == 1) {
                 printf("There is 1 account and no account is modified");
         }
        else {
                 printf("There are %d accounts and no account is modified", n);
         }
             return 0;
}

使用C++里的vectorstring组合将题目解出,省去了使用结构体的麻烦

最新文章

  1. 解析URL 获取某一个参数值
  2. yii-basic-app-2.0.5/basic/config/web.php
  3. MSSQL订阅库索引对齐
  4. ActiveX控件(MFC篇)
  5. 14款经典的MySQL客户端软件
  6. 查看Android应用签名信息
  7. Matlab梯度下降解决评分矩阵分解
  8. 集合框架Map之KeySet方法的使用
  9. 感觉tbceditor很不错,如果作者能坚持下来,非常非常看好啊
  10. 帝国cms灵动标签下常用标签
  11. Jsoup抓取、解析网页和poi存取excel综合案例——采集网站的联系人信息
  12. 云 MongoDB 优化让 LBS 服务性能提升十倍
  13. 解决VS2019中.net core WPF 暂时无法使用 Designer 的临时方法
  14. CSS3 animation 练习
  15. 修改mongodb(带仲裁节点的副本集)各机器端口
  16. Netty学习记录
  17. java 实现Word或Excel 转Pdf
  18. sudo 找不到命令 go
  19. python全栈开发知识点补充for else和while else如果不是除正常以外的其他方式退出循环,那么else语句就会被执行。
  20. python2.x下pip install mysql-python报错解决办法

热门文章

  1. git提交时设置忽略部分文件提交
  2. UVA 11235 RMQ算法
  3. JS添加、设置属性以及鼠标移入移出事件
  4. OGG实验:喂奶间隔数据表通过OGG配置同步
  5. 9.1hadoop 内置计数器、自定义枚举计数器、Streaming计数器
  6. 远程桌面,出现身份验证错误,要求的函数不正确,这可能是由于CredSSP加密Oracle修正
  7. ABP JTable如何显示序列号
  8. 数的划分(DFS、DP)
  9. HashMap的fast-fail和ConcurrentHashMap的fail-safe实例
  10. CodeForces-1100C NN and the Optical Illusion 简单数学