According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist remaining.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Merge Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0
 

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0
 

Sample Input 2:

10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6
 

Sample Output 2:

Merge Sort
1 2 3 8 4 5 7 9 0 6

题意:

给出一个序列的初始状态以及排序过程中的一种状态,判断属于那种排序方式。

思路:

刚开始是根据mooc上面老师讲的思路来做的,先判断是不是插入排序,若不是插入排序,则是归并排序。归并排序本来是想的找出当前归并段的长度(len),下次排序直接将相邻的两个len归并成一个。但是提交的时候发现有测试点过不去。于是就选择了模拟的办法,sort两个归并段。

Code:

#include<iostream>
#include<vector>
#include<algorithm> using namespace std; void Merge(vector<int> &p, vector<int> &t, int l, int r, int Rend) {
int Lend = r - 1;
int prt = l;
while (l <= Lend && r <= Rend) {
if (p[l] < p[r]) t[prt++] = p[l++];
if (p[r] < p[l]) t[prt++] = p[r++];
}
while (l <= Lend) t[prt++] = p[l++];
while (r <= Rend) t[prt++] = p[r++];
int len = 2 * (Rend - Lend);
for (int i = 0; i < len; ++i, Rend--) p[Rend] = t[Rend];
} int main() {
int n;
cin >> n; vector<int> init(n);
vector<int> part(n);
vector<int> temp(n); int t, p, q;
for (int i = 0; i < n; ++i) {
cin >> t;
init[i] = t;
}
for (int i = 0; i < n; ++i) {
cin >> t;
part[i] = t;
}
p = 1;
while (p < n && part[p] > part[p-1]) ++p;
p++;
q = p;
while (q < n && part[q] == init[q]) ++q; if (q == n) {
cout << "Insertion Sort" << endl;
sort(part.begin(), part.begin()+p);
cout << part[0];
for (int i = 1; i < n; ++i) cout << " " << part[i];
} else {
cout << "Merge Sort" << endl;
int j, k;
bool flag = false;
for (j = 1; j < n; j *= 2) {
k = j - 1;
while (k + 1 < n) {
if (part[k] < part[k+1]) k += 2 * j;
else { flag = true; break; }
}
if (flag) break;
}
for (k = 0; k <= n-2*j; k += 2*j) {
Merge(part, temp, k, k+j, k+2*j-1);
}
if (k + j < n)
Merge(part, temp, k, k+j, n); cout << part[0];
for (int i = 1; i < n; ++i) cout << " " << part[i];
} cout << endl; return 0;
}

  

骗了15分。


#include<iostream>
#include<vector>
#include<algorithm> using namespace std; int main() {
int n;
cin >> n; vector<int> init(n);
vector<int> part(n);
vector<int> temp(n); int t, p, q;
for (int i = 0; i < n; ++i) {
cin >> t;
init[i] = t;
}
for (int i = 0; i < n; ++i) {
cin >> t;
part[i] = t;
}
for (p = 0; p < n-1 && part[p] <= part[p+1]; p++);
for (q = p+1; init[q] == part[q] && q < n; q++);
if (q == n) {
cout << "Insertion Sort" << endl;
sort(part.begin(), part.begin()+p+2);
cout << part[0];
for (int i = 1; i < n; ++i) cout << " " << part[i];
} else {
cout << "Merge Sort" << endl;
int j, k = 1;
bool flag = true;
while (flag) {
flag = false;
for (int i = 0; i < n; ++i) {
if (init[i] != part[i])
flag = true;
}
k *= 2;
for (j = 0; j < n/k; ++j)
sort(init.begin()+j*k, init.begin()+(j+1)*k);
sort(init.begin()+(n/k)*k, init.end());
}
cout << init[0];
for (int i = 1; i < n; ++i)
cout << " " << init[i];
} cout << endl; return 0;
}

  

参考:

https://www.liuchuo.net/archives/1902

最新文章

  1. Mysql存储引擎比较
  2. python-基础案例
  3. 端口扫描之王——nmap入门精讲(一)
  4. Nginx SSL配置过程
  5. XibDemo
  6. cocos2dx3.2 画图方法小修改之 C++ final学习
  7. [Yii2]Unable to verify your data submission(你提交的资料无法被验证)
  8. [LeetCode] 347. Top K Frequent Elements 解题思路 - Java
  9. 使用Qt编写服务器端程序(包括Http传输服务器端)的方法
  10. UIView 中 frame, bounds, center 属性的关系
  11. Android开发之异步具体解释(二)之AsyncTask
  12. angularjs指令中的compile与link函数详解
  13. Java中 StringTokenizer 的用法
  14. 洛谷 P3102 [USACO14FEB]秘密代码Secret Code 解题报告
  15. kvm虚拟机相关
  16. 全网最详细的U盘被损坏导致一般性的软件无法修复的解决办法(必须可以)(图文详解)
  17. Struts2访问ServletAPI的三种方式
  18. 北美跨境电商平台Wish透露未来一年在华规划
  19. php 5.3新特性
  20. DiscuzX 3. 3搭建和学习

热门文章

  1. 顶级c程序员之路 基础篇 - 第一章 关键字的深度理解 number-1
  2. Python基础语法函数
  3. 浮动引发的高度塌陷问题及其解决方法(BFC相关概念及性质)
  4. nginx错误分析 `104: Connection reset by peer`
  5. POJ-1321棋盘问题(简单深搜)
  6. sanic-jwt 的使用
  7. 无限可能 | Flutter 2 重点更新一览
  8. Python--入门接口测试(1)
  9. Nacos常用配置
  10. Excel老式技术