Piggy-Bank

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 34301    Accepted Submission(s): 17010

Problem Description

Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid. 

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams.

Output

Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.".

Sample Input

3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4

Sample Output

The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.

题意

存钱罐里有一些钱(硬币)。所有硬币的重量已知,空存钱罐的质量e,装有钱的存钱罐的质量为f,有n行,每行代表一种硬币,每行的第一个数p表示硬币的面值,第二个数w表示硬币的重量。

对于给定总重量的硬币,所能得到的最少金额。如果无法恰好得到给定的重量。

思路

算是完全背包模板吧,求出来给出来的硬币的最小值,把原来的模板里的max换成了min ,对dp数组赋予一个很大的初始值(dp【0】还是0,保证所有状态都是从0转移来的)。最后判断能不能转移到f-e的状态即可

AC代码

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <math.h>
#include <limits.h>
#include <map>
#include <stack>
#include <queue>
#include <vector>
#include <set>
#include <string>
#define ll long long
#define ms(a) memset(a,0,sizeof(a))
#define pi acos(-1.0)
#define INF 0x3f3f3f3f
const double E=exp(1);
const int maxn=1e4+10;
using namespace std;
int p[maxn],w[maxn];
int dp[maxn];
int main(int argc, char const *argv[])
{
ios::sync_with_stdio(false);
int t;
cin>>t;
int n;
int e,f;
while(t--)
{
ms(p);
ms(w);
ms(dp);
cin>>e>>f;
cin>>n;
for(int i=0;i<n;i++)
cin>>p[i]>>w[i];//p->value;w->size
int res=f-e;
for(int i=1;i<maxn;i++)
dp[i]=INT_MAX/2;
for(int i=0;i<n;i++)
for(int j=w[i];j<=res;j++)
dp[j]=min(dp[j],dp[j-w[i]]+p[i]);
if(dp[res]==INT_MAX/2)
cout<<"This is impossible."<<endl;
else
cout<<"The minimum amount of money in the piggy-bank is "<<dp[res]<<"."<<endl;
}
return 0;
}

最新文章

  1. 【Python实战】Pandas:让你像写SQL一样做数据分析(二)
  2. JQuery中Ajax的操作
  3. 二十一、Java基础--------IO流之综合案例分析
  4. 2014嘉杰信息杯ACM/ICPC湖南程序设计邀请赛暨第六届湘潭市程序设计竞赛
  5. Camera
  6. asp.net 微信企业号办公系统-流程设计--流程步骤设置-策略设置
  7. Word2007插入两种页码
  8. 圆满完成平安科技Web安全与App应用安全测试培训!
  9. Qt实战之开发软件数据获取助手(eventFilter处理鼠标按下,event处理鼠标松开)
  10. prop解决一个checkbox选中后再次选中失效的问题
  11. 201521123103 《Java学习笔记》 第六周学习总结
  12. SQL Server Profiler的使用
  13. git-本地仓库和远程仓库关联
  14. boost--时间处理
  15. Codeforces828 D. High Load
  16. ueditor 使用
  17. Prometheus监控学习笔记之Prometheus不完全避坑指南
  18. Django中模型层中ORM的多表操作
  19. 【图像基础】图像不变性特征HU矩和Zernike矩
  20. Ettercap之ARP+DNS欺骗

热门文章

  1. 如何学习编程和做好DBA
  2. Codeforces 911E - Stack Sorting
  3. ubuntu系统连接windows系统
  4. thinkphp中页面中时间的默认显示
  5. 新建 ASP.NET MVC 项目快速代码
  6. Centos7 docker 常用指令
  7. sort中的比较函数compare
  8. 进程控制fork vfork,父子进程,vfork保证子进程先运行
  9. 手机端的META你知道多少
  10. selenium(五)伪造浏览器