https://pintia.cn/problem-sets/994805342720868352/problems/994805470349344768

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input

Each input file contains one test case which occupies a line containing the three decimal color values.

Output

For each test case you should output the Mars RGB value in the following format: first output "#", then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a "0" to the left.

Sample Input

15 43 71

Sample Output

#123456

代码:
#include <bits/stdc++.h>
using namespace std; const int maxn = 1e5 + 10;
char s[maxn];
char a[15] = {'0', '1', '2', '3', '4', '5', '6', '7', '8', '9', 'A', 'B', 'C'}; void num(int n) {
int cnt = 0;
if(n == 0) printf("00");
else {
while(n != 0) {
s[cnt ++] = a[n % 13];
n /= 13;
} if(cnt == 1)
printf("0%s", s);
else {
for(int i = cnt - 1; i >= 0; i --)
printf("%c", s[i]);
}
} } int main() {
int x, y, z;
scanf("%d%d%d", &x, &y, &z);
printf("#");
num(x);
num(y);
num(z);
printf("\n");
return 0;
}

  

最新文章

  1. 从express源码中探析其路由机制
  2. Java Hashtable的实现
  3. mysql 替换某个字段中的某个字符
  4. callback转Promise
  5. 深入理解java虚拟机【内存溢出实例】
  6. Nginx源码安装及调优配置
  7. the first assignment of software testing
  8. oracle8
  9. Mysql 进阶操作
  10. QT设置标签字体大小和颜色
  11. ExtJs 中的ext.date
  12. Django的分页器(paginator)
  13. 06 Django REST Framework 版本控制
  14. Linux(Ubuntu)使用日记------vim复制内容到其他应用
  15. JQuery官方学习资料(译):$ vs $()
  16. 洛谷 P1061 Jam的计数法
  17. zabbix中配置当memory剩余不足20%时触发报警
  18. 检查用户输入信息是否完整(vb.net实现)
  19. IOS-网络(AFNetworking)
  20. koa源码阅读[3]-koa-send与它的衍生(static)

热门文章

  1. python 时间time模块介绍和应用
  2. C服务程序模板
  3. openssl windows 下 编译 bat
  4. 关于NODEJS性能测试和优缺点总结
  5. WPF样式、模板、装饰器学习
  6. 2017-2018-1 20155308《信息安全技术》实验二——Windows口令破解
  7. 20155334 2016-2017-2 《Java程序设计》第三周学习总结
  8. [2016北京集训测试赛5]azelso-[概率/期望dp]
  9. MySQL入门篇(六)之mysqldump备份和恢复
  10. 转 gerrit