problem

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.

For example, 3 games' odds are given as the following:

 W    T    L
1.1 2.5 1.7
1.2 3.0 1.6
4.1 1.2 1.1
To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1*3.0*2.5*65%-1)*2 = 37.98 yuans (accurate up to 2 decimal places). Input Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L. Output For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space. Sample Input 1.1 2.5 1.7
1.2 3.0 1.6
4.1 1.2 1.1
Sample Output T T W 37.98

tip

answer

#include<bits/stdc++.h>
using namespace std; #define INF 0x3f3f3f3f float GetMax(float a, float b, float c){
return max(max(a, b),c);
} int GetStatus(float a, float b, float c){
if (a > b){
if( a > c) return 0;
else return 2;
}
if(a < b){
if( b > c) return 1;
else return 2;
}
return -1;
}
int main(){
// freopen("test.txt", "r", stdin);
float a, b, c, mul = 1;
for(int i = 0; i < 3; i++){
cin>>a>>b>>c;
mul *= GetMax(a, b, c);
switch(GetStatus(a, b, c)){
case 0: cout<<"W ";break;
case 1: cout<<"T ";break;
case 2: cout<<"L ";break;
default: return -1;
}
} cout<<fixed<<setprecision(2)<<(mul*0.65 - 1)*2;
return 0;
}

experience

  • 加快速度,这题目还要20分钟?

最新文章

  1. windows下 git配置ssh
  2. HDU 4251 The Famous ICPC Team Again 主席树
  3. 微信公开课PRO版张小龙演讲全文
  4. 一模 (4) day2
  5. 创建MySQL用户 赋予某指定库表的权限 flush privileges才能生效!!!!;@&#39;localhost&#39;授权本地,@&#39;%&#39;授权远程
  6. 策略模式(Strategey Pattern)
  7. Ajax的get和post两种请求方式区别
  8. Java进阶(十六)使用new Date()和System.currentTimeMillis()获取当前时间戳
  9. 为什么qt成为c++界面编程的第一选择
  10. Python绘制温度变化曲线
  11. python(leetcode)-66加一问题
  12. 设置SSH免密码登录
  13. YOLOv1
  14. 10. Regular Expression Matching (JAVA)
  15. numpy数组(4)-二维数组
  16. java1.8 版本改成 java1.7版本
  17. 【RabbitMQ】三种类型交换器 Fanout,Direct,Topic(转)
  18. MathExam作业
  19. Hello world(世界,你好)
  20. 【NOIP模拟题】Incr(dp)

热门文章

  1. #error#优化#Model#理解下面这句话错误所导致的错误:"传入一个对象,那么你就拥有了对象的属性"2
  2. HDU 2097 Sky数 进制转换
  3. [SDOI2010]外星千足虫 题解 高斯消元+bitset简介
  4. oracle06
  5. 动态获取UILabel的bounds
  6. cin.get()和cin.getline()之间的区别
  7. NuGet服务器搭建教程
  8. 你的组织使用了 windows defender 应用程序控制来阻止此应用
  9. No.6 selenium学习之路之下拉框Select
  10. jre安装配置!