Unix ls 

The computer company you work for is introducing a brand new computer line and is developing a new Unix-like operating system to be introduced along with the new computer. Your assignment is to write the formatter for the ls function.

Your program will eventually read input from a pipe (although for now your program will read from the input file). Input to your program will consist of a list of (F) filenames that you will sort (ascending based on the ASCII character values) and format into (C) columns based on the length (L) of the longest filename. Filenames will be between 1 and 60 (inclusive) characters in length and will be formatted into left-justified columns. The rightmost column will be the width of the longest filename and all other columns will be the width of the longest filename plus 2. There will be as many columns as will fit in 60 characters. Your program should use as few rows (R) as possible with rows being filled to capacity from left to right.

Input

The input file will contain an indefinite number of lists of filenames. Each list will begin with a line containing a single integer( ).There will then be N lines each containing one left-justifiedfilename and the entire line's contents (between 1 and 60 characters) are considered to be part of the filename. Allowable characters are alphanumeric (a to z, A to Z, and 0 to 9) and from the followingset { ._- } (not including the curly braces). There will be no illegalcharacters in any of the filenames and no line will be completely empty.

Immediately following the last filename will be the N for the next set or the end of file. You should read and format all sets in the input file.

Output

For each set of filenames you should print a line of exactly 60 dashes (-) followed by the formatted columns of filenames. The sorted filenames 1 to R will be listed down column 1; filenames R+1 to 2R listed down column 2; etc.

Sample Input

10
tiny
2short4me
very_long_file_name
shorter
size-1
size2
size3
much_longer_name
12345678.123
mid_size_name
12
Weaser
Alfalfa
Stimey
Buckwheat
Porky
Joe
Darla
Cotton
Butch
Froggy
Mrs_Crabapple
P.D.
19
Mr._French
Jody
Buffy
Sissy
Keith
Danny
Lori
Chris
Shirley
Marsha
Jan
Cindy
Carol
Mike
Greg
Peter
Bobby
Alice
Ruben

Sample Output

------------------------------------------------------------
12345678.123 size-1
2short4me size2
mid_size_name size3
much_longer_name tiny
shorter very_long_file_name
------------------------------------------------------------
Alfalfa Cotton Joe Porky
Buckwheat Darla Mrs_Crabapple Stimey
Butch Froggy P.D. Weaser
------------------------------------------------------------
Alice Chris Jan Marsha Ruben
Bobby Cindy Jody Mike Shirley
Buffy Danny Keith Mr._French Sissy
Carol Greg Lori Peter

题意:

制表输出给出的一堆单词;

制表规则:

根据所有单词中, 长度最长的一个, 决定了有几列

一行最多输出60个字符

做法及注意点:

网上挺多份代码说60会WA, 所以我听信了, 根据别人题解的建议, 用62;

然后输出的话我们可以先qsort一下, 接着, 看我AC代码吧, 怎么按列输出

AC代码:

#include<stdio.h>
#include<string.h>
#include<stdlib.h> char str[100][65]; int cmp(const void *a, const void *b) {
return strcmp((char *)a, (char *)b);
} int main() {
int N;
int row, col;
while(scanf("%d", &N) != EOF) {
getchar();
int max_l = 0;
for(int i = 0; i < N; i++) {
gets(str[i]);
if(strlen(str[i]) > max_l)
max_l = strlen(str[i]);
}
qsort(str, N, sizeof(str[0]), cmp);
printf("------------------------------------------------------------\n");
col = 62 / (max_l+2);
row = (N-1) / col+1;
for(int i = 0 ; i < row; i++) {
for(int j = 0; j < col; j++) {
int pos = j * row + i;
int len, blank;
if(pos >= N)
break;
printf("%s", str[pos]);
len = strlen(str[pos]);
blank = max_l - len;
for(int k = 0; k < blank; k++)
printf(" ");
printf(" ");
}
printf("\n");
}
}
return 0;
}

最新文章

  1. atitit.软件与sql设计模式原理与本质 大总结attialx总结v6 qc26.docx
  2. 一起学微软Power BI系列-使用技巧(2)连接Excel数据源错误解决方法
  3. python征程1.2(初识python)
  4. php字符串笔记
  5. CentOS 5系统安装Django、Apache 、mod_wsgi部署Python环境教程
  6. http 301 和 302 的区别!
  7. Struts登录
  8. 《JAVA NIO》读书笔记
  9. VC中调用COM组件的方法(转载)
  10. [Javascript] Array - Conact
  11. mysql——获取所有table名和table字段名。
  12. Mybatis+Struts2的结合:实现用户插入和查找
  13. webservice基本功能介绍
  14. UCS业务知识介绍
  15. 解决Docker安装MySQL不区分大小写问题
  16. .net实现网易云音乐下载
  17. 软件推荐----数据库数据处理Navicat Premium
  18. JQuery复习心得
  19. Spark 论文篇-RDD:一种为内存化集群计算设计的容错抽象(中英双语)
  20. AFNetworking 2.5.x 网络请求的封装

热门文章

  1. elementUI 学习入门之 Select 选择器
  2. @ControllerAdvice + @ExceptionHandler 处理 全部Controller层异常
  3. django定时任务
  4. QT学习笔记5:QMouseEvent鼠标事件简介
  5. BZOJ 2653: middle 主席树 二分
  6. HDU 4717 The Moving Points (三分)
  7. Syncovery 是目前功能最为强大的实时自动备份工具
  8. HTML5 Canvas,WebGL,CSS Shaders,GLSL的暧昧关系
  9. java异常知识点汇总
  10. Linux车载系统的开发方向