History Grading 

Background

Many problems in Computer Science involve maximizing some measure according to constraints.

Consider a history exam in which students are asked to put several historical events into chronological order. Students who order all the events correctly will receive full credit, but how should partial
credit be awarded to students who incorrectly rank one or more of the historical events?

Some possibilities for partial credit include:

  1. 1 point for each event whose rank matches its correct rank
  2. 1 point for each event in the longest (not necessarily contiguous) sequence of events which are in the correct order relative to each other.

For example, if four events are correctly ordered 1 2 3 4 then the order 1 3 2 4 would receive a score of 2 using the first method (events 1 and 4 are correctly ranked) and a score of 3 using the second
method (event sequences 1 2 4 and 1 3 4 are both in the correct order relative to each other).

In this problem you are asked to write a program to score such questions using the second method.

The Problem

Given the correct chronological order of n events  as  where  denotes
the ranking of event i in the correct chronological order and a sequence of student responses  where  denotes
the chronological rank given by the student to event i; determine the length of the longest (not necessarily contiguous) sequence of events in the student responses that are in the correct chronological order relative to each other.

The Input

The first line of the input will consist of one integer n indicating the number of events with  .
The second line will contain nintegers, indicating the correct chronological order of n events. The remaining lines will each consist of n integers with each line representing a student's chronological ordering of the n events. All
lines will contain n numbers in the range  , with each number appearing exactly once per line, and with each number separated
from other numbers on the same line by one or more spaces.

The Output

For each student ranking of events your program should print the score for that ranking. There should be one line of output for each student ranking.

Sample Input 1

4
4 2 3 1
1 3 2 4
3 2 1 4
2 3 4 1

Sample Output 1

1
2
3

Sample Input 2

10
3 1 2 4 9 5 10 6 8 7
1 2 3 4 5 6 7 8 9 10
4 7 2 3 10 6 9 1 5 8
3 1 2 4 9 5 10 6 8 7
2 10 1 3 8 4 9 5 7 6

Sample Output 2

6
5
10
9

求最长公共子序列

AC代码

#include<stdio.h>
#include<string.h> int max(int a, int b) {
if(a > b)
return a;
else
return b;
} int main() {
int l;
int t;
int num1[100]; scanf("%d", &l);
for(int i = 1; i <= l; i++) {
scanf("%d", &t);
num1[t] = i;
} int num2[100];
while(scanf("%d", &t) != EOF) {
num2[t] = 1;
for(int i = 2; i <= l; i++) {
scanf("%d", &t);
num2[t] = i;
} int dp[100][100];
memset(dp, 0, sizeof(dp)); for(int i = 1; i <= l; i++) {
for(int j = 1; j <= l; j++) {
if(num1[i] == num2[j])
dp[i][j] = dp[i-1][j-1] + 1;
else
dp[i][j] = max(dp[i-1][j], dp[i][j-1]);
}
} printf("%d\n", dp[l][l]);
} return 0;
}

最新文章

  1. Note1: windows下Python IDE(Eclipse+Pydev)
  2. 给自己的XTC820摆拍一下。
  3. MySQL 调优基础(五) Linux网络
  4. jquery-ui 的 主题 选择什么颜色? 建议使用html5 的标准进行书写, 更简洁!
  5. 模拟 POJ 2632 Crashing Robots
  6. Hadoop Oozie 学习笔记
  7. MachineKey
  8. weblogic启动报错之建域时未指定AdminServer的监听IP的引起的子节点启动故障
  9. opengl 函数
  10. java实现指定文件扫描目录
  11. linux学习小记:如何查看linux服务器的cpu数量,内核数,和cpu线程数
  12. 优酷、YouTube、Twitter及JustinTV几个视频网站的架构
  13. GoLang学习控制语句之switch
  14. 关于UITableView的黑线条
  15. java 栈和队列的模拟--java
  16. 基于Bootstrap使用jQuery实现输入框组input-group的添加与删除-改进版
  17. 自动化运维工具saltstack01 -- 之SaltStack介绍、安装与基础使用
  18. WPF界面框架的设计
  19. Shell 概述、截取字符操作等
  20. P4467 [SCOI2007]k短路

热门文章

  1. 使用srvany.exe把程序安装成windows服务
  2. 免费的二维码发布平台 http://zhifubao.masao.top:8282/assets/index.html
  3. centos dhcp获取不到ip解决方法 Bringing up interface eth0: Device eth0 does not seem to be present,delaying initialization.
  4. java基础练习 12
  5. POCO库中文编程参考指南(4)Poco::Net::IPAddress
  6. ubuntu16.04安装flash plugin
  7. leetcode-Min Cost Climbing Stairs
  8. [BZOJ4990][Usaco2017 Feb]Why Did the Cow Cross the Road II dp
  9. ubuntu for windows10设置中文
  10. 去除整站下载文件中的tppabs等冗余代码