Get Many Persimmon Trees
Time Limit:1000MS    Memory Limit:30000KB    64bit IO Format:%I64d
& %I64u

Description

Seiji Hayashi had been a professor of the Nisshinkan Samurai School in the domain of Aizu for a long time in the 18th century. In order to reward him for his meritorious career in education, Katanobu Matsudaira, the lord of the
domain of Aizu, had decided to grant him a rectangular estate within a large field in the Aizu Basin. Although the size (width and height) of the estate was strictly specified by the lord, he was allowed to choose any location for the estate in the field.
Inside the field which had also a rectangular shape, many Japanese persimmon trees, whose fruit was one of the famous products of the Aizu region known as 'Mishirazu Persimmon', were planted. Since persimmon was Hayashi's favorite fruit, he wanted to have
as many persimmon trees as possible in the estate given by the lord.

For example, in Figure 1, the entire field is a rectangular grid whose width and height are 10 and 8 respectively. Each asterisk (*) represents a place of a persimmon tree. If the specified width and height of the estate are 4 and 3 respectively, the area surrounded
by the solid line contains the most persimmon trees. Similarly, if the estate's width is 6 and its height is 4, the area surrounded by the dashed line has the most, and if the estate's width and height are 3 and 4 respectively, the area surrounded by the dotted
line contains the most persimmon trees. Note that the width and height cannot be swapped; the sizes 4 by 3 and 3 by 4 are different, as shown in Figure 1.



Figure 1: Examples of Rectangular Estates


Your task is to find the estate of a given size (width and height) that contains the largest number of persimmon trees.

Input

The input consists of multiple data sets. Each data set is given in the following format.



N

W H

x1 y1

x2 y2

...

xN yN

S T



N is the number of persimmon trees, which is a positive integer less than 500. W and H are the width and the height of the entire field respectively. You can assume that both W and H are positive integers whose values are less than 100. For each i (1 <= i <=
N), xi and yi are coordinates of the i-th persimmon tree in the grid. Note that the origin of each coordinate is 1. You can assume that 1 <= xi <= W and 1 <= yi <= H, and no two trees have the same positions. But you should not assume that the persimmon trees
are sorted in some order according to their positions. Lastly, S and T are positive integers of the width and height respectively of the estate given by the lord. You can also assume that 1 <= S <= W and 1 <= T <= H.



The end of the input is indicated by a line that solely contains a zero.

Output

For each data set, you are requested to print one line containing the maximum possible number of persimmon trees that can be included in an estate of the given size.

Sample Input

16
10 8
2 2
2 5
2 7
3 3
3 8
4 2
4 5
4 8
6 4
6 7
7 5
7 8
8 1
8 4
9 6
10 3
4 3
8
6 4
1 2
2 1
2 4
3 4
4 2
5 3
6 1
6 2
3 2
0

Sample Output

4
3

大致题意:国王所在的领地有W*H个点,当中n个点处有树, 如今领地上最多同意圈(当然能够少于)大小为S*T的矩形,问最多可圈中多少棵树?

解题思路:枚举起点,用二维树状数组求解。

枚举起点时要注意从行列从S和T開始。直到W和H为止。

用二维树状数组时。要注意update()每次更新时,c[ ] 加的是1。

AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std; const int maxn = 102;
int n, w, h, s, t;
int c[maxn][maxn]; int lowbit(int x){ return x&(-x); } void update(int x,int y){
for(int i=x; i<maxn; i+=lowbit(i))
for(int j=y; j<maxn; j+=lowbit(j))
c[i][j] ++;
} long long sum(int x, int y){
long long ans = 0;
for(int i=x; i>0; i-=lowbit(i))
for(int j=y; j>0; j-=lowbit(j))
ans += c[i][j];
return ans;
} int main(){
#ifndef ONLINE_JUDGE
freopen("in.txt", "r", stdin);
#endif
int x, y;
while(~scanf("%d", &n) && n){
scanf("%d%d", &w, &h);
memset(c,0,sizeof(c));
for(int i=1; i<=n; i++){
scanf("%d%d", &x, &y);
update(x, y);
}
scanf("%d%d", &s, &t);
long long ans = 0;
for(int i=s; i<=w; i++)      //枚举起点
for(int j=t; j<=h; j++)
ans = max(ans, sum(i, j) - sum(i-s, j) - sum(i, j-t) + sum(i-s, j-t));    //树状数组求区域和
printf("%lld\n", ans);
}
return 0;
}

最新文章

  1. MVC5 网站开发之二 创建项目
  2. 让ASP.NET Web API支持text/plain内容协商
  3. Ubuntu 改动bash
  4. let和const====均参考阮大神的es6入门
  5. android 快速创建一个新的线程
  6. Oracle笔试题库之问答题篇-总共60道
  7. Mesos+Zookeeper+Marathon+Docker分布式集群管理最佳实践
  8. vhost-user 简介
  9. Jetson TX1安装pyTorch
  10. JS 正则中的命名捕获分组
  11. [转] react-router4 + webpack Code Splitting
  12. sqlldr的用法 (这个最完整)
  13. React页面插入script
  14. python 阿狸的进阶之路(6)
  15. Android开发教程 - 使用Data Binding(一) 介绍
  16. Hibernate_day02讲义_使用Hibernate完成CRM客户管理中查询所有客户的操作
  17. SQL语句增加列、修改列类型、修改列、删除列
  18. 【Python】Java程序员学习Python(十一)— IO
  19. ALM在win7/IE8下无法浏览
  20. 【mysql】mysql统计查询count的效率优化问题

热门文章

  1. 内核request_mem_region 和 ioremap的理解【转】
  2. Kubernetes控制节点安装配置
  3. 通过过滤器和增强request对象解决get提交请求服务器端乱码。
  4. python每日一类(5):itertools模块
  5. OpenCV和Boost C++库的安装
  6. ACM阶段总结(2016.10.07-2016.11.09)
  7. ==与equals()区别
  8. 搭建负载均衡的环境(利用虚拟机上的四台centos)
  9. socket 和 webservice 的区别和比较
  10. [LOJ6277]数列分块入门 1