1007. Maximum Subsequence Sum (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1,
..., Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is
{ 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence
is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

动态规划求解最长子段和

#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <stdio.h>
#include <algorithm>
#include <math.h>
#include <queue>
#include <map>
#include <strstream>
#include <string> using namespace std;
#define MAX 10000
int dp[MAX+5];
int a;
int n;
int main()
{
int max;
int begin;
int end;
int sum;
int x;
scanf("%d",&n);
scanf("%d",&a);
sum=a;
max=a;
begin=end=a;
int s=a;
x=a;
for(int i=2;i<=n;i++)
{
scanf("%d",&a);
if(sum>=0)
sum+=a;
else
{
sum=a;
x=a;
}
if(max<sum)
{
max=sum;
begin=x;
end=a;
}
}
if(max<0)
cout<<0<<" "<<s<<" "<<a<<endl;
else
cout<<max<<" "<<begin<<" "<<end<<endl;
return 0;
}

最新文章

  1. DevExpress v16.1.5图表、Dashboard等多个控件API发生变化
  2. design philosophy
  3. 解决Gmail/GCalendar图标丢失问题
  4. netstat大量time_wait连接
  5. 使用Burpsuite破解Webshell密码
  6. 算法导论:Trie字典树
  7. 一个小面试题sql
  8. 剑指Offer12 数组奇数调整至偶数前
  9. ktv
  10. 就是一段程序,可以求出N个不等长列表中取N个元素形成的所有组合
  11. vs2012新建项目产生的问题
  12. IQueryable 和 IEnumerable
  13. shell多进程
  14. TensorFlow-谷歌深度学习库 体验一二三
  15. 金融量化分析【day110】:IPython介绍及简单操作
  16. liunx 运维知识四部分
  17. Error resolving version for plugin &#39;org.codehaus.mojo:tomcat-maven-plugin&#39;
  18. 2.7 UML状态图
  19. SQL-33 创建一个actor表,包含如下列信息
  20. 【codeforces 666E】 Forensic Examination

热门文章

  1. 参数数组(params)的用法
  2. window下安装Node.js NPM
  3. zookeeper综述
  4. [个人开发人员赚钱九]做一个日收入10元的APP!
  5. C# 版 防止 DNS 污染,获取域名真实 IP 地址
  6. 1.2.2 Loaders - 加载器
  7. [待解决]ColumnPrefixFilter 不能过滤出全部满足条件的,
  8. Error occurred whiLe getting the data source contents for the report
  9. Istio官方文档中文版
  10. shellscript