Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 36479    Accepted Submission(s): 15052

Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
 
Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 
Output
One integer per line representing the maximum of the total value (this number will be less than 231).
 
Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1
 
Sample Output
14
 
Author
Teddy
 
Source
 

AC code:

#include <iostream>
using namespace std;
int main()
{
int t,n,v,i,j;
int weight[1005],value[1005],record[1005];
cin>>t;
while(t--)
{
memset(record,0,sizeof(record));
cin>>n>>v;
for(i=0; i<n; i++)
cin>>value[i];
for(i=0; i<n; i++)
cin>>weight[i];
for(i=0; i<n; i++)
{
for(j=v;j>=weight[i]; j--)
{
if(record[j-weight[i]]+value[i]>record[j])
record[j] = record[j-weight[i]]+value[i];
}
}
cout<<record[v]<<endl;
} return 0;
}

  

最新文章

  1. Android系统中应用的安装和卸载的监听
  2. Output data in a cursor
  3. [tools]camtasia studio8.6
  4. asp.net修改web.config文件
  5. URL编码表,URL编码大全
  6. ThinkPhp之分页
  7. linux进程调度函数浅析(基于3.16-rc4)
  8. ASP.NET Web API 如何通过程序控制返回xml还是json
  9. UVAlive7141 BombX 14年上海区域赛D题 线段树+离散化
  10. 写一个Windows上的守护进程(8)获取进程路径
  11. hadoop编程小技巧(5)---自己定义输入文件格式类InputFormat
  12. nginx php mysql 集成安装包
  13. Leetcode解题-链表(2.2.0)基础类
  14. python之读取配置文件模块configparser(二)参数详解
  15. c++入门之类与内存
  16. python自学第11天-单线程并发、迭代器,序列化,获取路径
  17. 使用Topshelf管理Windows服务
  18. django csrf使用教程,解决Forbidden (403)CSRF verification failed. Request aborted.
  19. C#小技巧
  20. BarTender中每个标签提示手动输入的设置方法

热门文章

  1. spring-mybatis整合异常
  2. 安装阿里云版Linux云服务器,配置软件
  3. Element-ui组件--pagination分页
  4. h5页面苹果端浮动问题
  5. tp5.0初入
  6. B1086 就不告诉你 (15分)
  7. 统计输入任意的字符中中英文字母,空格和其他字符的个数 python
  8. [Codeforces967C]Stairs and Elevators(二分查找)
  9. 顺序链表的C风格实现
  10. ListView Viewholder的坑 线性布局的坑