Description

Starting with x and repeatedly multiplying by x, we can compute x31 with thirty multiplications:

x2 = x × xx3 = x2 × xx4 = x3 × x, …, x31 = x30 × x.

The operation of squaring can be appreciably shorten the sequence of multiplications. The following is a way to compute x31 with eight multiplications:

x2 = x × xx3 = x2 × xx6 = x3 × x3x7 = x6 × xx14 = x7 × x7x15 = x14 × xx30 = x15 × x15x31 = x30 × x.

This is not the shortest sequence of multiplications to compute x31. There are many ways with only seven multiplications. The following is one of them:

x2 = x × x, x4 = x2 × x2x8 = x4 × x4x8 = x4 × x4x10 = x8 × x2x20 = x10 × x10x30 = x20 × x10x31 = x30 × x.

If division is also available, we can find a even shorter sequence of operations. It is possible to compute x31 with six operations (five multiplications and one division):

x2 = x × xx4 = x2 × x2x8 = x4 × x4x16 = x8 × x8x32 = x16 × x16x31 = x32 ÷ x.

This is one of the most efficient ways to compute x31 if a division is as fast as a multiplication.

Your mission is to write a program to find the least number of operations to compute xn by multiplication and division starting with x for the given positive integer n. Products and quotients appearing in the sequence
should be x to a positive integer’s power. In others words, x−3, for example, should never appear.

Input

The input is a sequence of one or more lines each containing a single integer nn is positive and less than or equal to 1000. The end of the input is indicated by a zero.

Output

Your program should print the least total number of multiplications and divisions required to compute xn starting with x for the integer n. The numbers should be written each in a separate line without any superfluous
characters such as leading or trailing spaces.

Sample Input

1
31
70
91
473
512
811
953
0

Sample Output

0
6
8
9
11
9
13
12

Source

思路:用一个数组存每一次操作之后得到的数,剪下枝,迭代加深就可以。

详见代码。

#include <stdio.h>
#define max(A,B)(A>B?A:B) int n,dep,num[15]; bool dfs(int cnt,int x)//x是上一次操作之后得到的最大的数
{
if(num[cnt]==n) return 1; if(cnt>=dep) return 0; x=max(x,num[cnt]); if(x*(1<<(dep-cnt))<n) return 0;//假设最大的数都不能得到n就直接返回 for(int i=0;i<=cnt;i++)
{
num[cnt+1]=num[cnt]+num[i]; if(dfs(cnt+1,x)) return 1; if(num[cnt]>num[i]) num[cnt+1]=num[cnt]-num[i];
else num[cnt+1]=num[i]-num[cnt]; if(dfs(cnt+1,x)) return 1;
} return 0;
} int main()
{
while(~scanf("%d",&n) && n)
{
if(n==1) printf("0\n");
else
{
num[0]=1; for(dep=1;;dep++)
{
if(dfs(0,1)) break;
} printf("%d\n",dep);
}
}
}

最新文章

  1. vs 数据库链接Web.config 配置
  2. mysql5.6优化建议
  3. vbox里面的Ubuntu虚拟机与主机win7之间设置共享文件夹
  4. AssertValid函数学习
  5. POJ1087 A Plug for UNIX 【最大流】
  6. Blocks and Variables
  7. PAT (Advanced Level) 1018. Public Bike Management (30)
  8. JS——基础知识
  9. php调用js变量
  10. [转]Windows下Python多版本共存
  11. 基于Keepalived的MySQL高可用
  12. C#与C++数据类型比较及结构体转换[整理]
  13. 设置eclipse代码自动补全功能
  14. List,Set,Collection,Collections比较
  15. Poly2Tri介绍[转]
  16. vi 新建文件后保存文件时遇到的问题:E212: 无法打开并写入文件
  17. Python 装饰器学习心得
  18. C#基础笔记(第十五天)
  19. C++中的运算符重载练习题
  20. ElasticSearch搜索引擎安装配置拼音插件pinyin

热门文章

  1. 福州三中集训day4
  2. java中的3大特性之继承
  3. 【树状数组】bzoj2743 [HEOI2012]采花
  4. 【费马小定理+矩阵快速幂】HDU4549——M斐波那契数列
  5. python列表和分片
  6. vscode 使用笔记
  7. C#远程获取图片文件流的方法【很通用】
  8. linux基础-第十九单元_nfs服务
  9. uCOS-ii笔记
  10. 常用vim命令合集