Cutting Sticks 

You have to cut a wood stick into pieces. The most affordable company, The Analog Cutting Machinery, Inc. (ACM), charges money according to the length of the stick being cut. Their procedure of work requires that they only make one cut at a time.

It is easy to notice that different selections in the order of cutting can led to different prices. For example, consider a stick of length 10 meters that has to be cut at 2, 4 and 7 meters from one end. There are several choices. One can be cutting first at 2, then at 4, then at 7. This leads to a price of 10 + 8 + 6 = 24 because the first stick was of 10 meters, the resulting of 8 and the last one of 6. Another choice could be cutting at 4, then at 2, then at 7. This would lead to a price of 10 + 4 + 6 = 20, which is a better price.

Your boss trusts your computer abilities to find out the minimum cost for cutting a given stick.

Input

The input will consist of several input cases. The first line of each test case will contain a positive number  l  that represents the length of the stick to be cut. You can assume  l  < 1000. The next line will contain the number  n  ( n  < 50) of cuts to be made.

The next line consists of n positive numbers ci ( 0 < ci < l) representing the places where the cuts have to be done, given in strictly increasing order.

An input case with l = 0 will represent the end of the input.

Output

You have to print the cost of the optimal solution of the cutting problem, that is the minimum cost of cutting the given stick. Format the output as shown below.

Sample Input

100
3
25 50 75
10
4
4 5 7 8
0

Sample Output

The minimum cutting is 200.
The minimum cutting is 22.

题意:给定一段len长的木棍,有n个切割点,每个切割点切掉的花费是当前切割点所在木棍的长度,求最少的花费。

思路:这题我是把每个木棍分成已经切割好的状态,在从切割好进行复原,复原过程中用区间dp的方法记录花费。

状态转移方程为dp[i][j] = min{dp[i][k] + dp[k + 1][j] + he(当前要复原的长度)}。

代码:

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std; int len, n, strick[55], i, j, k, l, sb, sbb, dp[55][55]; int min(int a, int b) {
return a < b ? a : b;
}
int main() {
while (~scanf("%d", &len) && len) {
sbb = 0;
memset(dp, 0, sizeof(dp));
scanf("%d", &n);
for (i = 1; i <= n; i ++) {
scanf("%d", &sb);
strick[i] = sb - sbb;
sbb = sb;
}
strick[++ n] = len - sb;
for (l = 1; l < n; l ++) {
for (i = 1; i <= n - l; i ++) {
j = i + l;
int sb = 999999999;
int he = 0;
for (k = i; k <= j; k ++)
he += strick[k];
for (k = i; k < j; k ++) {
sb = min(dp[i][k] + dp[k + 1][j] + he, sb);
}
dp[i][j] = sb;
}
}
printf("The minimum cutting is %d.\n", dp[1][n]);
}
return 0;
}

最新文章

  1. 解读jQuery中extend函数
  2. #Mac技巧#如何在Mac系统上新建TXT文档,以及打开txt文稿的乱码问题如何解决
  3. webwork
  4. MD5加密(C#)
  5. Linux学习--第二波
  6. python第二步,类对象部分
  7. iOS开发之iOS7设置状态栏字体颜色
  8. win8下 msvcr100d.dll文件缺失解决方法
  9. How to change current process to background process
  10. Django Cookie 和 Sessions 应用
  11. 如何书写优雅、漂亮的SQL脚本?
  12. vue的v-model指令
  13. 关于 this 关键字的使用
  14. Hyper-V
  15. Git回滚代码到某个commit
  16. jvisualvm All-in-One Java Troubleshooting Tool
  17. Netstat Commands for Linux Network Management
  18. Oracle EBS 启动调试日志
  19. bzoj 5055: 膜法师 -- 树状数组
  20. 深入解析AsyncTask

热门文章

  1. [C#参考]主线程和子线程之间的参数传递
  2. vim vimrc
  3. R与数据分析旧笔记(十)非线性模型
  4. hdu 4545 魔法串 2013金山西山居创意游戏程序挑战赛——初赛(1)
  5. Angular form
  6. lombk在IDEA中报ClassNotFoundException错误
  7. Windows Azure 自动伸缩已内置
  8. HDU 2167 Pebbles
  9. mirantis cert
  10. linux内核源码阅读之facebook硬盘加速flashcache之四