主题链接:

http://poj.org/problem?

id=2230

Watchcow
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 6055   Accepted: 2610   Special Judge

Description

Bessie's been appointed the new watch-cow for the farm. Every night, it's her job to walk across the farm and make sure that no evildoers are doing any evil. She begins at the barn, makes her patrol, and then returns to the barn when she's done. 



If she were a more observant cow, she might be able to just walk each of M (1 <= M <= 50,000) bidirectional trails numbered 1..M between N (2 <= N <= 10,000) fields numbered 1..N on the farm once and be confident that she's seen everything she needs to see.
But since she isn't, she wants to make sure she walks down each trail exactly twice. It's also important that her two trips along each trail be in opposite directions, so that she doesn't miss the same thing twice. 



A pair of fields might be connected by more than one trail. Find a path that Bessie can follow which will meet her requirements. Such a path is guaranteed to exist.

Input

* Line 1: Two integers, N and M. 



* Lines 2..M+1: Two integers denoting a pair of fields connected by a path.

Output

* Lines 1..2M+1: A list of fields she passes through, one per line, beginning and ending with the barn at field 1. If more than one solution is possible, output any solution.

Sample Input

4 5
1 2
1 4
2 3
2 4
3 4

Sample Output

1
2
3
4
2
1
4
3
2
4
1

Hint

OUTPUT DETAILS: 



Bessie starts at 1 (barn), goes to 2, then 3, etc...

Source

[

problem_id=2230" style="text-decoration:none">Submit]   [Go Back]   [Status]  
[

problem_id=2230" style="text-decoration:none">Discuss]

题目意思:

给一幅连通无向图。求如何从点1出发,最后回到1,且每条边两个方向各走一次。

解题思路:

欧拉回路

将一条边抽象成两条有向边就可以。

代码:

//#include<CSpreadSheet.h>

#include<iostream>
#include<cmath>
#include<cstdio>
#include<sstream>
#include<cstdlib>
#include<string>
#include<string.h>
#include<cstring>
#include<algorithm>
#include<vector>
#include<map>
#include<set>
#include<stack>
#include<list>
#include<queue>
#include<ctime>
#include<bitset>
#include<cmath>
#define eps 1e-6
#define INF 0x3f3f3f3f
#define PI acos(-1.0)
#define ll __int64
#define LL long long
#define lson l,m,(rt<<1)
#define rson m+1,r,(rt<<1)|1
#define M 1000000007
//#pragma comment(linker, "/STACK:1024000000,1024000000")
using namespace std; #define Maxn 11000 int n,m;
struct Node
{
int to,id;
Node(int a,int b)
{
to=a,id=b;
}
};
vector<vector<Node> >myv;
bool vis[Maxn*10];
vector<int>ans; void dfs(int cur)
{
for(int i=0;i<myv[cur].size();i++)
{
Node ne=myv[cur][i];
if(vis[ne.id])
continue;
vis[ne.id]=true;
dfs(ne.to);
}
ans.push_back(cur); }
int main()
{
//freopen("in.txt","r",stdin);
//freopen("out.txt","w",stdout);
while(~scanf("%d%d",&n,&m))
{
myv.clear();myv.resize(n+1);
for(int i=1;i<=m;i++)
{
int a,b;
scanf("%d%d",&a,&b);
myv[a].push_back(Node(b,i*2-1));
myv[b].push_back(Node(a,i*2));
}
memset(vis,false,sizeof(vis));
ans.clear();
dfs(1);
for(int i=ans.size()-1;i>=0;i--)
printf("%d\n",ans[i]); }
return 0;
}

最新文章

  1. 一键发布ASP.NET Web安装程序
  2. php怎么判断网页是电脑访问还是手机访问
  3. C++中构造函数和析构函数调用的时机
  4. 数据持久化之CoreData
  5. libeXosip2(2-2) -- eXosip2 network API
  6. PyCrpyto windows安装使用方法
  7. HDOJ 1003 Max Sum(线性dp)
  8. 微信jssdk已无力吐槽
  9. Endnote从头开始五:修改output style(转载)
  10. bzoj 3212 Pku3468 A Simple Problem with Integers
  11. 6.3、Android Studio的CPU Monitor
  12. Ecust OJ
  13. mac上配置react-native环境run-ios/run-android命令遇到的问题
  14. Jaccard相似度在竞品分析中的应用
  15. MySQL InnoDB 行记录格式(ROW_FORMAT)
  16. Vue——轻松实现vue底部点击加载更多
  17. Python中的实例方法、classmethod和staticmethod的区别
  18. thu-learn-lib 开发小记(转)
  19. 【RAY TRACING THE REST OF YOUR LIFE 超详解】 光线追踪 3-3 蒙特卡罗 (三)
  20. 洛谷P2002消息扩散

热门文章

  1. [topcoder]TallPeople
  2. hdu4432 Sum of divisors(数论)
  3. tomcat docBase 和 path
  4. 结构体dtype_t
  5. sql 不同server間寫入數據
  6. MFC CVIew关闭时崩溃
  7. ☀【插件】iScroll
  8. c语言诊断_断言库函数#include&lt;assert.h&gt;
  9. 基于DDD的现代ASP.NET开发框架--ABP系列之2、ABP入门教程
  10. c#中字符串截取使用的方法