Problem Description

In this problem you need to make a multiply table of N * N ,just like the sample out. The element in the ith row and jth column should be the product(乘积) of i and j.

Input

The first line of input is an integer C which indicate the number of test cases.

Then C test cases follow.Each test case contains an integer N (1<=N<=9) in a line which mentioned above.

Output

For each test case, print out the multiply table.

Sample Input

2

1

4

Sample Output

1

1 2 3 4

2 4 6 8

3 6 9 12

4 8 12 16

就是输入t个数,对于每个数n,输出n*n个数。

i为1-n,j为1-n,输出i*j。

每一行最后一个输出后面没有空格啊!!!

import java.util.Scanner;

public class Main{

    public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
int t =sc.nextInt();
while(t-->0){
int n =sc.nextInt();
for(int i=1;i<=n;i++){
for(int j=1;j<=n;j++){
if(j==1){
System.out.print(i*j);
}else{
System.out.print(" "+i*j);
}
}
System.out.println();
}
}
}
}

最新文章

  1. safari cookie设置中文失败
  2. NopCommerce 在Category 显示 Store List列表
  3. Java-继承,多态练习09-22-01
  4. Ubuntu驱动摄像头
  5. 让一个小Div(子)在大Div(父)中垂直水平都居中
  6. web前端笔试题
  7. Python 的格式化字符串format函数
  8. JVM远程DEBUG(JPDA )
  9. SQL 数据类型
  10. SP687 REPEATS - Repeats
  11. php5.5.7添加pgsql,pdo_pgsql,swoole
  12. 0 ardunio processing 显示三轴数据
  13. 力扣(LeetCode)258. 各位相加
  14. Centos7防范SYN
  15. FZU 2273 Triangles 第八届福建省赛 (三角形面积交 有重边算相交)
  16. Hadoop HDFS 的 HttpFS
  17. linux内存回收机制
  18. php获取指定div内容
  19. 解决word2016鼠标每点击一下就出现一个保存的圆圈
  20. Unity3D 浅谈被忽略的Quality [转]

热门文章

  1. Java-Android 之单选按钮的运用
  2. Simple screenshot that explains the singleton invocation.
  3. 通常我们使用[NSDate date]方法得到的时间与当前时间不一致,如何解决?
  4. C# div布局
  5. Composite 模式的实现
  6. PHP~foreach遍历名单数组~有必要多次观看练习
  7. javascript原型模式理解
  8. css3 翻书效果
  9. js实现placeholder效果
  10. ThinkPHP接入支付宝支付功能