这是一道很坑爹的题,一定注意输入的两个数的大小,并且不能简单的交换,因为在最后的输出的时候还需要将原来的数按照原来的顺序和大小,这就是为什么还得开辟两个值得原因

Description

Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classification is not known
for all possible inputs.

Consider the following algorithm:


		1. 		 input n

		2. 		 print n

		3. 		 if n = 1 then STOP

		4. 		 		 if n is odd then   n <-- 3n+1

		5. 		 		 else   n <-- n/2

		6. 		 GOTO 2

Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1



It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however, for all integers n such that
0 < n < 1,000,000 (and, in fact, for many more numbers than this.)



Given an input n, it is possible to determine the number of numbers printed before the 1 is printed. For a given n this is called the cycle-length of n. In the example above, the cycle length of 22 is 16.



For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j.




Input

The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 10,000 and greater than 0.



You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j.

Output

For each pair of input integers i and j you should output i, j, and the maximum cycle length for integers between and including i and j. These three numbers should be separated by at least one space with all three numbers on one
line and with one line of output for each line of input. The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line).

Sample Input

1 10
100 200
201 210
900 1000

Sample Output

1 10 20
100 200 125
201 210 89
900 1000 174

#include<iostream>

#include <cmath>

using namespace std;

int main ()

{

 int m,n,w,j,i,max;

 while(cin>>m>>n)

 { 

  int x=m,y=n;

  if(m>n)

  { 

  int X=m;

           m=n;

     n=x;

  }

  max=-1;

  for(i=m;i<=n;i++)

  {

   j=i;

   w=0;

   while(j>1)

   {

    if(j%2!=0)

     j=3*j+1;

    else

     j=j/2;

    w++;

    //cout<<'*';

   }

     w++;

     if(max==-1)

      max=w;

     else

      if(max<w)

      max=w;

  }

 cout<<x<<' '<<y<<' '<<max<<endl;

 }

 return 0;

}

最新文章

  1. json文件
  2. Clang比 gcc/g++更人性化代码出错提示的C/C++编译器
  3. android 异步加载框架 原理完全解析
  4. 1055. The World&#39;s Richest (25)
  5. linux磁盘与文件系统的管理
  6. 根据SQL Server排序规则创建顺序GUID
  7. C++类静态成员的初始化和用法探讨
  8. 一、链接Sql Server2014提示找不到实例的问题解决方案
  9. 关于用模拟器运行百度地图API无法定位的问题 - 不能用模拟器
  10. 关于js的连续赋值
  11. TPYBoard读取芯片上的温度传感器
  12. BZOJ_1407_[Noi2002]Savage_EXGCD
  13. laravel 邮件配置
  14. 基于socket构造c/s 架构软件
  15. Java ceil() 方法
  16. 【Ray Tracing The Next Week 超详解】 光线追踪2-9
  17. Linux查找指令(阮一峰)
  18. php 关于文件夹的一些封装好的函数
  19. Python学习笔记——常量和变量
  20. CentOS mini 和 nginx 的安装和配置要点

热门文章

  1. html之head,base,meta,title
  2. window.open窗口关闭后刷新父窗口代码
  3. js 如何生成二维数组
  4. bzoj2044: 三维导弹拦截
  5. 【VB技巧】VB ListView 控件功能使用详解
  6. (C/C++) 基础问答题
  7. (WCF) WCF and Service Debug
  8. PLSQL_PLSQL调优健康检查脚本SQLHC(案例)
  9. cf 645F Cowslip Collections 组合数学 + 简单数论
  10. linux命令(4):top 命令(性能分析工具)