Description

FJ has purchased N (1 <= N <= 2000) yummy treats for the cows who get money for giving vast amounts of milk. FJ sells one treat per day and wants to maximize the money he receives over a given period time.

The treats are interesting for many reasons:

  • The treats are numbered 1..N and stored sequentially in single file in a long box that is open at both ends. On any day, FJ can retrieve one treat from either end of his stash of treats.
  • Like fine wines and delicious cheeses, the treats improve with age and command greater prices.
  • The treats are not uniform: some are better and have higher intrinsic value. Treat i has value v(i) (1 <= v(i) <= 1000).
  • Cows pay more for treats that have aged longer: a cow will pay v(i)*a for a treat of age a.

Given the values v(i) of each of the treats lined up in order of the index i in their box, what is the greatest value FJ can receive for them if he orders their sale optimally?

The first treat is sold on day 1 and has age a=1. Each subsequent day increases the age by 1.

Input

Line 1: A single integer, N

Lines 2..N+1: Line i+1 contains the value of treat v(i)

Output

Line 1: The maximum revenue FJ can achieve by selling the treats

Sample Input

5
1
3
1
5
2

Sample Output

43

Hint

Explanation of the sample:

Five treats. On the first day FJ can sell either treat #1 (value 1) or treat #5 (value 2).

FJ sells the treats (values 1, 3, 1, 5, 2) in the following order of indices: 1, 5, 2, 3, 4, making 1x1 + 2x2 + 3x3 + 4x1 + 5x5 = 43

 
题意:给出的一系列的数字,可以看成一个双向队列,每次只能从队首或者队尾出队,第n个出队就拿这个数乘以n,最后将和加起来,求最大和
思路:由里向外逆推区间
 
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std; int a[2005],dp[2005][2005]; int main()
{
int n,i,j,k,l,ans;
while(~scanf("%d",&n))
{
for(i = 1; i<=n; i++)
scanf("%d",&a[i]);
memset(dp,0,sizeof(dp));
for(i = 1; i<=n; i++)
dp[i][i] = a[i]*n;//将对角线初始化
for(l = 1; l<n; l++)
{
for(i = 1; i+l<=n; i++)
{
j = i+l;
dp[i][j] = max(dp[i+1][j]+(n-l)*a[i],dp[i][j-1]+(n-l)*a[j]);//这里是从最后出队的开始往前推,之前的初始化也是为了这里,因为只有最后出队的,i+1才会等于j。
}
}
printf("%d\n",dp[1][n]);
} return 0;
}

最新文章

  1. OD使用教程5
  2. thinkphp上传至服务器后模板无法解析原因
  3. Mac OS X 懒人版安装教程(之前的图全部挂了,所以重发了)
  4. ubuntu下Django的下载与安装(三种方法)
  5. Missing Number ——LeetCode
  6. 线段树(hdu 1754 i hate it)
  7. Tomcat--安装与部署(一)
  8. kafka 集群搭建
  9. python_如何使用生成器实现可迭代对象?
  10. 【Parallel】.Net 并行执行程序的使用心得
  11. 利用Delphi编写Socket通信程序
  12. 关于StringUtils的常用方法
  13. redis服务部署脚本
  14. Android使用binder访问service的方式(一)
  15. ubuntu 安装MySQLdb
  16. JAXB--@XmlElementWrapper注解(二)
  17. 如何批量下载bing的背景图片?
  18. Vertica7 Native Connection Load Balance
  19. linux下查看进程路径
  20. Unity Mecanim 动画系统

热门文章

  1. BearSkill实用方法之UITextField限制输入的字符数量
  2. jQuery 尺寸
  3. JAVA学习-基础知识
  4. AS3.0定义变量的访问范围
  5. iOS: 学习笔记, Swift运算符定义
  6. WPF扩展标记
  7. ASP.NET MVC轻教程 Step By Step 10——模型验证
  8. [译]36 Days of Web Testing(六)
  9. Data guard RAC配置【二】
  10. bzoj 1022: [SHOI2008]小约翰的游戏John anti_nim游戏