示例图:

其实说白了就是做线路冗余,达到热备切换。

组网需求:

楼层1和楼层2分别通过两条线路做冗余接入交换机(本示例只考虑vrrp,暂不考虑其他方面)。当其中一段链路故障时,能通过另外一条链路传输。

配置信息:

<lsw9>dis cu

#

sysname lsw9

#

vlan batch 10 20

#

stp mode stp

#

interface Ethernet0/0/2

 port link-type access

 port default vlan 10

#

interface Ethernet0/0/3

 port link-type access

 port default vlan 20

#

interface GigabitEthernet0/0/1

 port link-type trunk

 port trunk allow-pass vlan 10 20

#

interface GigabitEthernet0/0/2

 port link-type trunk

 port trunk allow-pass vlan 10 20

 stp instance 0 cost 200000000

#

return

<lsw9>

--------------------------

<lsw11>dis cu

#

sysname lsw11

#

vlan batch 30

#

stp mode stp

#

interface Ethernet0/0/2

 port link-type access

 port default vlan 30

#

interface Ethernet0/0/3

 port link-type access

 port default vlan 30

#

interface GigabitEthernet0/0/1

 port link-type trunk

 port trunk allow-pass vlan 30

 stp instance 0 cost 200000000

#

interface GigabitEthernet0/0/2

 port link-type trunk

 port trunk allow-pass vlan 30

#

return

<lsw11>

-------------------------

<lsw7>dis cu

#

sysname lsw7

#

vlan batch 10 20 30 100

#

stp mode stp

#

interface Vlanif1

#

interface Vlanif10

 description to 1 L

 ip address 10.155.10.254 255.255.255.0

 vrrp vrid 1 virtual-ip 10.155.10.252

 vrrp vrid 1 priority 120

 vrrp vrid 1 preempt-mode timer delay 20

#

interface Vlanif20

 ip address 10.155.20.254 255.255.255.0

 vrrp vrid 1 virtual-ip 10.155.20.252

 vrrp vrid 1 priority 120

 vrrp vrid 1 preempt-mode timer delay 20

#

interface Vlanif30

 description to 5 L

 ip address 10.156.40.254 255.255.255.0

 ip address 10.156.30.254 255.255.255.0 sub

 vrrp vrid 1 virtual-ip 10.156.30.252

 vrrp vrid 2 virtual-ip 10.156.40.252

 vrrp vrid 2 priority 120

 vrrp vrid 2 preempt-mode timer delay 20

#

interface Vlanif100

 ip address 10.10.10.1 255.255.255.0

#

interface MEth0/0/1

#

interface GigabitEthernet0/0/1

 port link-type access

 port default vlan 100

#

interface GigabitEthernet0/0/11

 port link-type trunk

 port trunk pvid vlan 100

 port trunk allow-pass vlan 2 to 4094

#

interface GigabitEthernet0/0/21

 port link-type trunk

 port trunk allow-pass vlan 30

#

ospf 1

 area 0.0.0.0

  network 10.10.10.0 0.0.0.255

  network 10.155.0.0 0.0.255.255

  network 10.156.0.0 0.0.255.255

#

return

--------------------------------------

<lsw8>dis cu

#

sysname lsw8

#

vlan batch 10 20 30 200

#

stp mode stp

#

interface Vlanif1

#

interface Vlanif10

 description to 1 L

 ip address 10.155.10.253 255.255.255.0

 vrrp vrid 1 virtual-ip 10.155.10.252

#

interface Vlanif20

 description to 1 L

 ip address 10.155.20.253 255.255.255.0

 vrrp vrid 1 virtual-ip 10.155.20.252

#

interface Vlanif30

 description to 5 L

 ip address 10.156.30.253 255.255.255.0

 ip address 10.156.40.253 255.255.255.0 sub

 vrrp vrid 1 virtual-ip 10.156.30.252

 vrrp vrid 1 priority 120

 vrrp vrid 1 preempt-mode timer delay 20

 vrrp vrid 2 virtual-ip 10.156.40.252

#

interface Vlanif200

 ip address 10.10.20.1 255.255.255.0

#

interface MEth0/0/1

#

interface GigabitEthernet0/0/1

#

interface GigabitEthernet0/0/2

 port link-type trunk

 port trunk allow-pass vlan 10 20

#

interface GigabitEthernet0/0/12

 port hybrid pvid vlan 200

 port hybrid tagged vlan 1 to 4094

#

interface GigabitEthernet0/0/22

 port link-type trunk

 port trunk allow-pass vlan 30

#

ospf 1

 area 0.0.0.0

  network 10.155.0.0 0.0.255.255

  network 10.156.0.0 0.0.255.255

  network 10.10.20.0 0.0.0.255

#

return

<lsw8>

-----------------

<R4>dis cu

#

sysname R4

#

stp instance 0 root primary

stp enable

#

interface GigabitEthernet0/0/1

 ip address 10.10.10.254 255.255.255.0

 stp enable

#

interface GigabitEthernet0/0/2

 ip address 10.10.20.254 255.255.255.0

 stp enable

#

interface GigabitEthernet0/0/3

 ip address 61.128.128.6 255.255.255.0

#

return

<R4>

参考:

http://www.023wg.com/kkxpz/85.html(以上内容转自此篇文章)

最新文章

  1. SharePoint 2013 工作流之使用Visio设计篇
  2. laravel5源码讲解整理
  3. 盒子模型简单理解(box-sizing)
  4. centos6.5安装lnmp环境
  5. ASP.NET MVC系列:添加视图
  6. div内的img下出现几像素的空白间距解决办法
  7. u-boot-1.1.6移植之dm9000
  8. Windows.document对象
  9. Java序列化与Hessian序列化的区别
  10. CloudStack搭建KVM环境
  11. jxl 导入excel
  12. (16)IO流之输入字节流FileInputStream和输出字节流FielOutputStream
  13. sp1是什么意思
  14. DHCP的主要知识点
  15. Django---请求、响应
  16. iOS后台运行播放无声音频 测试可行
  17. 细说java系列之反射
  18. cocosCreator 新版本的动作函数API的应用
  19. Navigator is deprecated and has been removed from this package
  20. PuTTY+Xming实现X11的ssh转发

热门文章

  1. python制作查找单词翻译的脚本
  2. CSS 实现图片灰度效果
  3. HDU 4506 小明系列故事——师兄帮帮忙(二分快速幂)
  4. HDU 2086 A=? 数学题
  5. 第11月第31天 keyboardwillshow CGAffineTransformMakeTranslation
  6. sql server查询某年某月有多少天
  7. 前端学PHP之正则表达式函数
  8. oracel回收站清理
  9. springcloud微服务架构搭建:服务调用
  10. php正则字符串提取汉字