Domino Effect
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 9335   Accepted: 2325

Description

Did you know that you can use domino bones for other things besides playing Dominoes?

Take a number of dominoes and build a row by standing them on end with only a small distance in between. If you
do it right, you can tip the first domino and cause all others to fall down in succession (this is where the phrase ``domino effect'' comes from).




While this is somewhat pointless with only a few dominoes, some people went to the opposite extreme in the early Eighties. Using millions of dominoes of different colors and materials to fill whole halls with elaborate patterns of falling dominoes, they created
(short-lived) pieces of art. In these constructions, usually not only one but several rows of dominoes were falling at the same time. As you can imagine, timing is an essential factor here.




It is now your task to write a program that, given such a system of rows formed by dominoes, computes when and where the last domino falls. The system consists of several ``key dominoes'' connected by rows of simple dominoes. When a key domino falls, all rows
connected to the domino will also start falling (except for the ones that have already fallen). When the falling rows reach other key dominoes that have not fallen yet, these other key dominoes will fall as well and set off the rows connected to them. Domino
rows may start collapsing at either end. It is even possible that a row is collapsing on both ends, in which case the last domino falling in that row is somewhere between its key dominoes. You can assume that rows fall at a uniform rate.

Input

The input file contains descriptions of several domino systems. The first line of each description contains two integers: the number n of key dominoes (1 <= n < 500) and the number m of rows between
them. The key dominoes are numbered from 1 to n. There is at most one row between any pair of key dominoes and the domino graph is connected, i.e. there is at least one way to get from a domino to any other domino by following a series of domino rows.




The following m lines each contain three integers a, b, and l, stating that there is a row between key dominoes a and b that takes l seconds to fall down from end to end.




Each system is started by tipping over key domino number 1.



The file ends with an empty system (with n = m = 0), which should not be processed.

Output

For each case output a line stating the number of the case ('System #1', 'System #2', etc.). Then output a line containing the time when the last domino falls, exact to one digit to the right of the
decimal point, and the location of the last domino falling, which is either at a key domino or between two key dominoes(in this case, output the two numbers in ascending order). Adhere to the format shown in the output sample. The test data will ensure there
is only one solution. Output a blank line after each system.

Sample Input

2 1
1 2 27
3 3
1 2 5
1 3 5
2 3 5
0 0

Sample Output

System #1
The last domino falls after 27.0 seconds, at key domino 2. System #2
The last domino falls after 7.5 seconds, between key dominoes 2 and 3.

Source

Southwestern European Regional Contest 1996



题目链接:http://poj.org/problem?id=1135



题目大意:有n张关键的多米诺骨牌,m条路。从一条路的起点到终点的牌所有倒下须要时间t。计算最后一张倒下的牌在哪。是什么时候



题目分析:两种情况:

1.最后倒下的牌就是某张关键牌,则时间为最短路中的最大值ma1

2.最后倒下的牌在某两张牌之间,则时间为到两张牌的时间加上两张牌之间牌倒下的时间除2的最大值ma2

最后比較m1和m2。若m1大则为第一种情况,否则是另外一种情况



一组例子:

4 4

1 2 5

2 4 6

1 3 5

3 4 7

0 0



答案:

The last domino falls after 11.5 seconds, between key dominoes 3 and 4.

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int const INF = 0x3fffffff;
int const MAX = 505;
int map[MAX][MAX];
int dis[MAX];
bool used[MAX];
int n, m, ca = 1; void Dijkstra(int v0)
{
memset(used, false, sizeof(used));
for(int i = 1; i <= n; i++)
dis[i] = map[v0][i];
used[v0] = true;
dis[v0] = 0;
for(int i = 0; i < n - 1; i++)
{
int u = 1, mi = INF;
for(int j = 1; j <= n; j++)
{
if(!used[j] && dis[j] < mi)
{
mi = dis[j];
u = j;
}
}
used[u] = true;
for(int k = 1; k <= n; k++)
if(!used[k] && map[u][k] < INF)
dis[k] = min(dis[k], dis[u] + map[u][k]);
}
double ma1 = -1, ma2 = -1;
int pos, pos1, pos2;
for(int i = 1; i <= n; i++)
{
if(dis[i] > ma1)
{
ma1 = dis[i];
pos = i;
}
}
for(int i = 1; i <= n; i++)
{
for(int j = 1; j <= n; j++)
{
if(map[i][j] < INF && (dis[i] + dis[j] + map[i][j]) / 2.0 > ma2)
{
ma2 = (dis[i] + dis[j] + map[i][j]) / 2.0;
pos1 = i;
pos2 = j;
}
}
}
if(ma1 < ma2)
printf("The last domino falls after %.1f seconds, between key dominoes %d and %d.\n\n", ma2, pos1, pos2);
else
printf("The last domino falls after %.1f seconds, at key domino %d.\n\n", ma1, pos); } int main()
{
while(scanf("%d %d", &n, &m) != EOF && (n + m))
{
for(int i = 1; i <= n; i++)
{
dis[i] = INF;
for(int j = 1; j <= n; j++)
map[i][j] = INF;
}
for(int i = 0; i < m; i++)
{
int u, v, w;
scanf("%d %d %d", &u, &v, &w);
map[u][v] = w;
map[v][u] = w;
}
printf("System #%d\n", ca ++);
Dijkstra(1);
}
}

最新文章

  1. DevExpress Carousel 设置水平滑动列表
  2. .jshintrc配置
  3. 【精心推荐】几款极好的 JavaScript 文件上传插件
  4. [问题2015S01] 复旦高等代数 II(14级)每周一题(第二教学周)
  5. JSBinding+SharpKit / 更新的原理
  6. 杭电1241 Oil Deposits
  7. 二叉树的前序和中序得到后序 hdu1710
  8. pm am 12小时格式化
  9. hdu4148 Length of S(n)
  10. 虎牙直播张波:掘金Nginx日志
  11. SpringBoot入门教程(二)CentOS部署SpringBoot项目从0到1
  12. 在centos上面编译安装python
  13. (2)free详解 (每周一个linux命令系列)
  14. Android典型界面设计(5)——使用SlidingMenu和DrawerLayout分别实现左右侧边栏
  15. 随机模拟(MCMC)
  16. Java-Runoob-高级教程-实例-方法:10. Java 实例 – 标签(Label)
  17. celery在Django中的集成使用
  18. SSL双向认证Java实现 Tomcat篇
  19. 面向对象 ( OO ) 的程序设计——理解对象
  20. KDevelop使用笔记【中文教程】

热门文章

  1. Laravel Model 的 fillable (白名单)与 guarded (黑名单)
  2. IE下css bug集合-翻译自haslayout.net
  3. RGBA颜色与兼容性的半透明背景色
  4. 微信隐藏的webJS Api汇总
  5. Web Sevice平台
  6. linux 时间戳
  7. 008 使用POJO对象绑定请求参数
  8. P1203 [USACO1.1]坏掉的项链Broken Necklace
  9. 001.NTP简介
  10. P4745 B’s problem(b)