转载请注明出处:http://blog.csdn.net/u012860063

题目链接:http://acm.hdu.edu.cn/showproblem.php?

pid=1027

Ignatius and the Princess II

Problem Description
Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, "I have three question for you, if
you can work them out, I will release the Princess, or you will be my dinner, too." Ignatius says confidently, "OK, at last, I will save the Princess."



"Now I will show you the first problem." feng5166 says, "Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once
in this problem). So it's easy to see the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It's easy, isn't is? Hahahahaha......"

Can you help Ignatius to solve this problem?
Input
The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub's demand. The input is terminated by the end of
file.
 
Output
For each test case, you only have to output the sequence satisfied the BEelzebub's demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number.
Sample Input
6 4
11 8

Sample Output
1 2 3 5 6 4
1 2 3 4 5 6 7 9 8 11 10

题意:给定n和m n表示1……n的数字排列。求第m个排列。

通过这题发现了STL中的神器:next_permutation(后一个)和prev_permutation(前一个)函数

依照STL文档的描写叙述,next_permutation函数将按字母表顺序生成给定序列的下一个较大的序列。直到整个序列为减序为止。prev_permutation函数与之相反。是生成给定序列的上一个较小的序列。

二者原理同样。仅遍例顺序相反

代码例如以下:



#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
#define N 1047
int num[N];
int main()
{
int n , m , i ,k;
while(~scanf("%d%d",&n,&m))
{
memset(num,0,sizeof(num));
for(i = 0 ; i < n ; i++)
{
num[i] = i+1;
}
for(i = 1 ; i < m ; i++)
{
next_permutation(num,num+n);
}
for(i = 0 ; i < n-1 ; i++)
printf("%d ",num[i]);
printf("%d\n",num[n-1]);
}
return 0;
}

最新文章

  1. 安装好oracle后,打开防火墙遇到的问题!
  2. hdu-5492 Find a path(dp)
  3. 【C#】构造函数的特点
  4. (转)java性能调优
  5. Mysql主从复制的实现
  6. 使用PowerDesigner建立数据库模型
  7. 【论文阅读】Retrieving Similar Similar Styles to Parse Clothing(相关工作)
  8. python 爬虫之爬取大街网(思路)
  9. dsp实验一 常见问题教程
  10. 【玩转开源】BananaPi R2 —— 第四篇 Openwrt Luci 初探
  11. css冲刺
  12. 清理Visual Studio 2017的项目历史记录或手工修改Visual Studio 2017的注册表设置
  13. 使用Go语言访问JSON数据(gojsonq)
  14. react之自定义react-redux的provider、connect
  15. linux 内核 内存管理 slub算法 (一) 原理
  16. .NET通用工具——正则表达式
  17. java基础-基础语法
  18. RFC 868 -- TIME Protocol
  19. 职责链模式(Chain of Responsibility)
  20. stl map一对多用法

热门文章

  1. [HihoCoder1596]Beautiful Sequence
  2. Syncthing -- 开源的云储存和同步服务工具
  3. SQLiteSpy - A fast and compact GUI database manager for SQLite
  4. blkblock工具1
  5. datagrid在MVC中的运用03-选择单行或多行
  6. 编码策略:在ios编码中一定要少写全局变量。
  7. 安装openldap
  8. Log4j按级别输出日志到不同文件配置分析
  9. [Git] 技术的热门度曲线
  10. MVC 部署在IIS7 出现的 404 错误