Description

Suppose that the fourth generation mobile phone base stations in the Tampere area operate as follows. The area is divided into squares. The squares form an S * S matrix with the rows and columns numbered from 0 to S-1. Each square contains a base station. The
number of active mobile phones inside a square can change because a phone is moved from a square to another or a phone is switched on or off. At times, each base station reports the change in the number of active phones to the main base station along with
the row and the column of the matrix. 



Write a program, which receives these reports and answers queries about the current total number of active mobile phones in any rectangle-shaped area. 

Input

The input is read from standard input as integers and the answers to the queries are written to standard output as integers. The input is encoded as follows. Each input comes on a separate line, and consists of one instruction integer and a number of parameter
integers according to the following table. 




The values will always be in range, so there is no need to check them. In particular, if A is negative, it can be assumed that it will not reduce the square value below zero. The indexing starts at 0, e.g. for a table of size 4 * 4, we have 0 <= X <= 3 and
0 <= Y <= 3. 



Table size: 1 * 1 <= S * S <= 1024 * 1024 

Cell value V at any time: 0 <= V <= 32767 

Update amount: -32768 <= A <= 32767 

No of instructions in input: 3 <= U <= 60002 

Maximum number of phones in the whole table: M= 2^30 

Output

Your program should not answer anything to lines with an instruction other than 2. If the instruction is 2, then your program is expected to answer the query by writing the answer as a single line containing a single integer to standard output.

Sample Input

0 4
1 1 2 3
2 0 0 2 2
1 1 1 2
1 1 2 -1
2 1 1 2 3
3

Sample Output

3
4

二维树状数组求和与改动,从一维能够扩展到二维。

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <set>
#include <stack>
#include <cctype>
#include <algorithm>
#define lson o<<1, l, m
#define rson o<<1|1, m+1, r
using namespace std;
typedef long long LL;
const int mod = 99999997;
const int MAX = 1000000000;
const int maxn = 100005;
int ca, s, op;
int c[1100][1100];
void add(int i, int j, int v) {
while(i <= s) {
int y = j;
while(y <= s) {
c[i][y] += v;
y += y&-y;
}
i += i&-i;
}
}
int query(int i ,int j) {
int ans = 0;
while(i > 0) {
int y = j;
while(y > 0) {
ans += c[i][y];
y -= y&-y;
}
i -= i&-i;
}
return ans;
}
int main()
{
cin >> ca >> s;
while(1) {
scanf("%d", &op);
if(op == 1) {
int a, b, v;
scanf("%d%d%d", &a, &b, &v);
add(a+1, b+1, v);
} else if(op == 2) {
int x1, x2, y1, y2;
scanf("%d%d%d%d", &x1, &y1, &x2, &y2);
int ans = query(x2+1, y2+1) + query(x1, y1) - query(x2+1, y1) - query(x1, y2+1);
printf("%d\n", ans);
} else break;
}
return 0;
}



最新文章

  1. [.NET领域驱动设计实战系列]专题一:前期准备之EF CodeFirst
  2. 黑马程序员——【Java基础】——网络编程
  3. PPTP服务器配置选项详解
  4. java.sql.SQLException: 关闭的连接 解决办法
  5. JSON.parse()和eval()区别
  6. 防范 DDoS 攻击的 15 个方法
  7. java面试笔试谈
  8. VS2012格式化插件配置备份
  9. 任意轴算法 ( Arbitrary Axis Algorithm )
  10. Java并发编程学习笔记 深入理解volatile关键字的作用
  11. android 瀑布流效果(仿蘑菇街)
  12. 1025InnoDB log file 设置多大合适
  13. 03. Redis-配置文件
  14. luogu 4145 花神游历各国 线段树/树状数组+并查集
  15. [osg]osgcallback各种回调使用的例子介绍
  16. Hadoop概念学习系列之Java调用Shell命令和脚本,致力于hadoop/spark集群(三十六)
  17. spring中关于&lt;context:component-scan&gt;的使用说明(转)
  18. CQ3
  19. 000 SpringMVC介绍
  20. mysql 多个字段 order by

热门文章

  1. JS函数调用原理($.ajax原理)
  2. Network | parity bit
  3. about乘法逆元
  4. webpack 学习笔记 03 Code Splitting
  5. DELPHI 10.2(TOKYO) FOR LINUX的兼容性说明
  6. Android Framework 记录之一
  7. js转换金额为中文大写
  8. Hibernate 3 深度解析--苏春波
  9. Unity -- 入门教程二
  10. 解决mac osx下pip安装ipython权限的问题