Unix ls

Time Limit:                                                        3000MS                           Memory Limit: Unknown   64bit IO Format:                            %lld & %llu                        

Submit                                        Status

Description

 

The computer company you work for is introducing a brand new computer line and is developing a new Unix-like operating system to be introduced along with the new computer. Your assignment is to write the formatter for thels function.

Your program will eventually read input from a pipe (although for now your program will read from the input file). Input to your program will consist of a list of (F) filenames that you will sort (ascending based on the ASCII character values) and format into (C) columns based on the length (L) of the longest filename. Filenames will be between 1 and 60 (inclusive) characters in length and will be formatted into left-justified columns. The rightmost column will be the width of the longest filename and all other columns will be the width of the longest filename plus 2. There will be as many columns as will fit in 60 characters. Your program should use as few rows (R) as possible with rows being filled to capacity from left to right.

Input

The input file will contain an indefinite number of lists of filenames. Each list will begin with a line containing a single integer ( ). There will then beN lines each containing one left-justified filename and the entire line's contents (between 1 and 60 characters) are considered to be part of the filename. Allowable characters are alphanumeric (a toz, A to Z, and 0 to 9) and from the following set{ ._- } (not including the curly braces). There will be no illegal characters in any of the filenames and no line will be completely empty.

Immediately following the last filename will be the N for the next set or the end of file. You should read and format all sets in the input file.

Output

For each set of filenames you should print a line of exactly 60 dashes (-) followed by the formatted columns of filenames. The sorted filenames 1 toR will be listed down column 1; filenames R+1 to 2R listed down column 2; etc.

Sample Input

10
tiny
2short4me
very_long_file_name
shorter
size-1
size2
size3
much_longer_name
12345678.123
mid_size_name
12
Weaser
Alfalfa
Stimey
Buckwheat
Porky
Joe
Darla
Cotton
Butch
Froggy
Mrs_Crabapple
P.D.
19
Mr._French
Jody
Buffy
Sissy
Keith
Danny
Lori
Chris
Shirley
Marsha
Jan
Cindy
Carol
Mike
Greg
Peter
Bobby
Alice
Ruben

Sample Output

------------------------------------------------------------
12345678.123 size-1
2short4me size2
mid_size_name size3
much_longer_name tiny
shorter very_long_file_name
------------------------------------------------------------
Alfalfa Cotton Joe Porky
Buckwheat Darla Mrs_Crabapple Stimey
Butch Froggy P.D. Weaser
------------------------------------------------------------
Alice Chris Jan Marsha Ruben
Bobby Cindy Jody Mike Shirley
Buffy Danny Keith Mr._French Sissy
Carol Greg Lori Peter

题意:输入N后有N段字符串,读入进行按字典序排序,然后按尽量少行数输出,每行最多60个字符,因此最大列数colum=(60-maxlen)/(maxlen+2)+1;当然maxlen最长字符串的长度,行数row=(int)(ceil( (double)t/colum) )。然后最后一列的每个字符串输出占位数为maxlen,其他为maxlen+2。题意刚开始看不懂,直接百度了。

代码:

#include<iostream>
#include<algorithm>
#include<string>
#include<cmath>
#include<cstdio>
#include<set>
#include<sstream>
#include<map>
#include<vector>
#include<iomanip>
using namespace std;
bool cmp(const string &a,const string &b)
{
return a<b;
}
int main(void)
{
int t,maxlen,colum,row;
while (cin>>t)
{
string list[1000];
maxlen=0;
for (int q=0; q<t; q++)
{
cin>>list[q];
maxlen=max(maxlen,(int)list[q].size());//计算字符串最大长度
}
sort(list,list+t,cmp);//字典序排序
colum=(60-maxlen)/(maxlen+2)+1;//计算列数
row=(int)(ceil((double)t/colum));//计算行数
cout<<"------------------------------------------------------------"<<endl;
for (int i=0; i<row; i++)//行外循环
{
for (int j=0; j<colum; j++)//列内循环
{
if(j<colum-1)
cout<<left<<setw(maxlen)<<list[j*row+i]<<" ";//不是最后一列,maxlen再多输俩空格
else
cout<<left<<setw(maxlen)<<list[j*row+i];//按maxlen输出
}
cout<<endl;
}
}
return 0;
}

最新文章

  1. CommonJS Promises/A规范
  2. C# 字符编码解码 Encoder 和Decoder
  3. SeekBar 圆角问题
  4. Digital Roots 分类: HDU 2015-06-19 22:56 13人阅读 评论(0) 收藏
  5. Section 1.4 Mother&#39;s Milk
  6. ASP.NET 中Request.QueryString 中的key
  7. oracle遍历游标
  8. iOS基础 - Copy
  9. Oracle学习的一些建议(转)
  10. Skewed Sorting
  11. asp.net权限认证:Windows认证
  12. 数据结构与算法--KMP算法查找子字符串
  13. javascript面向对象编程笔记
  14. Centos7安装OpenDCIM-19.01步骤
  15. QML学习笔记(六)- 简单计时器和定时器
  16. python全栈开发* 02 知识点汇总 * 180531
  17. golang:slice切片
  18. django框架基本介绍
  19. Django模型类之models字段类型和参数以及元数据meta
  20. BZOJ 1012--[JSOI2008]最大数maxnumber(二分&amp;单调栈)

热门文章

  1. 如何在SAP云平台的Cloud Foundry环境下添加新的Service(服务)
  2. SAP Cloud for Customer Price-计价简介
  3. UVA 1608 Non-boring sequence 不无聊的序列(分治,中途相遇)
  4. [Docker] Docker安装和简单指令
  5. PWD简介与妙用(一个免费、随时可用的Docker实验室)
  6. vue 中根据地址名称获取实际经纬度方法
  7. 禁止DataGridView控件中添加和删除行
  8. 2017乌鲁木齐网络赛 j 题
  9. WINDOWS-API:关于线程CreateThread,_beginthead(_beginthreadex),AfxBeginThread
  10. /^/m|/$/m|\b|\B|$&amp;|$`|$&#39;|变量捕获|()?|(?:pattern)|(?&lt;LABEL&gt;PATTERN)|$+{LABEL}|(|)|\g{LABEL}