Physics Experiment
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 1031   Accepted: 365   Special Judge

Description

Simon is doing a physics experiment with N identical balls with the same radius of R centimeters. Before the experiment, all N balls are fastened within a vertical tube one by one and the lowest point of the lowest ball is H meters
above the ground. At beginning of the experiment, (at second 0), the first ball is released and falls down due to the gravity. After that, the balls are released one by one in every second until all balls have been released. When a ball hits the ground, it
will bounce back with the same speed as it hits the ground. When two balls hit each other, they with exchange their velocities (both speed and direction).

Simon wants to know where are the N balls after T seconds. Can you help him?

In this problem, you can assume that the gravity is constant: g = 10 m/s2.

Input

The first line of the input contains one integer C (C ≤ 20) indicating the number of test cases. Each of the following lines contains four integers NHRT.

1≤ N ≤ 100.

1≤ H ≤ 10000

1≤ R ≤ 100

1≤ T ≤ 10000

Output

For each test case, your program should output N real numbers indicating the height in meters of the lowest point of each ball separated by a single space in a single line. Each number should be rounded to 2 digit after the decimal point.

Sample Input

2
1 10 10 100
2 10 10 100

Sample Output

4.95
4.95 10.20

Source

/*
** Problem: POJ3684
** Status: Accepted
** Running Time: 0ms
** Author: Changmu
**
** 题意:算是我的第一道物理题吧,题意是N个球叠放在一起,每隔一秒最下边的球
** 就掉落下来,给定最以下球的底的高度,求T秒后每一个球的底的离地高度,g=10m/s^2.
**
** 题解:因为碰撞时两个球的速度交换了。实际上能够看做两个球互相穿越了彼此。但
** 又因为球的顺序不会变。所以求得的结果排序后就是答案。
*/ #include <stdio.h>
#include <string.h>
#include <math.h>
#include <algorithm> #define maxn 105
const double g = 10.0; int N, H, R, T;
double Y[maxn]; double cal(int k) {
if(k < 0) return H;
double t = (double)sqrt(2.0 * H / g);
int m = (int)(k / t);
if(m & 1) {
double t1 = (m + 1) * t - k;
return H - g * t1 * t1 / 2;
} else {
double t1 = k - m * t;
return H - g * t1 * t1 / 2;
}
} int main() {
int t, i;
scanf("%d", &t);
while(t--) {
scanf("%d%d%d%d", &N, &H, &R, &T);
for(i = 0; i < N; ++i)
Y[i] = cal(T - i);
std::sort(Y, Y + N);
for(i = 0; i < N; ++i)
printf("%.2lf%c", Y[i] + 2.0*R*i/100.0, i==N-1?'\n':' ');
}
return 0;
}

最新文章

  1. POJ 1061
  2. 更改 Skype for Business Online 的 Sip 地址以匹配UPN
  3. [转]asp.net的ajax以及json
  4. NSArray和NSMutableArray
  5. Spring AOP基础知识
  6. struts使用html:file上传文件的时候文件名乱码解决
  7. winpcap 发送接收速率
  8. 【JSP实例】指定用户计数器
  9. Selenuim+Python之元素定位总结及实例说明
  10. ubuntu 14.04 中找不到 libgtk-x11-2.0.so
  11. Windows系统重装
  12. js到底new了点啥
  13. const 成员函数
  14. 移动应用滑动屏幕方向判断解决方案,JS判断手势方向
  15. Flask中的模板语言jinja2
  16. 深入浅出js中的this
  17. GLOBAL_NAMES参数研究
  18. 【图片下载-代码】java下载网络图片资源例子
  19. (高精度运算4.7.24)UVA 10013 Super long sums(大数加法——某一位的数字可能大于10)
  20. CentOS&amp;.NET Core初试系列

热门文章

  1. nodejs-安装及卸载
  2. cogs 1164. 跑步
  3. mongodb 学习笔记 07 -- 数据备份、恢复
  4. 编程算法 - 求1+2+...+n(模板类) 代码(C++)
  5. EntboostChat 0.9(越狱版)公布,iOS免费企业IM
  6. ubuntu12.04安装翻译软件stardict及卸载
  7. NAT配置
  8. 最大似然估计的缺陷 —— 方差和均值的 bias
  9. ROS集成开发环境RoboWare Studio安装教程
  10. 转:Eclipse上安装GIT插件EGit及使用