A+B Problem II
时间限制:3000 ms  |  内存限制:65535 KB
难度:3
描述
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

A,B must be positive.

输入
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
输出
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation.
样例输入
2
1 2
112233445566778899 998877665544332211
样例输出
Case 1:
1 + 2 = 3
Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

#include <stdio.h>
#include <string.h>
#define MAX_LEN 1000
int an1[MAX_LEN+100];
int an2[MAX_LEN+100];
char str1[MAX_LEN+100];
char str2[MAX_LEN+100];
int main()
{
 int k,N;
 scanf("%d",&N);
 for(k=1;k<=N;k++)
 {  
  int i,j,len1,len2;
  memset(an1,0,sizeof(an1));
  memset(an2,0,sizeof(an2));
  scanf("%s%s",str1,str2);
  len1=strlen(str1);
  for(j=0,i=len1-1;i>=0;i--)
  an1[j++]=str1[i]-'0';
  len2=strlen(str2);
  for(j=0,i=len2-1;i>=0;i--)
  an2[j++]=str2[i]-'0';
  for(i=0;i<MAX_LEN;i++)
  {
  an1[i]+=an2[i];
  if(an1[i]>=10)
  {
   an1[i]-=10;
   an1[i+1]++;
  }
  }
  printf("Case %d:\n",k);
  printf("%s + %s = ",str1,str2);
  for(i=MAX_LEN+100;(i>=0)&&(an1[i]==0);i--);
  if(i>=0)
  for(;i>=0;i--)
  printf("%d",an1[i]);
  else
  printf("0");
  printf("\n");
 }
 return 0;
}

hdu_1002_A+BII_bignum_201307291100

#include <stdio.h>
#include <string.h>
#define MAX_LEN 1000
int an1[MAX_LEN+100];
int an2[MAX_LEN+100];
char str1[MAX_LEN+100];
char str2[MAX_LEN+100];
int main()
{
 int k,N,t=0;
 scanf("%d",&N);
 for(k=1;k<=N;k++)
 {  
  int i,j,len1,len2;
  memset(an1,0,sizeof(an1));
  memset(an2,0,sizeof(an2));
  scanf("%s%s",str1,str2);
  len1=strlen(str1);
  for(j=0,i=len1-1;i>=0;i--)
  an1[j++]=str1[i]-'0';
  len2=strlen(str2);
  for(j=0,i=len2-1;i>=0;i--)
  an2[j++]=str2[i]-'0';
  for(i=0;i<MAX_LEN;i++)
  {
  an1[i]+=an2[i];
  if(an1[i]>=10)
  {
   an1[i]-=10;
   an1[i+1]++;
  }
  }
  printf(t++?"\nCase %d:\n":"Case %d:\n",k);
  printf("%s + %s = ",str1,str2);
  for(i=MAX_LEN+100;(i>0)&&(an1[i]==0);i--);  
  for(;i>=0;i--)
  printf("%d",an1[i]);
  printf("\n");
 }
 return 0;
}

较之上个程序有所修改,输出部分有所简化

最新文章

  1. AngularJS下对数组的比较
  2. 1、IOS开发--iPad之仿制QQ空间(登录界面搭建+登录逻辑实现)
  3. #316 div.2
  4. 2.5.4 使用popupWindow
  5. 编码规范(HTML)
  6. MSSQL 字符串XML 合成列
  7. JavaScript基础学习(二)&mdash;JavaScript基本概念
  8. Microsoft Visual Studio调试监视器(MSVSMON.EXE)未能启动
  9. Spring怎么引入多个xml配置文件
  10. 【worker】js中的多线程
  11. 向redis中添加删除list列表
  12. python基础一 -------如何在列表字典集合中根据条件筛选数据
  13. Python操作redis系列之 列表(list) (五)(转)
  14. IO流_PrintWriter(字符打印流)与PrintStream(字节打印流)
  15. LeetCode67.二进制求和
  16. 20145320 《网络渗透》MSF基础应用
  17. THML DOM / Element 对象操作
  18. android textview settext卡顿深层次原因
  19. 9、Android---UI---Material Design
  20. Markdown中添加数学公式

热门文章

  1. C语言/C++中如何产生随机数
  2. android recovery 主系统代码分析【转】
  3. C# 操作 INI 自己工作笔记(对文本框的操作)
  4. bzoj 3598 [ Scoi 2014 ] 方伯伯的商场之旅 ——数位DP
  5. 99.ext afteredit事件详解
  6. 84. ExtJS下页面显示中文乱码问题
  7. img标签间距问题
  8. mysql出错代码
  9. poj3071Football(概率期望dp)
  10. POJ 3253 STL优先队列