A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food. 

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. 

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked. 

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

Input

The input file will contain one or more test cases. The first line of each test case contains an integer n, 

representing the number of different blocks in the following data set. The maximum value for n is 30. 

Each of the next n lines contains three integers representing the values xi, yi and zi. 

Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".

Sample Input

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

Sample Output

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

题解:对于箱子的摆放方式进行枚举,每次6种,计算他们的面积,然后按照面积由小到大排序,然后在dp的时候需要找i之前最优的,条件是i的长和宽都必须严格大于前面的,然后遍历一次找出最大高度即可(滚去写数电!!!)

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm> using namespace std; struct node
{
int a;
int b;
int c;
int s;
}r[20005];
bool cmp(node x,node y)
{ return x.s<y.s; }
int main()
{
int cnt=1,n,k,l,w,h,dp[20005],temp;
while(scanf("%d",&n)!=EOF&&n)
{ memset(dp,0,sizeof(dp));
k=1;
for(int i=1;i<=n;i++)
{
scanf("%d%d%d",&l,&w,&h);
r[k].a=l;r[k].b=w;r[k].c=h;r[k].s=r[k].a*r[k].b;
k++;
r[k].a=w;r[k].b=l;r[k].c=h;r[k].s=r[k].a*r[k].b;
k++;
r[k].a=h;r[k].b=l;r[k].c=w;r[k].s=r[k].a*r[k].b;
k++;
r[k].a=h;r[k].b=w;r[k].c=l;r[k].s=r[k].a*r[k].b;
k++;
r[k].a=l;r[k].b=h;r[k].c=w;r[k].s=r[k].a*r[k].b;
k++;
r[k].a=w;r[k].b=h;r[k].c=l;r[k].s=r[k].a*r[k].b;
k++;
}
sort(r+1,r+k,cmp);
dp[1]=r[1].c;
for(int i=1;i<k;i++)
{
temp=0;
for(int j=1;j<i;j++)
if(r[i].a>r[j].a&&r[i].b>r[j].b)
temp=max(temp,dp[j]);
dp[i]=temp+r[i].c;
}
int max=0;
for(int i=1;i<k;i++)
if(max<dp[i])
max=dp[i];
printf("Case %d: maximum height = %d\n",cnt++,max);
}
return 0;
}

最新文章

  1. performSelector和performSelectorInBackground
  2. 职工工资管理系统 --C语言
  3. 在Web大作业——红十字会管理系统里出现的一个Error
  4. Python操作Excel之xlrd
  5. 解决内网主机ping不通网关能ping内网
  6. UITableView &amp; UITableViewController
  7. 开源入侵检测系统OSSEC搭建之二:客户端安装
  8. iOS开发--使用RSA加密
  9. hibernate的formula如何使用
  10. treap启发式合并
  11. C++ —— 笔记汇总
  12. hibernate学习笔记(1)hibernate基本步骤
  13. C# 通过扩展WebBrowser捕获网络连接错误信息
  14. jquery $.getJSON()跨域请求
  15. 【笔记】归纳js getcomputedStyle, currentStyle 以及其相关用法
  16. Eclipse将引用了第三方jar包的Java项目打包成jar文件
  17. Python中if __name__==&quot;__main__&quot; 语句在调用多进程Process过程中的作用分析
  18. Git管理工具对比(GitBash、EGit、SourceTree)
  19. oracle 删除表空间TABLESPACE步骤及注意项
  20. Elasticsearch 关键字与SQL关键字对比总结

热门文章

  1. 调用thrift出现No handlers could be found for logger &quot;thrift.transport.TSocket&quot;
  2. ubuntu apt-get 安装找不到包问题
  3. QWebEngineView简单使用
  4. 002_go语言的值类型
  5. effectivejava(破坏单例)
  6. Linux内核之 内核同步
  7. CC协议是怎么一回事?
  8. 方便c号
  9. ES6中的变量的解构赋值, 解放我们的双手,实现变量的批量赋值
  10. java泛型笔记