Web Navigation
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 30828   Accepted: 13821

Description

Standard web browsers contain features to move backward and forward among the pages recently visited. One way to implement these features is to use two stacks to keep track of the pages that can be reached by moving backward and forward. In this problem, you
are asked to implement this. 

The following commands need to be supported: 

BACK: Push the current page on the top of the forward stack. Pop the page from the top of the backward stack, making it the new current page. If the backward stack is empty, the command is ignored. 

FORWARD: Push the current page on the top of the backward stack. Pop the page from the top of the forward stack, making it the new current page. If the forward stack is empty, the command is ignored. 

VISIT : Push the current page on the top of the backward stack, and make the URL specified the new current page. The forward stack is emptied. 

QUIT: Quit the browser. 

Assume that the browser initially loads the web page at the URL http://www.acm.org/

Input

Input is a sequence of commands. The command keywords BACK, FORWARD, VISIT, and QUIT are all in uppercase. URLs have no whitespace and have at most 70 characters. You may assume that no problem instance requires more than 100 elements in each stack at any time.
The end of input is indicated by the QUIT command.

Output

For each command other than QUIT, print the URL of the current page after the command is executed if the command is not ignored. Otherwise, print "Ignored". The output for each command should be printed on its own line. No output is produced for the QUIT command.

Sample Input

VISIT http://acm.ashland.edu/
VISIT http://acm.baylor.edu/acmicpc/
BACK
BACK
BACK
FORWARD
VISIT http://www.ibm.com/
BACK
BACK
FORWARD
FORWARD
FORWARD
QUIT

Sample Output

http://acm.ashland.edu/
http://acm.baylor.edu/acmicpc/
http://acm.ashland.edu/
http://www.acm.org/
Ignored
http://acm.ashland.edu/
http://www.ibm.com/
http://acm.ashland.edu/
http://www.acm.org/
http://acm.ashland.edu/
http://www.ibm.com/
Ignored

水题,题意就是模拟访问网页,看当前网页到了哪里。

代码:

#include <iostream>
#include <vector>
#include <map>
#include <algorithm>
#include <cmath>
#include <string>
#include <cstring>
using namespace std; map <int,string> web; int main()
{
//freopen("input.txt","r",stdin);
//freopen("out.txt","w",stdout); string operate;
string website; int cur=1,zong=1;
web[1]="http://www.acm.org/"; while(cin>>operate)
{
if(operate=="QUIT")
break;
if(operate=="VISIT")
{
cin>>website;
web[++cur]=website;
zong=cur;
cout<<website<<endl;
}
if(operate=="BACK")
{
if(cur==1)
{
cout<<"Ignored"<<endl;
}
else
{
cur--;
cout<<web[cur]<<endl;
}
}
if(operate=="FORWARD")
{
if(cur==zong)
{
cout<<"Ignored"<<endl;
}
else
{
cur++;
cout<<web[cur]<<endl;
}
}
} //system("pause");
return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

最新文章

  1. Android中轻松显示Gif图片
  2. HDU 1166 敌兵布阵(线段树单点更新)
  3. Apache日志配置详解(rotatelogs LogFormat)
  4. NOIP 2014 普及组 T3 螺旋矩阵
  5. 给a标签herf属性赋值时,必须加http://
  6. uva 12284 直接判断
  7. Sharepoint2010之父子表实现
  8. sencha touch2 动画问题
  9. url 编码方法
  10. A*寻路算法的探寻与改良(三)
  11. eclipse打开一闪而过,环境安装正确
  12. Java中的注释
  13. python网络爬虫之使用scrapy自动爬取多个网页
  14. List删除
  15. 合作开发工具——freeze和pipreqs
  16. scrapy item pipeline
  17. Avahi DOS攻击broadcast-avahi-dos
  18. 深入理解无穷级数和的定义(the sum of the series)
  19. 计算图 graph
  20. bootstrap1.1

热门文章

  1. PCIE_DMA:xapp1052学习笔记
  2. 「UVA10559」Blocks
  3. rem布局js脚本代码
  4. Xeon 第一次训练赛 苏州大学ICPC集训队新生赛第二场(同步赛) [Cloned]
  5. vs2010编译C++ 栈的使用
  6. simplecheck
  7. python 关于异常处理 try...except... 的两个案例
  8. tools.lombok
  9. Dubbo的配置过程,实现原理及架构详解
  10. 《动手学深度学习》系列笔记 —— 语言模型(n元语法、随机采样、连续采样)