Selecting Courses
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 9380   Accepted: 4177

Description

It is well known that it is not easy to select courses in the college, for there is usually conflict among the time of the courses. Li Ming is a student who loves study every much, and at the beginning of each term, he always wants to select courses as more
as possible. Of course there should be no conflict among the courses he selects. 



There are 12 classes every day, and 7 days every week. There are hundreds of courses in the college, and teaching a course needs one class each week. To give students more convenience, though teaching a course needs only one class, a course will be taught several
times in a week. For example, a course may be taught both at the 7-th class on Tuesday and 12-th class on Wednesday, you should assume that there is no difference between the two classes, and that students can select any class to go. At the different weeks,
a student can even go to different class as his wish. Because there are so many courses in the college, selecting courses is not an easy job for Li Ming. As his good friends, can you help him? 

Input

The input contains several cases. For each case, the first line contains an integer n (1 <= n <= 300), the number of courses in Li Ming's college. The following n lines represent n different courses. In each line, the first number is an integer t (1 <= t <=
7*12), the different time when students can go to study the course. Then come t pairs of integers p (1 <= p <= 7) and q (1 <= q <= 12), which mean that the course will be taught at the q-th class on the p-th day of a week.

Output

For each test case, output one integer, which is the maximum number of courses Li Ming can select.

Sample Input

5
1 1 1
2 1 1 2 2
1 2 2
2 3 2 3 3
1 3 3

Sample Output

4

题意是给出了一些课程,有些课程是在在一周之内的许多时间都有这门课,同一门课程在不同的时间内容上并没有区别。每天有12节课,一周7天上课。

问Li Ming最多能选多少节课。

匈牙利算法。将一门课与其每一个开课时间连线,求其最多匹配数量。

代码:

#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
#include <string>
#include <cstring>
#pragma warning(disable:4996)
using namespace std; int grid[805][805];
int link[805];
int visit[805];
int n,k,V1,V2;
int result; bool dfs(int x)
{
int i;
for(i=1;i<=100;i++)
{
if(grid[x][i]==1&&visit[i]==0)
{
visit[i]=1;
if(link[i]==-1||dfs(link[i]))
{
link[i]=x;
return true;
}
}
}
return false;
} void Magyarors()
{
int i; result=0;
memset(link,-1,sizeof(link));//!!这里不能是0 for(i=1;i<=V1;i++)
{
memset(visit,0,sizeof(visit));
if(dfs(i))
result++;
}
cout<<result<<endl;
} int main()
{
int temp,temp2,temp3,i,j;
while(scanf("%d",&V1)!=EOF)
{
V2=0;
memset(grid,0,sizeof(grid)); for(i=1;i<=V1;i++)
{
scanf("%d",&temp);
for(j=1;j<=temp;j++)
{
scanf("%d%d",&temp2,&temp3);
grid[i][(temp2-1)*12+temp3]=1;
V2++;
}
}
Magyarors();
}
return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

最新文章

  1. wpf中UserControl的几种绑定方式
  2. Atitit.atiInputMethod&#160;v2词库清理策略工具&#160;&#160;&#160;&#160;q229
  3. cocos基础教程(2)Window环境下搭建(补充)
  4. POJ2586 Y2K Accounting Bug(贪心)
  5. logstash+ElasticSearch+Kibana VS Splunk
  6. Codeforces Round #271 (Div. 2) F题 Ant colony(线段树)
  7. linux 使用sh@d0ws0cks server
  8. 安装Redis 4.0单实例
  9. HDU - 6315(2018 Multi-University Training Contest 2) Naive Operations (线段树区间操作)
  10. 最简单的配置Centos中JAVA的环境变量的方法
  11. PAT 1031 查验身份证(15)(C++&Python)
  12. RPG游戏开发基础教程
  13. 网站性能测试指标(QPS,TPS,吞吐量,响应时间)详解
  14. Delphi IDE 版本
  15. Linux运维常用150个命令
  16. datagridview 如何禁止行被选中
  17. while 语句
  18. URL的getFile()和getPath()方法的区别(转)
  19. 高可用Kubernetes集群-12. 部署kubernetes-ingress
  20. Keywords Search HDU - 2222(ac自动机板题。。)

热门文章

  1. JavaScript之bind方法实现代码分析
  2. 「NOI2009」二叉查找树
  3. 【LOJ2513】「BJOI2018」治疗之雨
  4. JavaScript 环境污染
  5. 用 ConfigMap 管理配置【转】
  6. python 字典复制(存疑)
  7. JSON数组序列化C#方法
  8. 20190108PLC学习心得
  9. 洛谷P1002——过河卒
  10. 使用Def文件导出Dll文件