题目大意:一共有N个学生跟P门课程,一个学生可以任意选一门或多门课,问是否达成:

  1.每个学生选的都是不同的课(即不能有两个学生选同一门课)

  2.每门课都有一个代表(即P门课都被成功选过)

输入为:

  P N(课程数跟学生数)

  接着有P行,格式为Count studenti studenti+1 ……studentcount

  (Count表示对课程1感兴趣的学生数,接着有Count个学生)

  如第一行3 1 2 3表示学生1跟学生2跟学生3对课程1感兴趣

  输出为:

  若能满足上面两个要求这输出”YES”,否则为”NO”

Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions: 

. every student in the committee represents a different course (a student can represent a course if he/she visits that course) 

. each course has a representative in the committee 

Your program should read sets of data from a text file. The first line of the input file contains the number of the data sets. Each data set is presented in the following format: 

P N 
Count1 Student1 1 Student1 2 ... Student1 Count1 
Count2 Student2 1 Student2 2 ... Student2 Count2 
...... 
CountP StudentP 1 StudentP 2 ... StudentP CountP 

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses . from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you'll find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N. 

There are no blank lines between consecutive sets of data. Input data are correct. 

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line. 

An example of program input and output:

Input

2
3 3
3 1 2 3
2 1 2
1 1
3 3
2 1 3
2 1 3
1 1

Output

YES
NO

Sample Input

2
3 3
3 1 2 3
2 1 2
1 1
3 3
2 1 3
2 1 3
1 1

Sample Output

YES
NO

#include <stdio.h>
#include <algorithm>
#include <iostream>
#include <string.h>
using namespace std;
#define INF 0x3f3f3f3f
#define N 310
int dis[310],vis[310],dp[310][310];
int n,m,t;
int find(int x)
{
for(int i=1;i<=n;i++)
{
if(!vis[i]&&dp[x][i])
{
vis[i]=1;
if(dis[i]==0||find(dis[i]))
{
dis[i]=x;
return 1;
}
}
}
return 0;
}
int main()
{
cin>>t;
while(t--)
{
int v,x;
cin>>m>>n;
int ans=0;
memset(dp,0,sizeof(dp));
memset(dis,0,sizeof(dis));
for(int i=1;i<=m;i++)
{
cin>>v;
while(v--)
{
cin>>x;
dp[i][x]=1;
}
}
for(int i=1;i<=m;i++)
{
memset(vis,0,sizeof(vis));
if(find(i))
ans++;
}
if(ans==m) printf("YES\n");
else printf("NO\n");
}
}

最新文章

  1. Ajax跨域:jsonp还是CORS
  2. Xamarin Studio在Mac环境下的配置和Xamarin.iOS常用控件的示例
  3. 认识SQLServer索引以及单列索引和多列索引的不同
  4. msbuild ConfuserEx.Build 加密
  5. CSS样式覆盖顺序
  6. Excel 如何按条件计数和按条件求和(如按月求和)
  7. python 不得不知的第三方库以及常用安装包
  8. fork子进程之间传输信息的方法(包含子进程与子进程之间区分的问题的解决)
  9. javascript实现当前页导航激活
  10. 从头开始学JavaScript (八)——变量
  11. Python基础之数据类型
  12. Jquery blokckUI 快速入门
  13. JBOSS EAP 6 系列四 EJB实现——调用(贯穿始终的模块)
  14. python的学习笔记01_1 python2和python3的区别和环境
  15. centos安装jenkins
  16. selenium执行JavaScript语句:控制滚动条 聚焦元素 改变下拉选项
  17. 一、Composer下载安装
  18. Linux进程管理工具
  19. css postion 属性区别【原】
  20. 新做了块avr开发板--tft屏研究用

热门文章

  1. 十八般武艺玩转GaussDB(DWS)性能调优:SQL改写
  2. R语言学习笔记-Corrplot相关性分析
  3. sql查询速度慢分析及如何优化查询
  4. python中环境变量的使用
  5. SonarQube学习(六)- SonarQube之扫描报告解析
  6. Docker学习笔记之创建Ubuntu基础镜像
  7. Linux学习笔记 | 常见错误之无法获得锁
  8. 深入剖析setState同步异步机制
  9. leetcode刷题录-1395
  10. python中IF语句容易犯的错误CASE