A secret service developed a new kind of explosive that attain its volatile property only when a specific association of products occurs. Each product is a mix of two different simple compounds, to which we call a binding pair. If N > 2, then mixing N different binding pairs containing N simple compounds creates a powerful explosive. For example, the binding pairs A+B, B+C, A+C (three pairs, three compounds) result in an explosive, while A+B, B+C, A+D (three pairs, four compounds) does not. You are not a secret agent but only a guy in a delivery agency with one dangerous problem: receive binding pairs in sequential order and place them in a cargo ship. However, you must avoid placing in 

the same room an explosive association. So, after placing a set of pairs, if you receive one pair that might produce an explosion with some of the pairs already in stock, you must refuse it, otherwise, you must accept it. An example. Lets assume you receive the following sequence: A+B, G+B, D+F, A+E, E+G, F+H. You would accept the first four pairs but then refuse E+G since it would be possible to make the following explosive with the previous pairs: A+B, G+B, A+E, E+G (4 pairs with 4 simple compounds). Finally, you would accept the last pair, F+H. Compute the number of refusals given a sequence of binding pairs. 

Input 

The input will contain several test cases, each of them as described below. Consecutive 

test cases are separated by a single blank line. Instead of letters we will use integers to represent compounds. The input contains several lines. Each line (except the last) consists of two integers (each integer lies between 0 and 10 5 ) separated by a single space, representing a binding pair. Each test case ends in a line with the number ‘-1’. You may assume that no repeated binding pairs appears in the input. 

Output 

For each test case, the output must follow the description below. A single line with the number of refusals. 

Sample Input 

1 2 

3 4 

3 5 

3 1 

2 3 

4 1 

2 6 

6 5 

-1 

Sample Output 

3

题意:有若干个由两种元素组成的简单化合物,现在把它们装进车里,如果车里有k种简单化合物并且在这k种简单化合物中恰好有k种元素的话,那么就会引发爆炸,所以车上的化合物必须避免满足这个条件。求出这些化合物中有多少个化合物不能装进车。

分析:最开始没有找到规律,直到后来用图的思想去思考后才发现规律,发生爆炸的条件就是形成环。怎么判断有没有形成环呢?可以用并查集构造树,如果即将合并的两个结点有相同的根,则会形成环。

AC代码如下(3ms) :

#include <stdio.h>
#include <cstring>
#include <vector>
#include <algorithm>
using namespace std;
#define fast ios::sync_with_stdio(0);cin.tie(0);cout.tie(0);
#define ll long long const int maxn = 1e5 + 5;
int par[maxn]; void init(int n)
{
for (int i = 0; i < maxn; i++)
par[i] = i;
} int find_(int x)
{
return (par[x] == x) ? x : par[x] = find_(par[x]);
} int main()
{
int x,y;
while (~scanf("%d", &x))
{
int ans = 0;
init(maxn);
while (x != -1)
{
scanf("%d", &y);
int rx = find_(x);
int ry = find_(y);
if (rx == ry)ans++;//如果即将连接的两个结点拥有相同的根,则会成环
else par[rx] = ry;
scanf("%d", &x);
}
printf("%d\n", ans);
}
return 0;
}

最新文章

  1. 解决:HTML中多文本域(textarea)回车后数据存入数据库,EL表达式取出异常。
  2. 异步刷新tableView
  3. MVC设计模式下实现数据库的连接,并获取所有数据到浏览器页面上显示
  4. linux下磁盘进行分区、文件系统创建、挂载和卸载
  5. IDEA与Tomcat创建并运行Java Web项目及servlet的简单实现
  6. Android程序的入口点和全局变量设置--application
  7. Android实现图片宽度100%ImageView宽度且高度按比例自动伸缩
  8. Linux系列教程(十二)——Linux软件包管理之yum在线管理
  9. BCDEdit命令添加WinPE启动项
  10. 数据排序--vue
  11. JSP 内置对象(上)
  12. 什么是 IP 隧道,Linux 怎么实现隧道通信?
  13. IDEA汉化
  14. gitlab4.0备份还原
  15. responsiveslides 插件(图片轮播插件)
  16. c++ primer 学习杂记1
  17. (自己转)比较ArrayList、LinkedList、Vector
  18. Drbd双机环境安装配置
  19. NYOJ 832 DP
  20. Nginx的各种报错总结

热门文章

  1. psp表格
  2. Maven发展历史
  3. Java 多线程基础(十)interrupt()和线程终止方式
  4. 谈谈spring-boot-starter-data-redis序列化
  5. ElasticSearch中的sort排序和filedData作用
  6. Python3-logging模块-日志记录
  7. 入门大数据---Hive视图和索引
  8. Python干货整理之数据结构篇
  9. dart快速入门教程 (7.1)
  10. 【博弈】HDU - 5963 朋友