Crazy Search
Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3035    Accepted Submission(s): 1133
 
 
Problem Description
Many people like to solve hard puzzles some of which may lead them to madness. One such puzzle could be finding a hidden prime number in a given text. Such number could be the number of different substrings of a given size that exist in the text. As you soon will discover, you really need the help of a computer and a good algorithm to solve such a puzzle.
 
Your task is to write a program that given the size, N, of the substring, the number of different characters that may occur in the text, NC, and the text itself, determines the number of different substrings of size N that appear in the text.
 
As an example, consider N=3, NC=4 and the text "daababac". The different substrings of size 3 that can be found in this text are: "daa", "aab", "aba", "bab", "bac". Therefore, the answer should be 5.
 
Input
The first line of input consists of two numbers, N and NC, separated by exactly one space. This is followed by the text where the search takes place. You may assume that the maximum number of substrings formed by the possible set of characters does not exceed 16 Millions.
 
Output
The program should output just an integer corresponding to the number of different substrings of size N found in the given text.
The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.
 
The output format consists of N output blocks. There is a blank line between output blocks.
 
 
Sample Input
1
3 4
daababac
 
Sample Output
5
 
#include<iostream>
#include <map>
#include <string>
using namespace std;
int main()
{
int t,n,nc;
cin>>t;
map<string,int> m;
while(t--){
cin>>n>>nc;
m.clear(); //要格式化。
string str;
cin>>str;
string temp;
int i,length;
length=str.length();
for(i=0;i<=length-n;i++)
{
temp=string(str,i,n); //截取字符串(要记住)
if(m.count(temp)==0)
m[temp]++;
}
cout<<m.size()<<endl;
}
return 0;
}
 
 

最新文章

  1. intelliJ idea代码折叠
  2. java字符串拼接与性能
  3. 利用win7系统自带的dos命令把笔记本无线网卡当无线路由器(无线AP发射器)
  4. Leetcode 344 Reverse String 字符串处理
  5. 一个异常与Android Studio系列教程参考
  6. Leveldb 实现原理
  7. Sublime 的中文乱码问题
  8. python(6)-类
  9. 关于window.location不跳转的问题
  10. 零基础学习云计算及大数据DBA集群架构师【Linux系统配置及网络配置2015年12月30日周三】
  11. ubuntu12.10下arm-linux-gcc交叉编译环境的搭建
  12. Hadoop2.7.3集群搭建
  13. Vue 进阶之路(五)
  14. 7个优秀的国内外移动端web框架(转)
  15. 浅谈Quartz定时任务调度
  16. C++字符串结束标识
  17. hdu3516 Tree Construction (区间dp+四边形优化)
  18. Git教程学习(三)
  19. delete p和delete [] p的区别(转)
  20. python标准库介绍——19 mmap 模块详解

热门文章

  1. js 中常用的循环
  2. WPF中如何调整TabControl的大小,使其跟随Window的大小而改变?
  3. 【python练习题】程序9
  4. CF 1041 1042整理
  5. Xadmin 组件基础使用以及全局配置
  6. DNSCrypt
  7. zabbix agent 自定义 UserParameter
  8. thusc2017
  9. [luogu1972][bzoj1878][SDOI2009]HH的项链【莫队+玄学卡常】
  10. Balanced Sequence HDU - 6299(杭电多校1 B)