B - RGB Coloring


Time limit : 2sec / Memory limit : 1024MB

Score : 700 points

Problem Statement

Takahashi has a tower which is divided into N layers. Initially, all the layers are uncolored. Takahashi is going to paint some of the layers in red, green or blue to make a beautiful tower. He defines the beauty of the tower as follows:

  • The beauty of the tower is the sum of the scores of the N layers, where the score of a layer is A if the layer is painted red, A+B if the layer is painted green, B if the layer is painted blue, and 0 if the layer is uncolored.

Here, A and B are positive integer constants given beforehand. Also note that a layer may not be painted in two or more colors.

Takahashi is planning to paint the tower so that the beauty of the tower becomes exactly K. How many such ways are there to paint the tower? Find the count modulo 998244353. Two ways to paint the tower are considered different when there exists a layer that is painted in different colors, or a layer that is painted in some color in one of the ways and not in the other.

Constraints

  • 1≤N≤3×105
  • 1≤A,B≤3×105
  • 0≤K≤18×1010
  • All values in the input are integers.

Input

Input is given from Standard Input in the following format:

N A B K

Output

Print the number of the ways to paint tiles, modulo 998244353.


Sample Input 1

Copy
4 1 2 5

Sample Output 1

Copy
40

In this case, a red layer worth 1 points, a green layer worth 3 points and the blue layer worth 2 points. The beauty of the tower is 5 when we have one of the following sets of painted layers:

  • 1 green, 1 blue
  • 1 red, 2 blues
  • 2 reds, 1 green
  • 3 reds, 1 blue

The total number of the ways to produce them is 40.


Sample Input 2

Copy
2 5 6 0

Sample Output 2

Copy
1

The beauty of the tower is 0 only when all the layers are uncolored. Thus, the answer is 1.


Sample Input 3

Copy
90081 33447 90629 6391049189

Sample Output 3

Copy
577742975

pkusc之后非常难过qwq,刷道水题安慰自己qwq。
(这可能是组合计数模板题??)
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<algorithm>
#include<cstring>
#include<ctime>
#define ll long long
using namespace std;
const int maxn=300005,ha=998244353;
inline void add(int &x,int y){ x+=y; if(x>=ha) x-=ha;}
inline int ksm(int x,int y){
int an=1;
for(;y;y>>=1,x=x*(ll)x%ha) if(y&1) an=an*(ll)x%ha;
return an;
} int jc[maxn],ni[maxn];
int N,A,B,ans;
ll K; inline int C(int x,int y){ return jc[x]*(ll)ni[y]%ha*(ll)ni[x-y]%ha;} inline void init(){
jc[0]=1;
for(int i=1;i<=N;i++) jc[i]=jc[i-1]*(ll)i%ha;
ni[N]=ksm(jc[N],ha-2);
for(int i=N;i;i--) ni[i-1]=ni[i]*(ll)i%ha;
} inline void solve(){
const int b=B,T=min((ll)N,K/A); for(int i=0;i<=T;i++){
if((K-A*(ll)i)%b) continue;
ll lef=(K-A*(ll)i)/b;
if(lef>N) continue; add(ans,C(N,i)*(ll)C(N,lef)%ha);
}
} int main(){
scanf("%d%d%d%lld",&N,&A,&B,&K); init(),solve(); printf("%d\n",ans);
return 0;
}

  

最新文章

  1. 浅谈android binder机制
  2. JAVA - Collections用法总结
  3. 移动端事件touchstart、touchmove、touchend
  4. 利用JS提交表单的几种方法和验证
  5. 1password密码文件重装后恢复
  6. 百度UEditor组件出现Parameters: Invalid chunk &amp;#39;&amp;#39; ignored警告的分析
  7. 预览Cube出现没有注册类错误
  8. ios Base64编解码工具类及使用
  9. 通过代码创建label 计算最佳尺寸 让其自适应文本高度或宽度
  10. Browsing History
  11. Graphviz 绘制流程图
  12. excel删除问号~?~
  13. [刷题]Codeforces 794C - Naming Company
  14. 【Tomcat】shell 部署配置 war包
  15. 记一次oracle数据库复制过程
  16. Spring之BeanPostProcessor(后置处理器)介绍
  17. MySQL系列详解六:MySQL主从复制/半同步演示-技术流ken
  18. 转://Oracle Golden Gate 概念和原理
  19. C# MD5 加密
  20. 获取本机IP地址的小脚本

热门文章

  1. [学习笔记]可持久化数据结构——数组、并查集、平衡树、Trie树
  2. Java的Properties使用及格式定义
  3. 几个JQuery解析XML的程序例子
  4. C语言的getopt
  5. poj1185 炮兵阵地 状压dp
  6. centos安装net-speeder
  7. php getimagesize()函数获取图片宽度高度
  8. javascript简易下拉菜单效果
  9. 网络编程:connect函数
  10. 全排列---(dfs)