题目描述

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

有N件物品和一个容量为V的背包。第i件物品的重量是c[i],价值是w[i]。求解将哪些物品装入背包可使这些物品的重量总和不超过背包容量,且价值总和最大。

输入输出格式

输入格式:

  • Line 1: Two space-separated integers: N and M

  • Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

输出格式:

  • Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

输入输出样例

输入样例#1:

4 6
1 4
2 6
3 12
2 7
输出样例#1:

23

代码
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
],d[],f[];
int main()
{
    scanf("%d%d",&n,&v);
    ;i<=n;i++)
    {
        scanf("%d%d",&d[i],&c[i]);
    }
    ;i<=n;i++)
      for(int m=v;m>=d[i];m--)
        f[m]=max(f[m],f[m-d[i]]+c[i]);
    printf("%d",f[v]);
    ;
}
 

最新文章

  1. vmware在桥接模式下配置centos7网络,并使用xshell连接虚拟主机(总结篇)
  2. Nexpose下载安装注册一条龙
  3. Sprint1(第二天11.15)
  4. phpStudy
  5. 【shell脚本】显示文件的偶数或奇数行
  6. android sqlite导入数据
  7. 【学习笔记】【Foundation】集合Set
  8. WebService实现文件上传下载
  9. spring+hibernate基础
  10. LoadRunner脚本增强
  11. 关于WEB三层架构的思考
  12. 10分钟就能学会的.NET Core配置
  13. WebService服务(转)
  14. Unity3D NGUI事件监听的综合管理
  15. delphi提示“Undeclared identifier”TForm的缺少引用单元列表
  16. (转)用库函数stdarg.h实现函数参数的可变
  17. zabbix3.x添加H3C网络设备详解
  18. English trip -- VC(情景课)2 B Classroom objects
  19. 使用路径arc
  20. jquery统计显示或隐藏的元素个数

热门文章

  1. NOIP 2018 总结
  2. Java访问修饰符(控制属性或方法在哪些范围内可见)
  3. springboot09 事务 H2数据库
  4. 为什么js获取图片高度的值 都为0
  5. P4160 [SCOI2009]生日快乐
  6. hihoCoder #1902 字符替换
  7. [CF845G]Shortest Path Problem?
  8. [zoj] 1081 Points Within || 判断点是否在多边形内
  9. POJ3252 Round Numbers 【数位dp】
  10. JAVA学习资料大全