Jungle Roads

The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems.

Input

The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above.

Output

The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit.

Sample Input

9

A 2 B 12 I 25

B 3 C 10 H 40 I 8

C 2 D 18 G 55

D 1 E 44

E 2 F 60 G 38

F 0

G 1 H 35

H 1 I 35

3

A 2 B 10 C 40

B 1 C 20

0

Sample Output

216

30

题解:最小生成树

(水题)

注意poj上用scanf()和printf()可能运行错误,

#include<cstdio>
#include<algorithm>
#include<cstring>
#include<iostream>
using namespace std;
struct node{
int x,y;
int price;
}a[1000]; int vis[100]; int find(int x)
{
if(vis[x]==x)
return x;
return vis[x]=find(vis[x]);
} bool cmp(node a,node b)
{
return a.price <b.price ;
} void join(int a,int b)
{
int x=find(a);
int y=find(b);
if(x!=y)
vis[x]=y;
} int main()
{
int n;
char str[200];
memset(str,0,sizeof(str));
int zzz=1;
for(int i='A';i<='Z';i++)
str[i]=zzz++;
while(cin>>n&&n)
{ for(int i=1;i<=n;i++)
vis[i]=i; int j=0;
for(int i=0;i<n-1;i++)
{
char c;
getchar();
cin>>c;
int m;
// scanf("%d",&m);
cin>>m;
while(m--)
{
char s;
getchar();
// scanf("%c",&s);
cin>>s;
int u;
//scanf("%d",&u);
cin>>u;
a[j].x =str[c];
a[j].y =str[s];
a[j++].price =u;
}
} sort(a,a+j,cmp);
int sum=0;
for(int i=0;i<j;i++)
{
if(find(a[i].x )!=find(a[i].y ))
sum+=a[i].price ;
join(a[i].x ,a[i].y );
}
// printf("%d\n",sum);
cout<<sum<<endl; }
return 0;
}

最新文章

  1. java动态代理的2种实现方式
  2. Mysql数据库之Binlog日志使用总结
  3. PHP中的NULL类型
  4. 运行java的class文件方法详解
  5. iOS 面试基础题目
  6. eclipse安装完成后配置tomcat server runtime evironment
  7. 帝国cms常用变量总结
  8. Ios 程序封装,安装流程
  9. 给Sublime Text 2安装CTags插件
  10. rabbitmq问题之HTTP access denied: user &#39;guest&#39; - User can only log in via localhost
  11. [Swift]LeetCode299. 猜数字游戏 | Bulls and Cows
  12. 我的.gitignore下配置。存在这里一下。日后有空研究研究!
  13. ShowWindow 隐藏、显示、最大化、最小化窗口
  14. DevExpress v18.2新版亮点——Reporting篇(一)
  15. DataGrip for Mac破解步骤详解 亲测好用
  16. 对世界首款“人工智能”ERP系统HUE的初步了解 - AI ERP - WAP - 万革始
  17. Android BottomNavigationBar底部导航控制器的使用(包含默认postion的设置)
  18. android防止按钮连续点击方案之AOP
  19. D. Babaei and Birthday Cake---cf629D(LIS线段树优化)
  20. ACM赛前准备——模板(排版篇)

热门文章

  1. Java hibernate 遇到的问题:could not read a hi value
  2. 前端-页面性能调试:Hiper
  3. mysql5.6.31安装及配置
  4. 常用的CSS属性列表汇总
  5. 转载 tomcat6下项目移植到tomcat7下出问题的解决办法
  6. COGS 1944. 背驮式行走
  7. pat乙级1034
  8. Sentinel spring-cloud-gateway adapter(1.6)异常错误之@EnableCircuitBreaker
  9. IOS 强指针(strong)和弱指针(weak)
  10. IOS 图形上下文栈