问题描述

Little A gets to know a new friend, Little B, recently. One day, they realize that they are family 500 years ago. Now, Little A wants to know whether Little B is his elder, younger or brother.

输入

There are multiple test cases.

For each test case, the first line has a single integer, n (n<=1000). The next n lines have two integers a and b (1<=a,b<=2000) each, indicating b is the father of a. One person has exactly one father, of course. Little A is numbered 1 and Little B is numbered 2.

Proceed to the end of file.

输出

For each test case, if Little B is Little A’s younger, print “You are my younger”. Otherwise, if Little B is Little A’s elder, print “You are my elder”. Otherwise, print “You are my brother”. The output for each test case occupied exactly one line.

样例输入

5

1 3

2 4

3 5

4 6

5 6

6

1 3

2 4

3 5

4 6

5 7

6 7

样例输出

You are my elder

You are my brother

提示



来源

辽宁省赛2010

#include<map>
#include<set>
#include<queue>
#include<stack>
#include<vector>
#include<math.h>
#include<cstdio>
#include<sstream>
#include<numeric>//STL数值算法头文件
#include<stdlib.h>
#include <ctype.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<functional>//模板类头文件
using namespace std; typedef long long ll;
const int maxn=11000;
const int INF=0x3f3f3f3f; int a,b,n;
int fa[maxn]; int main()
{
while(cin>>n)
{
int x1,x2,cot1,cot2;
for(int i=0; i<maxn; i++)
fa[i]=i;
while(n--)
{
scanf("%d %d",&a,&b);
fa[a]=b;
}
x1=1;
cot1=0;
while(fa[x1]!=x1)
{
x1=fa[x1];
cot1++;
}
x2=2;
cot2=0;
while(fa[x2]!=x2)
{
x2=fa[x2];
cot2++;
}
if(cot1>cot2)
printf("You are my elder\n");
else if(cot1<cot2)
printf("You are my younger\n");
else
printf("You are my brother\n");
}
return 0;
}

最新文章

  1. ARM处理器解析
  2. android 监听短信并发送到服务器
  3. linux下安装7z命令及7z命令的使用
  4. [转]Delphi多线程编程入门(二)——通过调用API实现多线程
  5. Debugging Information in Separate Files
  6. ECharts地图中tooltip提示框通过formatter分别显示多个数值
  7. OPenGL中三维图形的矩阵变换
  8. scala学习笔记:理解类继承
  9. 关于ueditor1.4.3版复制section标签丢失class和style样式问题
  10. GDB 的MI接口
  11. neovim的新体验
  12. 基于 Hexo + GitHub Pages 搭建个人博客(一)
  13. Java_Object_Date_System等常用类
  14. [JS设计模式]:构造函数模式(2)
  15. js 面向对象的三大特性
  16. 兼容ie透明书写
  17. 2018.01.04 bzoj5291: [Bjoi2018]链上二次求和(线段树)
  18. WCF加密传输数据,b并且用户名+密码验证
  19. spring 配置bean的方法及依赖注入发方式
  20. ubuntu vsftpd

热门文章

  1. 三星 C7恢复 出厂设置
  2. Chrome profile manager
  3. IntentServicce;Looper;long-running task
  4. 【洛谷 P4008】 [NOI2003]文本编辑器 (Splay)
  5. SQL SERVER 常用公式
  6. js_如何优化你的代码让它更好看
  7. hdu 1162 Eddy&#39;s picture(最小生成树算法)
  8. Xutils使用详解
  9. aptitude约等于apt-get的工具
  10. PHP路由代码