传送门:

http://acm.hdu.edu.cn/showproblem.php?pid=1028

Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 24967    Accepted Submission(s): 17245

Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"

 
Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 
Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 
Sample Input
4
10
20
 
Sample Output
5
42
627
 
Author
Ignatius.L
 
分析:
整数的划分问题
 关于这个整数划分请参考我的这篇博客
关于这个题目
有两种做法
1.暴力打表
打表就不是折磨你自己了,而是折磨电脑了
运行程序之后大概要等几分钟才有结果
code:
#include<bits/stdc++.h>
using namespace std;
typedef long long LL;
#define max_v 125
/*LL f(int n,int m)
{
if(n==1||m==1)
return 1;
else if(n==m&&n>1)
{
return f(n,n-1)+1;
}else if(n<m)
{
return f(n,n);
}else if(n>m)
{
return f(n,m-1)+f(n-m,m);
}
}*/
int main()
{
LL a[]={,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,};
/*for(int i=1;i<max_v;i++)
{
printf("%I64d,",f(i,i));
}
printf("\n**\n");*/
int n;
while(~scanf("%d",&n))
{
printf("%I64d\n",a[n]);
// printf("%I64d\n",f(n,n));
}
return ;
}

2.另外一种做法

记忆化搜索

就是在搜索之前先判断一下,搜过了就不再搜索了

跟dp一个意思

code:

#include<bits/stdc++.h>
using namespace std;
typedef long long LL;
#define max_v 125
int dp[max_v][max_v];
LL f(int n,int m)
{
if(dp[n][m]!=-)//判断有没有搜过
return dp[n][m];
if(n==||m==)
return dp[n][m]=;
else if(n==m&&n>)
{
return dp[n][m]=f(n,n-)+;
}else if(n<m)
{
return dp[n][m]=f(n,n);
}else if(n>m)
{
return dp[n][m]=f(n,m-)+f(n-m,m);
}
}
int main()
{
//两种做法
//LL a[]={0,1,2,3,5,7,11,15,22,30,42,56,77,101,135,176,231,297,385,490,627,792,1002,1255,1575,1958,2436,3010,3718,4565,5604,6842,8349,10143,12310,14883,17977,21637,26015,31185,37338,44583,53174,63261,75175,89134,105558,124754,147273,173525,204226,239943,281589,329931,386155,451276,526823,614154,715220,831820,966467,1121505,1300156,1505499,1741630,2012558,2323520,2679689,3087735,3554345,4087968,4697205,5392783,6185689,7089500,8118264,9289091,10619863,12132164,13848650,15796476,18004327,20506255,23338469,26543660,30167357,34262962,38887673,44108109,49995925,56634173,64112359,72533807,82010177,92669720,104651419,118114304,133230930,150198136,169229875,190569292,214481126,241265379,271248950,304801365,342325709,384276336,431149389,483502844,541946240,607163746,679903203,761002156,851376628,952050665,1064144451,1188908248,1327710076,1482074143,1653668665,1844349560,2056148051,2291320912,2552338241,2841940500};
/*for(int i=1;i<max_v;i++)
{
printf("%I64d,",f(i,i));
}
printf("\n**\n");*/
memset(dp,-,sizeof(dp));//没有搜索的标记
int n;
while(~scanf("%d",&n))
{
//printf("%I64d\n",a[n]);
printf("%I64d\n",f(n,n));
}
return ;
}

最新文章

  1. 【接口开发】浅谈 SOAP Webserver 与 Restful Webserver 区别
  2. 闭区间套定理(Nested intervals theorem)
  3. 利用闭包解决for循环里onclick事件不能捕捉实时i值问题
  4. 深入理解及应用Position
  5. 利用 PhpStorm、Idea 等 IDE 如何 运行/调试 Go 程序 ?
  6. pll及其modesim仿真
  7. 正整数转换成N进制的数组
  8. Tesseract-OCR识别验证码
  9. win8.1 无法安装 net framework3.5的解决办法
  10. 提高你的Java代码质量吧:让我们疑惑的字符串拼接方式的选择
  11. shell编程笔记(基本部分)
  12. php获取post参数的几种方式
  13. ORACLE经常使用的命令
  14. 为Android系统内置C可执行程序测试Linux内核驱动程序
  15. 网站与域名知识扫盲-DNS
  16. Nodejs的运行原理-生态篇
  17. FSG报表打印报错,log文件显示java.sql.SQLException: No corresponding LOB data found
  18. 基于scrapy-redis的分布式爬虫
  19. SpringBoot整合模板引擎
  20. Bash 5.0 发布及其新功能

热门文章

  1. Jquery判断checkbox选中状态
  2. 抽象工厂模式的C++、Java实现
  3. ul li各属性设置
  4. vue-cli脚手架项目实例
  5. MDM-Object.fn 一些实践与理解
  6. 在线官网Spring Initializr 或 IntelliJ IDEA 快速搭建springboot项目
  7. css properties
  8. SQL Server 2016 -&gt;&gt; T-SQL新特性
  9. iOS文件处理类
  10. phpstorm2017使用快捷键