时间限制:1 秒

内存限制:32 兆

特殊判题:否

提交:2691

解决:1432

题目描述:

Among grandfather's papers a bill was found.

    72 turkeys $_679_

    The first and the last digits of the number that obviously represented the total price of those turkeys are replaced here by blanks (denoted _), for they are faded and are illegible. What are the two faded digits and what was the price of one turkey?

    We want to write a program that solves a general version of the above problem.

    N turkeys $_XYZ_

    The total number of turkeys, N, is between 1 and 99, including both. The total price originally consisted of five digits, but we can see only the three digits in the middle. We assume that the first digit is nonzero, that the price of one turkeys is an
integer number of dollars, and that all the

turkeys cost the same price.

    Given N, X, Y, and Z, write a program that guesses the two faded digits and the original price. In case that there is more than one candidate for the original price, the output should be the most expensive one. That is, the program is to report the two
faded digits and the maximum price per turkey for the turkeys.

输入:

The first line of the input file contains an integer N (0<N<100), which represents the number of turkeys. In the following line, there are the three decimal digits X, Y, and Z., separated by a space, of the original price $_XYZ_.

输出:

For each case, output the two faded digits and the maximum price per turkey for the turkeys.

样例输入:
72
6 7 9
5
2 3 7
78
0 0 5
样例输出:
3 2 511
9 5 18475
0
来源:
2007年上海交通大学计算机研究生机试真题

思路:

比较简单,万位和个位循环尝试即可。

代码:

#include <stdio.h>

#define N 100

int main(void)
{
int n, i, j, num;
int x, y, z, xyz0; while (scanf("%d", &n) != EOF)
{
scanf("%d%d%d", &x, &y ,&z);
xyz0 = x*1000 + y*100 +z*10; int find = 0;
for (i=9; i>0; i--)
{
for (j=9; j>=0; j--)
{
num = i*10000 + xyz0 + j;
if (num % n == 0)
{
printf("%d %d %d\n", i, j, num/n);
find = 1;
break;
}
}
if (find == 1)
break;
}
if (find == 0)
printf("0\n");
} return 0;
}
/**************************************************************
Problem: 1036
User: liangrx06
Language: C
Result: Accepted
Time:0 ms
Memory:912 kb
****************************************************************/

最新文章

  1. .Net客户端监听ZooKeeper节点数据变化
  2. [No00007E]2016-面经[中]
  3. 【jQuery api】isArray
  4. UVA1220Party at Hali-Bula(树的最大独立集 + 唯一性判断)
  5. netty入门实例
  6. JavaScript中的运动数学函数(持续更新)
  7. java基础之操作符
  8. 关于JVM加载class文件和类的初始化
  9. Java - day001 - 8种基本数据类型
  10. 测试开发之前端——No9.HTML5中的视频/音频
  11. hdu 2036 求多边形面积 (凸、凹多边形)
  12. bochs
  13. layui数据表格的td模板
  14. HTML项目总结
  15. idea常用设置(持续更新)
  16. Monte carlo
  17. 老司机谈APK瘦身套路-图片资源篇
  18. git的常见操作方法
  19. [BZOJ3124]直径
  20. Django安装及创建工程

热门文章

  1. usaco-Cow Pedigrees
  2. android dagger2使用笔记
  3. Oracle并发控制、事务管理学习笔记
  4. (入门SpringBoot)SpringBoot结合logback(六)
  5. git-ssh配置和使用
  6. 转: Gradle:Gradle入门
  7. &gt; 1366 - Incorrect string value: &#39;\xE6\xB5\x8B\xE8\xAF\x95...&#39; for column &#39;description&#39; at row 1 字符串格式错误
  8. apache默认路径
  9. php猴子吃桃
  10. UNP学习笔记(第六章 I/O复用)