Zjnu Stadium

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1631    Accepted Submission(s): 616

Problem Description

In 12th Zhejiang College Students Games 2007, there was a new stadium built in Zhejiang Normal University. It was a modern stadium which could hold thousands of people. The audience Seats made a circle. The total number of columns were 300 numbered 1--300, counted clockwise, we assume the number of rows were infinite.
These days, Busoniya want to hold a large-scale theatrical performance in this stadium. There will be N people go there numbered 1--N. Busoniya has Reserved several seats. To make it funny, he makes M requests for these seats: A B X, which means people numbered B must seat clockwise X distance from people numbered A. For example: A is in column 4th and X is 2, then B must in column 6th (6=4+2).
Now your task is to judge weather the request is correct or not. The rule of your judgement is easy: when a new request has conflicts against the foregoing ones then we define it as incorrect, otherwise it is correct. Please find out all the incorrect requests and count them as R.

Input

There are many test cases:
For every case:
The first line has two integer N(1<=N<=50,000), M(0<=M<=100,000),separated by a space.
Then M lines follow, each line has 3 integer A(1<=A<=N), B(1<=B<=N), X(0<=X<300) (A!=B), separated by a space.

Output

For every case:
Output R, represents the number of incorrect request.

Sample Input


10 10
1 2 150
3 4 200
1 5 270
2 6 200
6 5 80
4 7 150
8 9 100
4 8 50
1 7 100
9 2 100

Sample Output


2



Hint

Hint:
(PS: the 5th and 10th requests are incorrect)

Source

2009 Multi-University Training Contest 14 - Host by ZJNU

 

 

(1)弄清题意,找出出现冲突的位置,判断冲突很简单: 就是当两个人在同一行坐同时, 他们到根节点的距离差值正好是他们之间的距离差值。如果和测试数据不同,此时就出现了冲突了。

(2)关键有两个地方,这也是并查集题目的难点,1、路径压缩,2、合并时候求被合并根节点到新根节点的距离。

路径压缩在递归过程中计算每个节点到根的距离: dist[x] += dist[fx];

合并过程 fy合并到fx

p[fy]=fx;

dist[fy]=-dist[y]+d+dist[x];

使用的是数学中向量计算的原理如图

 

#include<cstdio>
#include<cstring>
#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
const int maxn=50000+5;
int p[maxn], dist[maxn];//dist存储的是相对于父节点的距离 void make_set()
{
memset(p, -1, sizeof(p));
memset(dist, 0, sizeof(dist));
} int find_set(int x)
{
if(p[x]==-1) return x;
int fx=p[x];
p[x]=find_set(p[x]);
dist[x]+=dist[fx];
return p[x];
} void union_set(int x, int y, int d)
{
int fx=find_set(x), fy=find_set(y);
if(fx==fy) return;
p[fy]=fx;
dist[fy]=-dist[y]+d+dist[x];
} int main()
{
int n, m;
int a, b, x;
int ans;
while(scanf("%d%d", &n, &m)!=EOF) {
ans=0;
make_set();
while(m--)
{
scanf("%d%d%d", &a, &b, &x);
if(find_set(a)==find_set(b))
{
if(dist[b]-dist[a]!=x)
{
//printf("a=%d b=%d x=%d, dist[b]-dist[a]=%d\n", a, b, x, dist[b]-dist[a]);
ans++;
}
}
else union_set(a, b,x);
}
printf("%d\n", ans);
} return 0;
}

最新文章

  1. TableLayout表格布局详解
  2. Wcf 双工通信的应用
  3. c#开源Excel操作库--NPOI
  4. python基础:自定义函数
  5. 简单md5加密
  6. 【转】Multithreaded Python Tutorial with the “Threadworms” Demo
  7. BZOJ 2730: [HNOI2012]矿场搭建( tarjan )
  8. hdu_5903_Square Distance(dp)
  9. XML解析之DOM解析技术案例
  10. 产生AJAX跨域问题的原因
  11. 中小研发团队架构实践之生产环境诊断工具WinDbg
  12. SQL语句完整的执行顺序(01)
  13. 欧姆龙PLC CP1E型号的90,91,190
  14. Java设计模式(二)
  15. jsp中引入jquery报错:Failed to load resource: the server responded with a status of 404 (Not Found)
  16. RESTful API后台系统架构设计(Java)
  17. 【bzoj1087】互不侵犯King
  18. ​网页图表Highcharts实践教程标之加入题副标题版权信息
  19. phpstorm破解 IntelliJ IDEA License Server本地搭建教程 http://blog.lanyus.com/archives/174.html/comment-page-6#comments 附件:mac环境
  20. 如何用jQuery封装插件

热门文章

  1. Java分布式 一些概念理解
  2. mysql操作索引的sql语句
  3. Atitit.执行cli&#160;cmd的原理与调试
  4. 分页技术框架(Pager-taglib)学习一(页面分页)
  5. nginx整合php+lua+oracle环境搭建
  6. spring junit 部署两套测试方案
  7. PHP学习笔记(3)GD库画图
  8. head管理EC下载,配置启动
  9. 读取Properties文件六种方法
  10. Windows Server2008R2中导入Excel