A + B Again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 15772    Accepted Submission(s): 6847

Problem Description
There must be many A + B problems in our HDOJ , now a new one is coming.

Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too.

Easy ? AC it !
 
Input
The input contains several test cases, please process to the end of the file.

Each case consists of two hexadecimal integers A and B in a line seperated by a blank.

The length of A and B is less than 15.
 
Output
For each test case,print the sum of A and B in hexadecimal in one line.
 
Sample Input
+A -A
+1A 12
1A -9
-1A -12
1A -AA
 
Sample Output
0
2C
11
-2C
-90
 
Author
linle
 
Source

1.%I64X 输入

2.%I64X 不能输出负数

3.%I64O 也不能输出负数

4.如果x 为小写 输出的16进制为小写,为大写,输出大写

#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <cstring>
#include <ctime>
#include <algorithm>
#include <iostream>
#include <sstream>
#include <string>
#define oo 0x13131313
using namespace std;
int main()
{
long long A;long long B;
while(scanf("%I64O%I64O",&A,&B)!=EOF)
{
long long C=A+B;
// if(C<0)
// printf("-%I64X\n",-C);
printf("%I64o\n",C);
}
return 0;
}

最新文章

  1. android中加载的html获取的宽高不正确
  2. 【转】NoSQL初探之人人都爱Redis:(1)Redis简介与简单安装
  3. 深入浅出设计模式——单例模式(Singleton Pattern)
  4. 使用Firefox user agent进行移动端网页测试
  5. CollectionView添加头尾部
  6. myeclipse 6.5配置tomcat7.X
  7. eclipse 护眼色
  8. 【转】Android自动化测试之MonkeyRunner录制和回放脚本(四)
  9. mong 备份和恢复
  10. 04 AutoCompleteTextView
  11. pyecharts使用
  12. socket编程: TypeError: must be bytes or buffer, not str
  13. XML学习总结二&mdash;&mdash;DTD
  14. R基本图形示例及代码(持续收集)
  15. HDU 2647 Reward(拓扑排序,vector实现邻接表)
  16. ASP.NET MVC项目框架快速搭建实战
  17. stringstream读入每行数据
  18. BBS - 表、登录、文件上传、注册
  19. IOS CALayer的属性和使用
  20. sqlmap tamper编写

热门文章

  1. 飘逸的python - 解决一个有限制的组合需求
  2. 把Go程序变小的办法
  3. C#邮件发送
  4. python 3.6 import pymysql错误
  5. C++学习笔录4
  6. (转)Ubuntu中让终端对于历史输出的内容保持足够长
  7. setInterval &amp;&amp; setTimeout || 定时器
  8. Java中的IO学习总结
  9. Python之路第十二天,高级(4)-Python操作rabbitMQ
  10. oc语言--语法