一、EIGRP的基本配置
1(1)、进入接口配置IP
R1(config)#inter s1/0
R1(config-if)#ip address 200.1.1.1 255.255.255.0
R1(config-if)#no shut
1(2)、配置环回地址
R1(config)#inter lo 1
R1(config-if)#ip add 1.1.1.1 255.255.255.0

2(1)、路由器2同理配置
R2(config)#inter s1/0
R2(config-if)#ip address 200.1.1.2 255.255.255.0
R2(config-if)#no shut

2(2)
R2(config)#inter lo 1
R2(config-if)#ip add 2.2.2.2 255.255.255.0

1(1)配置EIGRP和宣告
R1(config)#router eigrp 100
R1(config-router)#network 200.1.1.0
R1(config-router)#network 1.1.1.0
1(2)关闭自动汇总
R1(config)#router eigrp 100
R1(config-router)#no auto-summary
1(3)手工汇总
R1(config)#inter s1/0
R1(config-if)#ip summary-address eigrp 100 192.168.10.0 255.255.0.0
2(1)
R2(config)#router eigrp 100
R2(config-router)#network 200.1.1.0
R2(config-router)#network 2.2.2.0
R2(config-router)#network 200.1.1.0 ?
  A.B.C.D  EIGRP wild card bits
  <cr>
R2(config-router)#network 200.1.1.0 0.0.0.255
R2(config-router)#network 2.2.2.0 0.0.0.255 
二、查看EIGRP运行情况
    一、R1#show ip eigrp neighbors(查看邻居表的信息)
    二、R1#show ip route eigrp(查看特定的协议信息)
    三、R1#show ip route (查看路由表中所有的路由)
    四、R1#show ip protocols(查看eigrp的一些信息,比如k值)
    五、R1#show ip eigrp interfaces
    六、R1#show ip eigrp topology
    七、R1#show ip eigrp traffic

三、关闭自动汇总,实现手工汇总
1(1)关闭自动汇总
R1(config)#router eigrp 100
R1(config-router)#no auto-summary
1(2)手工汇总
R1(config)#inter s1/0
R1(config-if)#ip summary-address eigrp 100 192.168.10.0 255.255.0.0

2(1)
R2(config)#router eigrp 100
R2(config-router)#no auto-summary

四、掌握EIGRP的认证
第一步、配置认证
    注意两台路由器的密码需要保持一致
R1(config)#key chain ccna
R1(config-keychain)#key 1
R1(config-keychain-key)#key-string cisco
R1(config-keychain-key)#exit

R2(config)#key chain ccna
R2(config-keychain)#key 1     //定义钥匙
R2(config-keychain-key)#key-string cisco
R2(config-keychain-key)#exit

第二步、在接口上启用认证
1、
R1(config)#inter s1/0
R1(config-if)#ip authentication mode eigrp 100 ?
  md5  Keyed message digest

R1(config-if)#ip authentication mode eigrp 100 md5

2、
R1(config)#inter s1/0                          
R1(config-if)#ip authentication key-chain eigrp 100 ?
  WORD  name of key-chain

R1(config-if)#ip authentication key-chain eigrp 100 ccna

查看
R1#show ip eigrp neighbors
IP-EIGRP neighbors for process 100   //因为R2没有启用认证,所以邻居关系当掉

现将R2开启认证
1、
R2(config)#inter s1/0
R2(config-if)#ip authentication mode eigrp 100 ?
  md5  Keyed message digest

R2(config-if)#ip authentication mode eigrp 100 md5

2、
R2(config-if)#ip authentication key-chain eigrp 100 ccna

再次查看
R2(config-if)#do show ip eigrp neighbors
IP-EIGRP neighbors for process 100
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   200.1.1.1               Se1/0             11 00:01:13 1395  5000  0  19

最新文章

  1. 手把手教你如何加入到github的开源世界!
  2. IoC模式
  3. mac上创建MySQL的基本步骤
  4. 记一次mybatis的classpath踩坑记录
  5. CSS 样式的优先级
  6. [转]有关USES_CONVERSION
  7. 【转】SQL Server T-SQL高级查询
  8. [原][Android]All WebView methods must be called on the same thread.
  9. FFT矩阵
  10. Zabbix lld发现磁盘监控
  11. MVC3和MVC4中CRUD操作
  12. Leetcode 39 40 216 Combination Sum I II III
  13. RTX 无法刷新组织架构的处理方法总结
  14. webpack4的总结
  15. 16.python-I/O模型
  16. 简述rpm与yum命令的常见选项
  17. Git之创建仓库并上传/更新项目版本
  18. Spring技术内幕_IOC容器载入Bean定义资源文件
  19. Erlang编程语言的一些痛点
  20. [转载]ASP.NET-----Repeater数据控件的用法总结

热门文章

  1. no datanode to stop
  2. MEF 编程指南(六):导出和元数据
  3. RT-Thread学习笔记(1)
  4. Codeforces Round #313 (Div. 2) A. Currency System in Geraldion 水题
  5. Codeforces Gym 100342E Problem E. Minima 暴力
  6. Android 4.1源码编译找不到资源文件解决办法
  7. Github上最全的APICloud开源前端框架效果盘点(转)
  8. Python学习 之 走进python
  9. The First
  10. poj1068解题报告(模拟类)