Parencodings
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 24932   Accepted: 14695

Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways: 
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence). 
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).

Following is an example of the above encodings:

	S		(((()()())))

P-sequence 4 5 6666

W-sequence 1 1 1456

Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string. 

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9

Source

 
 
 
解析:模拟。
 
 
 
#include <cstdio>

char s[10000000];
int a[25];
int n;
int res[25];
int rid[25]; void solve()
{
int cnt = 0, rcnt = 0;
for(int i = 1; i <= a[0]; ++i)
s[cnt++] = '(';
s[cnt] = ')';
rid[rcnt++] = cnt;
++cnt;
for(int i = 1; i < n; ++i){
int num = a[i]-a[i-1];
for(int j = 1; j <= num; ++j)
s[cnt++] = '(';
s[cnt] = ')';
rid[rcnt++] = cnt;
++cnt;
}
int res_cnt = 0;
for(int i = 0; i < rcnt; ++i){
int l = 0, r = 1;
for(int j = rid[i]-1; ; --j){
if(s[j] == '('){
++l;
if(l == r){
res[res_cnt++] = l;
break;
}
}
else
++r;
}
}
for(int i = 0; i < n-1; ++i)
printf("%d ", res[i]);
printf("%d\n", res[n-1]);
} int main()
{
int t;
scanf("%d", &t);
while(t--){
scanf("%d", &n);
for(int i = 0; i < n; ++i)
scanf("%d", &a[i]);
solve();
}
return 0;
}

  

最新文章

  1. float---浮动带来的影响与清除浮动带来的影响方法----在路上(20)
  2. qrcodenet 代码中一些基础的认识 帮助
  3. HDU1051 贪心
  4. Linux下列格式化工具 - column
  5. HDU 2066 一个人的旅行(单源最短路SPFA)
  6. pragma伪指令
  7. 编译安装-Percona 5.6
  8. 【trim()】去掉字符串开头和结尾的空格,防止不必要的空格导致的错误。
  9. 2013年10月13日学习:SQL通过图形化界面创建表
  10. (转) 谈C/C++指针精髓
  11. .Net MVC 入门之Razor语法
  12. NYNU_省赛选拔题(8)
  13. Git安装配置,和使用的简介
  14. CentOS 7下简单的Ansible使用入门
  15. 遍历所有子物体中renderer(渲染器)中的material(材质)并改变其alpha值实现若隐若现的效果
  16. Le Chapitre I
  17. 牛客网——E求最值
  18. eclipse 设置打开java文件代码自动折叠
  19. SQL 触发器的缺点 坏处 弊端 哼╭(╯^╰)╮
  20. python学习笔记(二)python基础知识(交作业)

热门文章

  1. Sublime Text 3配置与vim模式(待完整)
  2. 46. Permutations
  3. JDBC学习总结(二)
  4. 开发板挂载nfs服务器错误解析
  5. redis sentinel 配置
  6. ExtJs自学教程(1):一切从API开始
  7. 注意:C++中double的表示是有误差的
  8. hdu 4143 A Simple Problem (变形)
  9. bzoj2482
  10. C#4.0新特性(3):变性 Variance(逆变与协变)