Antenna Placement
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 7011   Accepted: 3478

Description

The Global Aerial Research Centre has been allotted the task of building the fifth generation of mobile phone nets in Sweden. The most striking reason why they got the job, is their discovery of a new, highly noise resistant, antenna. It is called 4DAir, and
comes in four types. Each type can only transmit and receive signals in a direction aligned with a (slightly skewed) latitudinal and longitudinal grid, because of the interacting electromagnetic field of the earth. The four types correspond to antennas operating
in the directions north, west, south, and east, respectively. Below is an example picture of places of interest, depicted by twelve small rings, and nine 4DAir antennas depicted by ellipses covering them. 

 

Obviously, it is desirable to use as few antennas as possible, but still provide coverage for each place of interest. We model the problem as follows: Let A be a rectangular matrix describing the surface of Sweden, where an entry of A either is a point of interest,
which must be covered by at least one antenna, or empty space. Antennas can only be positioned at an entry in A. When an antenna is placed at row r and column c, this entry is considered covered, but also one of the neighbouring entries (c+1,r),(c,r+1),(c-1,r),
or (c,r-1), is covered depending on the type chosen for this particular antenna. What is the least number of antennas for which there exists a placement in A such that all points of interest are covered?

Input

On the first row of input is a single positive integer n, specifying the number of scenarios that follow. Each scenario begins with a row containing two positive integers h and w, with 1 <= h <= 40 and 0 < w <= 10. Thereafter is a matrix presented, describing
the points of interest in Sweden in the form of h lines, each containing w characters from the set ['*','o']. A '*'-character symbolises a point of interest, whereas a 'o'-character represents open space. 


Output

For each scenario, output the minimum number of antennas necessary to cover all '*'-entries in the scenario's matrix, on a row of its own.

Sample Input

2
7 9
ooo**oooo
**oo*ooo*
o*oo**o**
ooooooooo
*******oo
o*o*oo*oo
*******oo
10 1
*
*
*
o
*
*
*
*
*
*

Sample Output

17
5

Source

field=source&key=Svenskt+M%C3%A4sterskap+i+Programmering%2FNorgesmesterskapet+2001" style="text-decoration:none">Svenskt Mästerskap i
Programmering/Norgesmesterskapet 2001

ac代码

#include<stdio.h>
#include<string.h>
int map[1010][1010],cut[1010][1010];
int link[101000],vis[101000],x,y,cnt;
char str[1010][1010];
int dfs(int u)
{
int i;
for(i=1;i<=cnt;i++)
{
if(!vis[i]&&map[u][i])
{
vis[i]=1;
if(link[i]==-1||dfs(link[i]))
{
link[i]=u;
return 1;
}
}
}
return 0;
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int n,m,i,j;
scanf("%d%d",&n,&m);
for(i=0;i<n;i++)
{
scanf("%s",str[i]);
}
// int x=0
cnt=0;
memset(cut,0,sizeof(cut));
for(i=0;i<n;i++)
{
for(j=0;j<m;j++)
{
if(str[i][j]=='*')
cut[i][j]=++cnt;
}
}
memset(map,0,sizeof(map));
for(i=0;i<n;i++)
{
for(j=0;j<m;j++)
{
if(cut[i][j])
{
if(j>0&&cut[i][j-1])
map[cut[i][j]][cut[i][j-1]]=1;
if(i>0&&cut[i-1][j])
map[cut[i][j]][cut[i-1][j]]=1;
if(j<m-1&&cut[i][j+1])
map[cut[i][j]][cut[i][j+1]]=1;
if(i<n-1&&cut[i+1][j])
map[cut[i][j]][cut[i+1][j]]=1;
}
}
}
memset(link,-1,sizeof(link));
int ans=0;
for(i=1;i<=cnt;i++)
{
memset(vis,0,sizeof(vis));
if(dfs(i))
ans++;
}
printf("%d\n",cnt-ans/2);
}
}

最新文章

  1. codevs 1536 海战
  2. NSOperation的start与main,并发与非并发。
  3. Guacamole之配置Guacamole(五)
  4. 使用AWT组件实现验证码功能
  5. Encapsulating Data
  6. 《linux源代码包的编译安装》RHEL6
  7. 【HDOJ】3071 Gcd &amp; Lcm game
  8. 在ASP.NET中ShowModalDialog+ztree的使用
  9. c#读取进程列表判断程序是否已经启动(转)
  10. Objective-C学习篇10—NSDate与NSDateFormatter
  11. C#在outlook里创建一封邮件到草稿箱
  12. asp.net动态添加控件学习
  13. JavaScript数据类型 正则表达式RegExp类型
  14. vim matchit 自定义配对关键字之间的跳转
  15. JSON数据从MongoDB迁移到MaxCompute最佳实践
  16. ARMV7-M数据手册---Part B :System Level Architecture---B3 System Address Map
  17. STM32L476应用开发之八:便携式气体分析仪项目总结
  18. Python的浮点数损失精度问题
  19. hadoop-2
  20. c#引用命名空间的作用

热门文章

  1. C#之调用存储过程
  2. Rabbit--ack机制
  3. Xcode控制台输出中文
  4. C# 多线程系列(一)
  5. bootstrap 图片 图标
  6. js-事件处理(重点)
  7. js邮箱正则表达式的使用
  8. dubbo之隐式参数
  9. ROS和OpenCV的对接cv_bridge
  10. C++多行文本读取