Nico Number


Time Limit: 2 Seconds      Memory Limit: 262144 KB


Kousaka Honoka and Minami Kotori are playing a game about a secret of Yazawa Nico.

When the game starts, Kousaka Honoka will
give Minami Kotori an array A of N non-negative
integers. There is a special kind of number in the array, which is called NicoNico-number.
We call a integer x is a NicoNico-number,
if all integers(no more than x) that is coprime with x could
form an Arithmetic Sequence.

Then Minami Kotori will
choose some consecutive part of the array A, wondering the number of NicoNico-number in
this part. What's more, Kousaka Honoka sometimes modify the value of some consecutive elements
in the array. Now it is your task to simulate this game!

Input

There are multiple test cases in input, you should process to the end of file.

For each case, the first line is an integer N, the number of elements in the array described above. Then second line contains N integers no greater than 107,
the elements of the array initially.(1 <= N <= 100,000)

The third line is a integer T, the number of the operations of the game. Each line of the following T lines is in one of the following formats.(1 <= T <= 100,000)

"1 L R" : Minami Kotori will chooses the consecutive part of the array from the Lth to Rth element inclusive. (1 <= L <= R <= N)

"2 L R v" : Kousaka Honoka will change the value of the pth element A[p] in the array to A[p]%v for all L <= p <= R.(1 <= L <=
R <= N, 1 <= v <= 107
)

"3 p x" : Kousaka Honoka will change the value of the p th element A[p] to x.(1 <= p <= N, 1 <= x <= 107)

Output

Each time when Minami Kotori chooses some part of the array, you should output a line, the number of NicoNico-number in that part.

Sample Input

3
4 6 9
6
1 1 3
1 3 3
2 1 1 10
1 1 3
3 2 4
1 1 3

Sample Output

2
0
2
2

Hint

4 is a NicoNico-number because only 1 and 3 is coprime with 4 among the integers no greater than 4, and could form an Arithmetic Sequence {1,3}.

题目大意:定义一个NicoNico-number,假设x是NicoNico-number,那么全部小于x的且与x互质的整数是一个等差数列,初始给出n个数字的数组,三种操作:

1 l r 问在[l,r]内有多少个NicoNico-number数

2 l r v 对于[l,r]内的数所有对v取余

3 k x 将第k个数换为x

对每一次询问做出输出。

1、首先写一个找规律的,发现NicoNico-number是有三种组成的第一种是素数,另外一种是2的x次幂,第三种是6

2、那么能够建一个数组。直接标记某个数是不是NicoNico-number

3、使用线段树维护一段区间的NicoNico-number个数,然后能够进行对某一个数的改动,和对一个区间的查询。

对于另外一种操作。我们要知道对于一个数x取余操作。最多会运行log(x)次。由于每次取余至少数值会降低一半。所以对于每一个数来说最多会有log(x)次操作,之后会由于v大于当前值,而不用运行操作。既然取余的次数不多,那么就能够对区域操作进行暴力,维护一段区间的最大值,假设最大值小于v,那么这一段不用更新,否则就遍历的最低层进行取余。

4、对于n个数来说,查找到一个数须要log(n),一个数最多会被改动log(x)次,所以总的时间不会超过n*log(n)*log(x)。

#include <cstdio>
#include <cstring>
#include <queue>
#include <set>
#include <vector>
#include <cmath>
#include <map>
#include <stack>
#include <algorithm>
using namespace std ;
#define LL __int64
#define INF 0x3f3f3f3f
#define PI acos(-1.0)
#define root 1,n,1
#define int_rt int l,int r,int rt
#define lson l,(l+r)/2,rt<<1
#define rson (l+r)/2+1,r,rt<<1|1
const int mod = 1e9+7 ;
const double eqs = 1e-9 ;
int cl[400000] , num[400000] ;
int a[10000005] , check[10000005] ;
int tot ;
void init() {
memset(check,-1,sizeof(check)) ;
tot = 0 ;
for(int i = 2 ; i <= 10000000 ; i++) {
if( check[i] == -1 ){
a[tot++] = i ;
check[i] = 1 ;
}
for(int j = 0 ; j < tot ; j++) {
if( i*a[j] >= 10000000 ) break ;
check[i*a[j]] = 0 ;
if( i%a[j] == 0 ) break ;
}
}
check[0] = check[1] = check[6] = 1 ;
for(int i = 2 ; i <= 10000000 ; i *= 2)
check[i] = 1 ;
}
void push_up(int rt) {
cl[rt] = max(cl[rt<<1],cl[rt<<1|1]) ;
num[rt] = num[rt<<1]+num[rt<<1|1] ;
}
void create(int_rt) {
cl[rt] = num[rt] = 0 ;
if( l == r ) {
scanf("%d", &cl[rt]) ;
if( check[ cl[rt] ] == 1 ) num[rt] = 1 ;
return ;
}
create(lson) ;
create(rson) ;
push_up(rt) ;
}
void update1(int ll,int rr,int v,int_rt) {
if( ll > r || rr < l ) return ;
if( cl[rt] < v ) return ;
if( l == r ) {
cl[rt] %= v ;
if( check[ cl[rt] ] == 1 ) num[rt] = 1 ;
else num[rt] = 0 ;
return ;
}
update1(ll,rr,v,lson) ;
update1(ll,rr,v,rson) ;
push_up(rt) ;
}
void update2(int k,int x,int_rt) {
if( l == r && l == k ) {
cl[rt] = x ;
if( check[ cl[rt] ] == 1 ) num[rt] = 1 ;
else num[rt] = 0 ;
return ;
}
int mid = (l+r)/2 ;
if(k <= mid) update2(k,x,lson) ;
else update2(k,x,rson) ;
push_up(rt) ;
}
int query(int ll,int rr,int_rt) {
if( ll > r || rr < l ) return 0 ;
if( ll <= l && rr >= r ) return num[rt] ;
return query(ll,rr,lson) + query(ll,rr,rson) ;
}
int main() {
int n , m , i , k , l , r , v , x ;
init() ;
while( scanf("%d", &n) !=EOF ) {
create(root) ;
scanf("%d", &m) ;
while( m-- ) {
scanf("%d", &k) ;
if( k == 1 ) {
scanf("%d %d", &l, &r) ;
printf("%d\n", query(l,r,root)) ;
}
else if( k == 2 ) {
scanf("%d %d %d", &l, &r, &v) ;
update1(l,r,v,root) ;
}
else {
scanf("%d %d", &i, &x) ;
update2(i,x,root) ;
}
}
}
return 0 ;
}

最新文章

  1. Html.DropDownLis绑定数据库
  2. 小丁带你走进git世界五-远程仓库
  3. android include进来的组件 调用其子元素
  4. AndroidPn源码分析(一)
  5. KlayGE 4.4中渲染的改进(三):高质量无限地形
  6. hdu 4856 Tunnels (记忆化搜索)
  7. [转]How to insert a row between two rows in an existing excel with HSSF (Apache POI)
  8. 一键制作u盘启动盘教程
  9. 第一个Sprint冲刺第三天
  10. Nginx+FastCGI+C
  11. 通过 struct 成员地址 获取 struct 结构体地址
  12. 正确使用c语言中的头文件
  13. ActiveMQ, RabbitMQ和ZeroMQ 选型关注点
  14. console 高级用法
  15. type=&quot;submit&quot; button的用法
  16. 整理Cocos2d-x 面试题解
  17. 自学Zabbix9.4 zabbix low-level discover底层发现(zabbix批量部署必备)
  18. python + eclipse +pydev
  19. Ubuntu 下matlab 查看memory函数
  20. docker部署PiggyMetrics分布式微服务

热门文章

  1. C99C新增内容
  2. c# 官方文档必看
  3. NPOI导出Excel自动计算公式问题
  4. C#程序集版本控制文件属性祥解
  5. EnforceLearning-主动强化学习
  6. 作业07之《MVC模式》
  7. fiddler抓包 IOS11以上系统
  8. webstorm界面主题
  9. Phpstudy apache2 配置 https
  10. 实现Modbus ASCII多主站应用