/*

Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 89272    Accepted Submission(s): 33796

Problem Description

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input

5

green

red

blue

red

red

3

pink

orange

pink

0

Sample Output

red

pink

Author

WU, Jiazhi

Source

ZJCPC2004 

RecommendGShining   |   We have carefully selected several similar problems for you:  1001 1008 1005 1003 1000


 */

 //字符组灵活运用

#include<stdio.h>

#include<stdlib.h>

#include<string.h>

int main()

{

 int n;

 char s[1001][16];

 int b[1001];

 while(scanf("%d",&n),n)

 {

  int k;

  memset(b,0,sizeof(b));

  for(int i=0;i<n;i++)

  {

   scanf("%s",s[i]);

   for(int j=0;j<=i;j++)

   {

    if(strcmp(s[i],s[j])==0) b[j]++;

   }

     }

     k=0;

     for(int i=1;i<n;i++)

     {

      if(b[k]<b[i]) k=i;

     }

     printf("%s\n",s[k]);

 }

 return 0;

}

最新文章

  1. Hystrix框架3--线程池
  2. android最常用的退出方法
  3. 【英语魔法俱乐部——读书笔记】 3 高级句型-简化从句&amp;倒装句(Reduced Clauses、Inverted Sentences) 【完结】
  4. Hive 的分桶 &amp; Parquet 概念
  5. 使用UIL(Universal-Image-Loader)异步加载图片
  6. Hadoop基础教程之HelloWord
  7. 过拟合(Overfitting)和正规化(Regularization)
  8. [置顶] cocos2dx sqllite 增删查改等操作
  9. HTML5面试题-备
  10. apache----------在apache环境下安装https支持
  11. Markdown指南
  12. jQuery.ajax()调用asp.net后台方法(非常重要)
  13. PHP从入门到精通(三)
  14. IntelliJ IDEA配置Tomcat 与安装Tomcat失败原因
  15. vuex数据持久化存储
  16. [转]搞个这样的 APP 要多久
  17. Orcale11g单机安装与卸载
  18. python之函数的参数
  19. delphi 图像处理 图像放大缩小
  20. 透过汇编另眼看世界之DLL导出函数调用

热门文章

  1. 多任务-进程之进程池Pool
  2. 【转载】02-PowerDesigner的下载及安装
  3. rescan-scsi-bus.sh linux扫盘 脚本
  4. GIT配置多用户
  5. 部署OGG时字符集转换问题--oracle to oracle已验证,其他异构环境应当也适用
  6. Qt 学习之路问题
  7. FPGA静态时序分析——IO口时序(Input Delay /output Delay)
  8. Vue Syntax Highlight
  9. BZOJ 1927 最小费用流问题
  10. SpringMVC学习一:SpringMVC的配置