MZL's chemistry

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 629    Accepted Submission(s): 449

Problem Description
MZL define F(X)
as the first ionization energy of the chemical element
X



Now he get two chemical elements U,V,given
as their atomic number,he wants to compare F(U)
and F(V)



It is guaranteed that atomic numbers belongs to the given set:{1,2,3,4,..18,35,36,53,54,85,86}



It is guaranteed the two atomic numbers is either in the same period or in the same group



It is guaranteed that x≠y
 
Input
There are several test cases



For each test case,there are two numbers u,v,means
the atomic numbers of the two element
 
Output
For each test case,if F(u)>F(v),print
"FIRST BIGGER",else print"SECOND BIGGER"
 
Sample Input
1 2
5 3
 
Sample Output
SECOND BIGGER
FIRST BIGGER
 
Author
SXYZ
 
Source
 
Recommend
wange2014   |   We have carefully selected several similar problems for you:  

pid=5416" target="_blank">5416 

pid=5415" target="_blank">5415 5414 5413 5412 

 

打表

#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#include<functional>
#include<iostream>
#include<cmath>
#include<cctype>
#include<ctime>
using namespace std;
#define For(i,n) for(int i=1;i<=n;i++)
#define Fork(i,k,n) for(int i=k;i<=n;i++)
#define Rep(i,n) for(int i=0;i<n;i++)
#define ForD(i,n) for(int i=n;i;i--)
#define RepD(i,n) for(int i=n;i>=0;i--)
#define Forp(x) for(int p=pre[x];p;p=next[p])
#define Forpiter(x) for(int &p=iter[x];p;p=next[p])
#define Lson (x<<1)
#define Rson ((x<<1)+1)
#define MEM(a) memset(a,0,sizeof(a));
#define MEMI(a) memset(a,127,sizeof(a));
#define MEMi(a) memset(a,128,sizeof(a));
#define INF (2139062143)
#define F (100000007)
#define MAXN (1000000+10)
typedef long long ll;
ll mul(ll a,ll b){return (a*b)%F;}
ll add(ll a,ll b){return (a+b)%F;}
ll sub(ll a,ll b){return (a-b+llabs(a-b)/F*F+F)%F;}
void upd(ll &a,ll b){a=(a%F+b%F)%F;}
int a[24]={1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,35,36,53,54,85,86} ;
double f[24]={1312.0,2372.3,520.2,899.5,800.6,1086.5,1402.3,1313.9,1681,2080.7,495.8,737.7,577.5,786.5,1011.8,999.6,1251.2,1520.6,1139.9,1350.8,1008.4,1170.4,890,1037};
double h[1000];
int main()
{
// freopen("E.in","r",stdin); Rep(i,24) h[a[i]]=f[i]; int u,v;
while (cin>>u>>v)
{
if (h[u]<h[v]) puts("SECOND BIGGER");
else puts("FIRST BIGGER");
} return 0;
}

最新文章

  1. Cinder 调试 - 无法挂载到虚拟机
  2. git修改已提交记录的注释
  3. 使用Jekyll搭建博客
  4. tomcat 解析(四)-处理http请求过程
  5. 《Python基础教程(第二版)》学习笔记 -&gt; 第三章 使用字符串
  6. hdu1272并查集入门
  7. [C入门 - 游戏编程系列] 贪吃蛇篇(五) - 蛇实现
  8. 频繁模式挖掘apriori算法介绍及Java实现
  9. 开始Unity3D参观考察
  10. geotrellis使用(四十)优雅的处理请求超过最大层级数据
  11. jquery实现全选 反选 取消
  12. 搭建Linux下Android程序开发环境
  13. Netty+MUI从零打造一个仿微信的高性能聊天项目,兼容iPhone/iPad/安卓
  14. Jenkins--Credentials添加证书从git上拉代码
  15. Java BIO、NIO、AIO 学习
  16. Java环境变量配置错误
  17. Nginx服务器搭建
  18. 将数据写入TXT文件中,file_put_contents与fwrite
  19. SSH公钥认证(码云)
  20. iOS Base64加密

热门文章

  1. MVC系列学习(十五)-验证码
  2. mysql常用命令介绍
  3. 在CentOS下搭建Android 开发环境
  4. shell编程之grep命令的使用
  5. CSS3:变换和动画
  6. 9-4前端vue面试的问题
  7. css页面布局总结
  8. Luogu P2866 [USACO06NOV]糟糕的一天Bad Hair Day
  9. 【郑轻邀请赛 I】这里是天堂!
  10. Mysql学习总结(41)——MySql数据库基本语句再体会