FatMouse and Cheese

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 4966    Accepted Submission(s): 2035
Problem Description
FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100
blocks of cheese in a hole. Now he's going to enjoy his favorite food.



FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run
at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks
of cheese than those that were at the current hole.



Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.
 
Input
There are several test cases. Each test case consists of



a line containing two integers between 1 and 100: n and k

n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on.

The input ends with a pair of -1's.
 
Output
For each test case output in a line the single integer giving the number of blocks of cheese collected.
 
Sample Input
3 1
1 2 5
10 11 6
12 12 7
-1 -1
 
Sample Output
37
 
Source
 

题意:给定一张N*N的图。每一个格子上有一些豆子,初始位置是(0,0)。每次仅仅能向一个方向走最多m步,然后停下吃掉这个格子上的豆子。但有个限制是当前格子上的豆子必须比之前呆的一个格子里的豆子多。问最多能吃多少豆子。

题解:深搜,dp[i][j]表示从(i,j)点出发最多能吃到的豆子。

#include <stdio.h>
#include <string.h> #define maxn 105 int G[maxn][maxn], n, m;
int dp[maxn][maxn];
const int mov[][2] = {1, 0, -1, 0, 0, 1, 0, -1}; void getMap() {
int i, j;
for(i = 0; i < n; ++i)
for(j = 0; j < n; ++j)
scanf("%d", &G[i][j]);
} int max(int a, int b) {
return a > b ? a : b;
} bool check(int x, int y) {
if(x < 0 || x >= n || y < 0 || y >= n)
return 0;
return 1;
} int DFS(int xx, int yy) {
int i, j, x, y, maxv = 0;
if(dp[xx][yy]) return dp[xx][yy];
for(i = 1; i <= m; ++i) {
for(j = 0; j < 4; ++j) {
x = xx + mov[j][0] * i;
y = yy + mov[j][1] * i;
if(check(x, y) && G[x][y] > G[xx][yy])
maxv = max(maxv, DFS(x, y));
}
}
return dp[xx][yy] = maxv + G[xx][yy];
} void solve() {
int i, j;
memset(dp, 0, sizeof(dp));
printf("%d\n", DFS(0, 0));
} int main() {
// freopen("stdin.txt", "r", stdin);
while(scanf("%d%d", &n, &m), n > 0) {
getMap();
solve();
}
return 0;
}

版权声明:本文博主原创文章。博客,未经同意不得转载。

最新文章

  1. Response.End抛出ThreadAbortException 异常
  2. Spring使用ThreadLocal技术来处理这些问题
  3. 一张图片说明MII
  4. 用RxJava处理嵌套请求
  5. 【poj3241】 Object Clustering
  6. Linear regression with multiple variables(多特征的线型回归)算法实例_梯度下降解法(Gradient DesentMulti)以及正规方程解法(Normal Equation)
  7. Linux强制访问控制机制模块分析之mls_type.h
  8. [译]开始学习webpack
  9. mysql中 case when的使用
  10. 理解C++ lvalue与rvalue
  11. 利用document的readyState去实现页面加载中的效果
  12. PAT 1002. A+B for Polynomials
  13. laravel+阿里大于实现发送验证码短信
  14. JavaScript中JSON对象和JSON字符串的相互转化
  15. 代理(Proxy)模式 ,桥梁(Bridge)模式
  16. 如何加固linux NFS 服务安全的方法
  17. tomcat报错相关问题
  18. PS-点击选中某一个图层
  19. 【NotePad++】使用指南
  20. 【转】Leader-Follower线程模型

热门文章

  1. 如何在Win8/Win10上开启 dotNetFramework 2.0/3.5 功能
  2. 程序猿必备软件转载自 www.uhdesk.com
  3. css3-13 css3的3D动画如何实现
  4. get_slave_status.py
  5. 关于右移和除法的关系 , ADC采集电量 ,ADC采集MIC(麦克风)
  6. 数据类型总结——String(字符串类型)
  7. 线上java排查
  8. [React] Use React.cloneElement to Extend Functionality of Children Components
  9. 细说Oracle中NULL值
  10. PatentTips - Heterogeneous Parallel Primitives Programming Model